Bitcoin Forum
January 21, 2020, 07:47:40 AM *
News: Latest Bitcoin Core release: 0.19.0.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 [28] 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 »
  Print  
Author Topic: Building headless Bitcoin and Bitcoin-qt on Windows  (Read 418025 times)
old c coder
Sr. Member
****
Offline Offline

Activity: 260
Merit: 250



View Profile WWW
April 18, 2014, 06:04:28 AM
 #541

Quote
What's interesting is that the compiler "warnings" about the bad C++ slang that is being used, as opposed to the preferred slang, i.e. the highly idiomatic, baroque (as Knuth calls it) nature of C++, can be controlled in MSVC++ and one can "see" more clearly what is "going on".  The thought is that this should lead to more understanding, but so far, the answers given are swamped by the questions that now appear!  Which is why you haven't heard from me (yet) on the Windows MSVC2005 version of bitcoind.  I have a "debug" version of bitcoind 0.8.6 that "appears to" run correctly.  And yes, Claire123 has a MSVC2012 version of bitcoind (& bitcoin-qt), but do our versions work correctly?  Do we have 'release' versions?  I am hoping to "GitHub" commit-pull request my MSVC "additions" to the bitcoind sources soon, but only when I feel that the code runs reliably. 
...
Ron

Hello all,

Well I do now! Grin  See https://github.com/bc4-old-c-coder/bitcoin/commit/f0d221e56a12947b67b9c8f43cc5832b665052c8

I feel pretty confident in it.  Release & debug modes, links with OpenSSL1.0.1g, and so on...
Here it is running at startup


Ron


LTC: LUYiMVsrFQewUSPDasSKGzhyTPAkiTeSov BTC: 1DPvP6WoZzaNQ9Nxzd64hjYad1kyQzTTbx YAC: Y3ZggXDvnRJaRwtVGyGJwt6DMLN3EPQpQf 
The day is coming when a single carrot, freshly observed, will set off a revolution.  Paul Cezanne
1579592860
Hero Member
*
Offline Offline

Posts: 1579592860

View Profile Personal Message (Offline)

Ignore
1579592860
Reply with quote  #2

1579592860
Report to moderator
1579592860
Hero Member
*
Offline Offline

Posts: 1579592860

View Profile Personal Message (Offline)

Ignore
1579592860
Reply with quote  #2

1579592860
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1579592860
Hero Member
*
Offline Offline

Posts: 1579592860

View Profile Personal Message (Offline)

Ignore
1579592860
Reply with quote  #2

1579592860
Report to moderator
1579592860
Hero Member
*
Offline Offline

Posts: 1579592860

View Profile Personal Message (Offline)

Ignore
1579592860
Reply with quote  #2

1579592860
Report to moderator
tweminer
Newbie
*
Offline Offline

Activity: 56
Merit: 0


View Profile
April 18, 2014, 03:19:32 PM
Last edit: April 18, 2014, 03:30:50 PM by tweminer
 #542

please help
http://tryimg.com/thumbs/edgd.jpg
i try compile bitcoind got that error
http://tryimg.com/thumbs/error.jpg
and i try this
From a windows command prompt configure and make:
Code:
set PATH=%PATH%;C:\Qt\4.8.5\bin
cd C:\qcoin\
qmake "USE_QRCODE=1" "USE_UPNP=1" "USE_IPV6=1" qcoin-qt.pro
got that error
old c coder
Sr. Member
****
Offline Offline

Activity: 260
Merit: 250



View Profile WWW
April 18, 2014, 05:08:03 PM
 #543

Hello all (again)

MSVC++ bitcoind version 0.8.6 sources are at
https://github.com/bc4-old-c-coder/bitcoin/archive/0.8.6.zip
from
https://github.com/bc4-old-c-coder/bitcoin/tree/0.8.6
from
https://github.com/bc4-old-c-coder/bitcoin/commit/f0d221e56a12947b67b9c8f43cc5832b665052c8
which was given in message #550.

The same info is also at
https://bitcointalk.org/index.php?topic=349094.msg6284139#msg6284139

Ron


LTC: LUYiMVsrFQewUSPDasSKGzhyTPAkiTeSov BTC: 1DPvP6WoZzaNQ9Nxzd64hjYad1kyQzTTbx YAC: Y3ZggXDvnRJaRwtVGyGJwt6DMLN3EPQpQf 
The day is coming when a single carrot, freshly observed, will set off a revolution.  Paul Cezanne
old c coder
Sr. Member
****
Offline Offline

Activity: 260
Merit: 250



View Profile WWW
April 18, 2014, 09:12:48 PM
 #544

please help

i try compile bitcoind got that error

and i try this
From a windows command prompt configure and make:
Code:
set PATH=%PATH%;C:\Qt\4.8.5\bin
cd C:\qcoin\
qmake "USE_QRCODE=1" "USE_UPNP=1" "USE_IPV6=1" qcoin-qt.pro
got that error
Hello tweminer

I don't really understand you, since you haven't asked any questions that I could answer, but I can guess...?

In the first pix, I see that the build you are using is trying to link libmemenv.a and it can't seem to find what it needs.  Perhaps it can't find libleveldb.a or the parts therein, for whatever reason?  You're in a "qcoin" directory, so perhaps you didn't build it?  Or build it correctly?  Or configure your build system to know where to look for it?

In the second pix, I see that C:/Qt/4.8.5/bin\lrelease.exe is not being "seen" by your OS, whatever that is?  Again I see qcoin, whatever that is, and your path being set, so technically lrelease.exe doesn't need a fully qualified path in order for the OS to run it?  I can't see what else is down there past the bottom of your screen, but it might give you some more insight as to what is going on.

Ron


LTC: LUYiMVsrFQewUSPDasSKGzhyTPAkiTeSov BTC: 1DPvP6WoZzaNQ9Nxzd64hjYad1kyQzTTbx YAC: Y3ZggXDvnRJaRwtVGyGJwt6DMLN3EPQpQf 
The day is coming when a single carrot, freshly observed, will set off a revolution.  Paul Cezanne
operezm
Newbie
*
Offline Offline

Activity: 5
Merit: 0


View Profile
April 20, 2014, 12:33:48 AM
Last edit: April 20, 2014, 12:49:31 AM by operezm
 #545

I followed this guide loosely and successfully compiled OpenSSL, BDB and Boost (compiling for the headless version, so no QT, protoc, libpng or qrencode needed). Then I set the appropriate include and library files in the gcc specs file, so that they could be found and ran autogen.sh and configure. All went well and a makefile was generated in the root directory, which I ran. It compiled all modules successfully and then tried to build bitcoind (I believe), outputting:

Code:
Making all in src
make[1]: Entering directory `/i/code/bitcoin_git/bitcoin/src'
make  all-recursive
make[2]: Entering directory `/i/code/bitcoin_git/bitcoin/src'
Making all in .
make[3]: Entering directory `/i/code/bitcoin_git/bitcoin/src'
  CXXLD  bitcoind.exe

This failed however with a host of errors (I included the head only, but I think the problem can be derived from this, as the other errors are very alike):

Code:
libbitcoin_server.a(main.o): In function `CLevelDBBatch':
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.h:25: undefined reference to `leveldb::WriteBatch::WriteBatch()'
libbitcoin_server.a(main.o): In function `~CLevelDBBatch':
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.h:25: undefined reference to `leveldb::WriteBatch::~WriteBatch()'
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.h:25: undefined reference to `leveldb::WriteBatch::~WriteBatch()'
libbitcoin_server.a(leveldbwrapper.o): In function `Z11HandleErrorRKN7leveldb6StatusE':
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.cpp:18: undefined reference to `leveldb::Status::ToString() const'
libbitcoin_server.a(leveldbwrapper.o): In function `ZN15CLevelDBWrapperC2ERKN5boost10filesystem4pathEjbb':
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.cpp:38: undefined reference to `leveldb::Options::Options()'
libbitcoin_server.a(leveldbwrapper.o): In function `GetOptions':
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.cpp:29: undefined reference to `leveldb::Options::Options()'
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.cpp:30: undefined reference to `leveldb::NewLRUCache(unsigned int)'
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.cpp:32: undefined reference to `leveldb::NewBloomFilterPolicy(int)'
libbitcoin_server.a(leveldbwrapper.o): In function `ZN15CLevelDBWrapperC2ERKN5boost10filesystem4pathEjbb':
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.cpp:52: undefined reference to `leveldb::DestroyDB(std::string const&, leveldb::Options const&)'
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.cpp:57: undefined reference to `leveldb::DB::Open(leveldb::Options const&, std::string const&, leveldb::DB**)'
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.cpp:47: undefined reference to `leveldb::Env::Default()'
libbitcoin_server.a(txdb.o): In function `CLevelDBBatch':
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.h:25: undefined reference to `leveldb::WriteBatch::WriteBatch()'
libbitcoin_server.a(txdb.o): In function `Write<char, int>':
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.h:44: undefined reference to `leveldb::WriteBatch::Put(leveldb::Slice const&, leveldb::Slice const&)'
libbitcoin_server.a(txdb.o): In function `~CLevelDBBatch':
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.h:25: undefined reference to `leveldb::WriteBatch::~WriteBatch()'
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.h:25: undefined reference to `leveldb::WriteBatch::~WriteBatch()'
...
...
...

I checked if libleveldb.a and libmemenv.a were available, and they were (located at .../src/leveldb).

Could anyone point me in the right direction?

I followed the instructions to the letter and I'm having this same problem when linking bitcoind.exe.  Does anyone know what I'm missing here?
Jori
Newbie
*
Offline Offline

Activity: 25
Merit: 0


View Profile
April 20, 2014, 09:58:21 AM
Last edit: April 20, 2014, 11:00:57 AM by Jori
 #546

@operezm, I still haven't figured it out. Adding the library and include folders of leveldb in the GCC specs file did not help either.

Could anyone explain the error format to me? It seems confusing.
old c coder
Sr. Member
****
Offline Offline

Activity: 260
Merit: 250



View Profile WWW
April 20, 2014, 03:22:04 PM
 #547

I followed this guide loosely and successfully compiled OpenSSL, BDB and Boost (compiling for the headless version, so no QT, protoc, libpng or qrencode needed). Then I set the appropriate include and library files in the gcc specs file, so that they could be found and ran autogen.sh and configure. All went well and a makefile was generated in the root directory, which I ran. It compiled all modules successfully and then tried to build bitcoind (I believe), outputting:
Code:
Making all in src
make[1]: Entering directory `/i/code/bitcoin_git/bitcoin/src'
make  all-recursive ...
This failed however with a host of errors (I included the head only, but I think the problem can be derived from this, as the other errors are very alike):
Code:
libbitcoin_server.a(main.o): In function `CLevelDBBatch':
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.h:25: undefined reference to `leveldb::WriteBatch::WriteBatch()'
...
libbitcoin_server.a(txdb.o): In function `~CLevelDBBatch':
i:\code\bitcoin_git\bitcoin\src/leveldbwrapper.h:25: undefined reference to `leveldb::WriteBatch::~WriteBatch()'
...
I checked if libleveldb.a and libmemenv.a were available, and they were (located at .../src/leveldb).

Could anyone point me in the right direction?
I followed the instructions to the letter and I'm having this same problem when linking bitcoind.exe.  Does anyone know what I'm missing here?

Hello operezm,

It looks like the linker-loader in gcc, is not finding the library libleveldb.a  So even though you built it, did gcc see a line like
-L"$(CURDIR)/leveldb" \ where $(CURDIR) is correct at the moment of linking?  I just took that line from nitrogenetics message #1 here
https://bitcointalk.org/index.php?topic=149479.0
in this forum, in the section Additional notes for Bitcoin 0.8.6

You get points for not being on drive c Grin

Ron


LTC: LUYiMVsrFQewUSPDasSKGzhyTPAkiTeSov BTC: 1DPvP6WoZzaNQ9Nxzd64hjYad1kyQzTTbx YAC: Y3ZggXDvnRJaRwtVGyGJwt6DMLN3EPQpQf 
The day is coming when a single carrot, freshly observed, will set off a revolution.  Paul Cezanne
operezm
Newbie
*
Offline Offline

Activity: 5
Merit: 0


View Profile
April 20, 2014, 09:45:15 PM
 #548

@operezm, I still haven't figured it out. Adding the library and include folders of leveldb in the GCC specs file did not help either.

Could anyone explain the error format to me? It seems confusing.

Hi Jori,

I ended up deploying a fresh Win7 Pro 32bit Virtual Machine, followed the OP instructions to the letter and I was able to link it properly this time. 

Jori
Newbie
*
Offline Offline

Activity: 25
Merit: 0


View Profile
April 21, 2014, 12:33:34 PM
 #549


Hello operezm,

It looks like the linker-loader in gcc, is not finding the library libleveldb.a  So even though you built it, did gcc see a line like
-L"$(CURDIR)/leveldb" \ where $(CURDIR) is correct at the moment of linking?  I just took that line from nitrogenetics message #1 here
https://bitcointalk.org/index.php?topic=149479.0
in this forum, in the section Additional notes for Bitcoin 0.8.6

You get points for not being on drive c Grin

Ron

Haha, that my post, so thanks for the points.

It is impossible that gcc is not able to find the library, because I explicitly linked it in the specs file.

I'm not following OP's instructions to the letter because they are confusing and lack detail (I do admire the initiative, but I'm not going to run any command or install every program just because someone on the internet says so). There are also some errors in the post (you do not need to install perl for example, because it comes already with every MSYS or Git install).

I also wonder why he is talking about a makefile.mingw and how to patch it, because I can't find it.

All help is appreciated.

Jori.
Jori
Newbie
*
Offline Offline

Activity: 25
Merit: 0


View Profile
April 21, 2014, 02:25:21 PM
 #550

Traverse to: $BOOSTDIR/tools/build/v2/engine/build.bat

What do you mean exactly?
old c coder
Sr. Member
****
Offline Offline

Activity: 260
Merit: 250



View Profile WWW
April 21, 2014, 07:22:53 PM
 #551

...
You get points for not being on drive c Grin

Ron
Haha, that my post, so thanks for the points.

It is impossible that gcc is not able to find the library, because I explicitly linked it in the specs file.
Nothing is impossible in computer science!
Quote
I'm not following OP's
Who's OP and where are his/her instructions?
Quote
instructions to the letter because they are confusing and lack detail (I do admire the initiative, but I'm not going to run any command or install every program just because someone on the internet says so).
Bravo.  Me too.
Quote
There are also some errors in the post (you do not need to install perl for example, because it comes already with every MSYS or Git install).
Apparantly not all perl's are alike, at least as far as Qt or perhaps qmake are concerned!?  Seems like way too much install baggage required to do a lowly compile for Windows
Quote
I also wonder why he is talking about a makefile.mingw and how to patch it, because I can't find it.
makefile.mingw is(was) the makefile used to create bitcoind.exe before the changeover to autogen, which happened between versions 0.8.6 & 0.9.0
Quote
All help is appreciated.

Jori.
Hello Jori,

A lot of "digital water" has flowed under the makefile "bridge" since nitrogenetics message # 1 in this forum! See
https://bitcointalk.org/index.php?topic=149479.msg1587734#msg1587734
He has updated that message many times since the original March 05, 2013 message.  I saved the original and still refer to it. Wink  And since it has been updated, the comments back and forth about it, in this forum, may not seem to make sense, since they (the comments) refer to an original message # 1 that you cannot see. Sad

But there are timeless comments (ahem!) on the art of compiling-linking software that should guide one to a working .exe file.  See messages # 45 (page 3), 68 & 75 (page 4), 85 (page 5), 102 (page 6) and bypassing all the bending over backwards that gcc qmake and makefile must do to run on or target Windows, message # 550 & 552 (page 28).  These last two answer all the issues I posed in message # 85 on July 13, 2013.  It's a fait accompli since I have now built working versions of 3 other *coind.exe's and bitcoind.exe (YACoind.exe, Auroracoind.exe and Maxcoind.exe) all on MSVC++ Express all using the same four static multi-threaded libraries: Boost 1.53, OpenSSL 1.0.1g (!), Berkeley DB 4.8.30 and levelDB 1.13.  It's pretty much build it (the libraries) and forget it.  Also it's very easy to swap out a library.  For example swapping out OpenSSL 1.0.1g for 1.0.1e or 1.0.1c was pretty much a no brainer.  Same for flavors of Boost.  Is 1.54 or 1.55 better than 1.53? Is level DB 1.16 better than 1.15, 1.13, 1.12 as far as bitcoin is concerned?  On Windows? 

Getting off the soapbox and high horse now... and going back to the nose to the grindstone, salt mine, dungeon...  Actually, to making the "how to build the libraries" video series for MSVC++.  Imagine a video game walk through Grin  GUI manipulation is much easier to understand by seeing rather than reading "how to".

Ron



LTC: LUYiMVsrFQewUSPDasSKGzhyTPAkiTeSov BTC: 1DPvP6WoZzaNQ9Nxzd64hjYad1kyQzTTbx YAC: Y3ZggXDvnRJaRwtVGyGJwt6DMLN3EPQpQf 
The day is coming when a single carrot, freshly observed, will set off a revolution.  Paul Cezanne
microlost
Newbie
*
Offline Offline

Activity: 44
Merit: 0


View Profile
April 22, 2014, 02:39:35 AM
 #552

I have got an error like this in step2.6:
configure: error: zlib not installed.

who can tell me where can find and how to install zlib.
Jori
Newbie
*
Offline Offline

Activity: 25
Merit: 0


View Profile
April 22, 2014, 09:29:06 AM
 #553

Quote
Quote
...
Hello Jori,

A lot of "digital water" has flowed under the makefile "bridge" since nitrogenetics message # 1 in this forum! See
https://bitcointalk.org/index.php?topic=149479.msg1587734#msg1587734
He has updated that message many times since the original March 05, 2013 message.  I saved the original and still refer to it. Wink  And since it has been updated, the comments back and forth about it, in this forum, may not seem to make sense, since they (the comments) refer to an original message # 1 that you cannot see. Sad

But there are timeless comments (ahem!) on the art of compiling-linking software that should guide one to a working .exe file.  See messages # 45 (page 3), 68 & 75 (page 4), 85 (page 5), 102 (page 6) and bypassing all the bending over backwards that gcc qmake and makefile must do to run on or target Windows, message # 550 & 552 (page 28).  These last two answer all the issues I posed in message # 85 on July 13, 2013.  It's a fait accompli since I have now built working versions of 3 other *coind.exe's and bitcoind.exe (YACoind.exe, Auroracoind.exe and Maxcoind.exe) all on MSVC++ Express all using the same four static multi-threaded libraries: Boost 1.53, OpenSSL 1.0.1g (!), Berkeley DB 4.8.30 and levelDB 1.13.  It's pretty much build it (the libraries) and forget it.  Also it's very easy to swap out a library.  For example swapping out OpenSSL 1.0.1g for 1.0.1e or 1.0.1c was pretty much a no brainer.  Same for flavors of Boost.  Is 1.54 or 1.55 better than 1.53? Is level DB 1.16 better than 1.15, 1.13, 1.12 as far as bitcoin is concerned?  On Windows? 

Getting off the soapbox and high horse now... and going back to the nose to the grindstone, salt mine, dungeon...  Actually, to making the "how to build the libraries" video series for MSVC++.  Imagine a video game walk through Grin  GUI manipulation is much easier to understand by seeing rather than reading "how to".

Ron

Hi Ron,

OP = Original Poster and I was referring to nitrogenetics original message (post #1).

I really appreciate your time and help, but I did not find anything similar to the problems I'm having (i.e. libleveldb.a and libmemenv.a are available but do not get linked).

One thing I thought of yesterday: maybe the files were compiled and archived successfully, but do not contain all necessary content. It could be that while making leveldb, some essential files for bitcoin were skipped. Running ar tv libmemenv.a and ar tv libleveldb.a reveals:

Code:
rw-rw-rw- 0/0 432255 Apr 15 16:56 2014 memenv.o

and

Code:
rw-rw-rw- 0/0  21322 Apr 15 16:56 2014 port_win.o

respectively. Could you verify if you have similar output?

Thanks in advance,
Jori.
microlost
Newbie
*
Offline Offline

Activity: 44
Merit: 0


View Profile
April 22, 2014, 02:36:15 PM
 #554

step3 got an error:

$ ./autogen.sh
./autogen.sh: line 5: autoreconf: command not found

and the configure,return:

sh: ./configure: No such file or directory

old c coder
Sr. Member
****
Offline Offline

Activity: 260
Merit: 250



View Profile WWW
April 22, 2014, 02:55:12 PM
 #555

Quote
Quote
...
Hello Jori,

A lot of "digital water" has flowed under the makefile "bridge" since nitrogenetics message # 1 in this forum! See
https://bitcointalk.org/index.php?topic=149479.msg1587734#msg1587734
He has updated that message many times since the original March 05, 2013 message.  I saved the original and still refer to it. Wink  And since it has been updated, the comments back and forth about it, in this forum, may not seem to make sense, since they (the comments) refer to an original message # 1 that you cannot see. Sad

But there are timeless comments (ahem!) on the art of compiling-linking software that should guide one to a working .exe file.  See messages # 45 (page 3), 68 & 75 (page 4), 85 (page 5), 102 (page 6) and bypassing all the bending over backwards that gcc qmake and makefile must do to run on or target Windows, message # 550 & 552 (page 28).  These last two answer all the issues I posed in message # 85 on July 13, 2013.  It's a fait accompli since I have now built working versions of 3 other *coind.exe's and bitcoind.exe (YACoind.exe, Auroracoind.exe and Maxcoind.exe) all on MSVC++ Express all using the same four static multi-threaded libraries: Boost 1.53, OpenSSL 1.0.1g (!), Berkeley DB 4.8.30 and levelDB 1.13.  It's pretty much build it (the libraries) and forget it.  Also it's very easy to swap out a library.  For example swapping out OpenSSL 1.0.1g for 1.0.1e or 1.0.1c was pretty much a no brainer.  Same for flavors of Boost.  Is 1.54 or 1.55 better than 1.53? Is level DB 1.16 better than 1.15, 1.13, 1.12 as far as bitcoin is concerned?  On Windows? 

Getting off the soapbox and high horse now... and going back to the nose to the grindstone, salt mine, dungeon...  Actually, to making the "how to build the libraries" video series for MSVC++.  Imagine a video game walk through Grin  GUI manipulation is much easier to understand by seeing rather than reading "how to".

Ron

Hi Ron,

OP = Original Poster and I was referring to nitrogenetics original message (post #1).

I really appreciate your time and help, but I did not find anything similar to the problems I'm having (i.e. libleveldb.a and libmemenv.a are available but do not get linked).

One thing I thought of yesterday: maybe the files were compiled and archived successfully, but do not contain all necessary content. It could be that while making leveldb, some essential files for bitcoin were skipped. Running ar tv libmemenv.a and ar tv libleveldb.a reveals:

Code:
rw-rw-rw- 0/0 432255 Apr 15 16:56 2014 memenv.o

and

Code:
rw-rw-rw- 0/0  21322 Apr 15 16:56 2014 port_win.o

respectively. Could you verify if you have similar output?

Thanks in advance,
Jori.
Hello Jori,

When I last built levelDB for gcc bitcoin building, it was last July it seems and my output is:
Code:
...c\leveldb  9:42:14.73 >ar tv libmemenv.a
rw-rw-rw- 0/0  33085 Jul 01 16:04 2013 memenv.o

...c\leveldb  9:42:44.03 >ar tv libleveldb.a
rw-rw-rw- 0/0   4119 Jul 01 16:04 2013 builder.o
rw-rw-rw- 0/0  26496 Jul 01 16:04 2013 c.o
rw-rw-rw- 0/0 104625 Mar 12 13:14 2014 db_impl.o
rw-rw-rw- 0/0  10257 Jul 01 16:04 2013 db_iter.o
rw-rw-rw- 0/0  10402 Jul 01 16:04 2013 dbformat.o
rw-rw-rw- 0/0   6155 Jul 01 16:04 2013 filename.o
rw-rw-rw- 0/0   6827 Jul 01 16:04 2013 log_reader.o
rw-rw-rw- 0/0   3044 Jul 01 16:04 2013 log_writer.o
rw-rw-rw- 0/0  15096 Jul 01 16:04 2013 memtable.o
rw-rw-rw- 0/0  45012 Jul 01 16:04 2013 repair.o
rw-rw-rw- 0/0   5934 Mar 11 11:57 2014 table_cache.o
rw-rw-rw- 0/0  21177 Jul 01 16:04 2013 version_edit.o
rw-rw-rw- 0/0  97689 Jul 01 16:04 2013 version_set.o
rw-rw-rw- 0/0   7759 Jul 01 16:04 2013 write_batch.o
rw-rw-rw- 0/0  15021 Jul 01 16:04 2013 block.o
rw-rw-rw- 0/0   3788 Jul 01 16:04 2013 block_builder.o
rw-rw-rw- 0/0   6070 Jul 01 16:04 2013 filter_block.o
rw-rw-rw- 0/0   4500 Jul 01 16:04 2013 format.o
rw-rw-rw- 0/0   4944 Jul 01 16:04 2013 iterator.o
rw-rw-rw- 0/0   6462 Jul 01 16:04 2013 merger.o
rw-rw-rw- 0/0   9652 Jul 01 16:04 2013 table.o
rw-rw-rw- 0/0  11333 Jul 01 16:04 2013 table_builder.o
rw-rw-rw- 0/0   7157 Jul 01 16:04 2013 two_level_iterator.o
rw-rw-rw- 0/0   2724 Jul 01 16:04 2013 arena.o
rw-rw-rw- 0/0   3500 Jul 01 16:04 2013 bloom.o
rw-rw-rw- 0/0   7497 Jul 01 16:04 2013 cache.o
rw-rw-rw- 0/0   3422 Jul 01 16:04 2013 coding.o
rw-rw-rw- 0/0   4748 Jul 01 16:04 2013 comparator.o
rw-rw-rw- 0/0   5503 Jul 01 16:04 2013 crc32c.o
rw-rw-rw- 0/0  20556 Jul 01 16:04 2013 env.o
rw-rw-rw- 0/0    288 Jul 01 16:04 2013 env_posix.o
rw-rw-rw- 0/0  48635 Jul 01 16:04 2013 env_win.o
rw-rw-rw- 0/0   1540 Jul 01 16:04 2013 filter_policy.o
rw-rw-rw- 0/0    770 Jul 01 16:04 2013 hash.o
rw-rw-rw- 0/0   4853 Jul 01 16:04 2013 histogram.o
rw-rw-rw- 0/0   2545 Jul 01 16:04 2013 logging.o
rw-rw-rw- 0/0    772 Jul 01 16:04 2013 options.o
rw-rw-rw- 0/0   2511 Jul 01 16:04 2013 status.o
rw-rw-rw- 0/0   4087 Jul 01 16:04 2013 port_win.o

"Alas, poor Jori! I knew him, levelDB; a library of infinite jest..."
So I would say that something is amiss with your levelDB library build.

Ron


LTC: LUYiMVsrFQewUSPDasSKGzhyTPAkiTeSov BTC: 1DPvP6WoZzaNQ9Nxzd64hjYad1kyQzTTbx YAC: Y3ZggXDvnRJaRwtVGyGJwt6DMLN3EPQpQf 
The day is coming when a single carrot, freshly observed, will set off a revolution.  Paul Cezanne
Jori
Newbie
*
Offline Offline

Activity: 25
Merit: 0


View Profile
April 22, 2014, 05:35:34 PM
 #556

Hi Ron,

After being set on a trail by your ar tv output, I finally found the sinister thing that was causing all the trouble, which no sane soul could have figured out (yes I'm insane). In the file that is generating the platform specific parameters for the building of leveldb (build_detect_platform), I found the following line that searches for the files to be compiled:

Code:
PORTABLE_FILES=`find $DIRS $PRUNE_TEST -o $PRUNE_BENCH -o $PRUNE_TOOL -o -name '*.cc' -print | sort | sed "s,^$PREFIX/,," | tr "\n" " "`

I immediately realized that Windows too has a find.exe and that the PATH variable on Windows starts with the system directories, like system32 where find.exe is located. Putting my MSYS bin directory ahead of the system32 directory solved it. I was now able to compile and archive all necessary files and get similar output as you for ar tv. After that, bitcoind compiled with no problems.

Thanks a lot Ron for your help here, and I hope to see you soon in some other thread  Smiley!

Jori.
Jori
Newbie
*
Offline Offline

Activity: 25
Merit: 0


View Profile
April 22, 2014, 06:35:12 PM
 #557

step3 got an error:

$ ./autogen.sh
./autogen.sh: line 5: autoreconf: command not found

and the configure,return:

sh: ./configure: No such file or directory



Have you installed the following packages correctly?

Quote
msys-base-bin
msys-autoconf-bin
msys-automake-bin
msys-libtool-bin
Jori
Newbie
*
Offline Offline

Activity: 25
Merit: 0


View Profile
April 23, 2014, 12:54:40 PM
 #558

Hoping someone can help out. Also hoping that its something very simple and ive just been staring at it too long Smiley
I get stuck on 2.6.  /qren . When i try to run config it goes about it's checklists. Finds :
Checking wether c compiler works... no.... and stops

http://s7.postimg.org/a4k5rtekb/ccompiler.png

output on config.log =

Code:
configure:3233: $? = 0
configure:3222: gcc -v >&5
Using built-in specs.
COLLECT_GCC=c:\mingw32\bin\gcc.exe
COLLECT_LTO_WRAPPER=c:/mingw32/bin/../libexec/gcc/i686-w64-mingw32/4.8.2/lto-wrapper.exe
Target: i686-w64-mingw32
Configured with: ../../../src/gcc-4.8.2/configure --host=i686-w64-mingw32 --build=i686-w64-mingw32 --target=i686-w64-mingw32 --prefix=/mingw32 --with-sysroot=/c/mingw482/i686-482-posix-dwarf-rt_v3-rev3/mingw32 --with-gxx-include-dir=/mingw32/i686-w64-mingw32/include/c++ --enable-shared --enable-static --disable-multilib --enable-languages=ada,c,c++,fortran,objc,obj-c++,lto --enable-libstdcxx-time=yes --enable-threads=posix --enable-libgomp --enable-libatomic --enable-lto --enable-graphite --enable-checking=release --enable-fully-dynamic-string --enable-version-specific-runtime-libs --disable-sjlj-exceptions --with-dwarf2 --disable-isl-version-check --disable-cloog-version-check --disable-libstdcxx-pch --disable-libstdcxx-debug --enable-bootstrap --disable-rpath --disable-win32-registry --disable-nls --disable-werror --disable-symvers --with-gnu-as --with-gnu-ld --with-arch=i686 --with-tune=generic --with-libiconv --with-system-zlib --with-gmp=/c/mingw482/prerequisites/i686-w64-mingw32-static --with-mpfr=/c/mingw482/prerequisites/i686-w64-mingw32-static --with-mpc=/c/mingw482/prerequisites/i686-w64-mingw32-static --with-isl=/c/mingw482/prerequisites/i686-w64-mingw32-static --with-cloog=/c/mingw482/prerequisites/i686-w64-mingw32-static --enable-cloog-backend=isl --with-pkgversion='i686-posix-dwarf-rev3, Built by MinGW-W64 project' --with-bugurl=http://sourceforge.net/projects/mingw-w64 CFLAGS='-O2 -pipe -I/c/mingw482/i686-482-posix-dwarf-rt_v3-rev3/mingw32/opt/include -I/c/mingw482/prerequisites/i686-zlib-static/include -I/c/mingw482/prerequisites/i686-w64-mingw32-static/include' CXXFLAGS='-O2 -pipe -I/c/mingw482/i686-482-posix-dwarf-rt_v3-rev3/mingw32/opt/include -I/c/mingw482/prerequisites/i686-zlib-static/include -I/c/mingw482/prerequisites/i686-w64-mingw32-static/include' CPPFLAGS= LDFLAGS='-pipe -L/c/mingw482/i686-482-posix-dwarf-rt_v3-rev3/mingw32/opt/lib -L/c/mingw482/prerequisites/i686-zlib-static/lib -L/c/mingw482/prerequisites/i686-w64-mingw32-static/lib -Wl,--large-address-aware'
Thread model: posix
gcc version 4.8.2 (i686-posix-dwarf-rev3, Built by MinGW-W64 project)
configure:3233: $? = 0
configure:3222: gcc -V >&5
gcc.exe: error: unrecognized command line option '-V'
gcc.exe: fatal error: no input files
compilation terminated.
configure:3233: $? = 1
configure:3222: gcc -qversion >&5
gcc.exe: error: unrecognized command line option '-qversion'
gcc.exe: fatal error: no input files
compilation terminated.
configure:3233: $? = 1
configure:3253: checking whether the C compiler works
configure:3275: gcc    conftest.c ../libpng-1.6.9/.libs/libpng16a ../../mingw32/i686-w64-mingw32/lib/libz.a >&5
gcc.exe: error: ../libpng-1.6.9/.libs/libpng16a: No such file or directory
configure:3279: $? = 1
configure:3317: result: no
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE_URL ""
| #define MAJOR_VERSION 3
| #define MINOR_VERSION 4
| #define MICRO_VERSION 3
| #define PACKAGE "qrencode"
| #define VERSION "3.4.3"
| /* end confdefs.h.  */
|
| int
| main ()
| {
|
|   ;
|   return 0;
| }
configure:3322: error: in `/c/deps/qrencode-3.4.3':
configure:3324: error: C compiler cannot create executables
See `config.log' for more details

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=i686-pc-mingw32
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=set
ac_cv_env_LIBS_value='../libpng-1.6.9/.libs/libpng16a ../../mingw32/i686-w64-mingw32/lib/libz.a'
ac_cv_env_PKG_CONFIG_LIBDIR_set=
ac_cv_env_PKG_CONFIG_LIBDIR_value=
ac_cv_env_PKG_CONFIG_PATH_set=
ac_cv_env_PKG_CONFIG_PATH_value=
ac_cv_env_PKG_CONFIG_set=
ac_cv_env_PKG_CONFIG_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_png_CFLAGS_set=set
ac_cv_env_png_CFLAGS_value=-I../libgpng-1.6.9/.libs
ac_cv_env_png_LIBS_set=set
ac_cv_env_png_LIBS_value=-L../libpng-1.6.9/.libs
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=i686-pc-mingw32
ac_cv_path_install='/bin/install -c'
ac_cv_path_mkdir=/bin/mkdir
ac_cv_prog_AWK=gawk
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_make_make_set=yes
ac_cv_target=i686-pc-mingw32

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /c/deps/qrencode-3.4.3/use/missing --run aclocal-1.11'
AMDEPBACKSLASH='\'
AMDEP_FALSE='#'
AMDEP_TRUE=''
AMTAR='$${TAR-tar}'
AR=''
AUTOCONF='${SHELL} /c/deps/qrencode-3.4.3/use/missing --run autoconf'
AUTOHEADER='${SHELL} /c/deps/qrencode-3.4.3/use/missing --run autoheader'
AUTOMAKE='${SHELL} /c/deps/qrencode-3.4.3/use/missing --run automake-1.11'
AWK='gawk'
BUILD_TESTS_FALSE=''
BUILD_TESTS_TRUE=''
BUILD_TOOLS_FALSE=''
BUILD_TOOLS_TRUE=''
CC='gcc'
CCDEPMODE=''
CFLAGS=''
CPP=''
CPPFLAGS=''
CYGPATH_W='echo'
DEFS=''
DEPDIR='.deps'
DLLTOOL=''
DSYMUTIL=''
DUMPBIN=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
FGREP=''
GREP=''
HAVE_LIBPTHREAD_FALSE=''
HAVE_LIBPTHREAD_TRUE=''
HAVE_SDL_FALSE=''
HAVE_SDL_TRUE=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='$(install_sh) -c -s'
LD=''
LDFLAGS=''
LIBICONV=''
LIBOBJS=''
LIBPTHREAD=''
LIBS='../libpng-1.6.9/.libs/libpng16a ../../mingw32/i686-w64-mingw32/lib/libz.a'
LIBTOOL=''
LIPO=''
LN_S=''
LTLIBICONV=''
LTLIBOBJS=''
MAJOR_VERSION='3'
MAKEINFO='${SHELL} /c/deps/qrencode-3.4.3/use/missing --run makeinfo'
MANIFEST_TOOL=''
MICRO_VERSION='3'
MINOR_VERSION='4'
MKDIR_P='/bin/mkdir -p'
NM=''
NMEDIT=''
OBJDUMP=''
OBJEXT=''
OTOOL64=''
OTOOL=''
PACKAGE='qrencode'
PACKAGE_BUGREPORT=''
PACKAGE_NAME=''
PACKAGE_STRING=''
PACKAGE_TARNAME=''
PACKAGE_URL=''
PACKAGE_VERSION=''
PATH_SEPARATOR=':'
PKG_CONFIG=''
PKG_CONFIG_LIBDIR=''
PKG_CONFIG_PATH=''
RANLIB=''
SDL_CFLAGS=''
SDL_CONFIG=''
SDL_LIBS=''
SED=''
SET_MAKE=''
SHELL='/bin/sh'
STRIP=''
VERSION='3.4.3'
ac_ct_AR=''
ac_ct_CC='gcc'
ac_ct_DUMPBIN=''
am__EXEEXT_FALSE=''
am__EXEEXT_TRUE=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__include='include'
am__isrc=''
am__leading_dot='.'
am__nodep='_no'
am__quote=''
am__tar='$${TAR-tar} chof - "$$tardir"'
am__untar='$${TAR-tar} xf -'
bindir='${exec_prefix}/bin'
build='i686-pc-mingw32'
build_alias=''
build_cpu='i686'
build_os='mingw32'
build_vendor='pc'
datadir='${datarootdir}'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE}'
dvidir='${docdir}'
exec_prefix='NONE'
host='i686-pc-mingw32'
host_alias=''
host_cpu='i686'
host_os='mingw32'
host_vendor='pc'
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh='${SHELL} /c/deps/qrencode-3.4.3/use/install-sh'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
mandir='${datarootdir}/man'
mkdir_p='/bin/mkdir -p'
oldincludedir='/usr/include'
pdfdir='${docdir}'
png_CFLAGS='-I../libgpng-1.6.9/.libs'
png_LIBS='-L../libpng-1.6.9/.libs'
prefix='NONE'
program_transform_name='s,x,x,'
psdir='${docdir}'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target='i686-pc-mingw32'
target_alias=''
target_cpu='i686'
target_os='mingw32'
target_vendor='pc'

## ----------- ##
## confdefs.h. ##
## ----------- ##

/* confdefs.h */
#define PACKAGE_NAME ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define PACKAGE_STRING ""
#define PACKAGE_BUGREPORT ""
#define PACKAGE_URL ""
#define MAJOR_VERSION 3
#define MINOR_VERSION 4
#define MICRO_VERSION 3
#define PACKAGE "qrencode"
#define VERSION "3.4.3"

configure: exit 77

At this point i really hope i did something stupid.... cause that could mean an easy fix.  Smiley  Thanks in advance for ur help

Look at the following line:
Code:
gcc.exe: error: ../libpng-1.6.9/.libs/libpng16a: No such file or directory
That is the problem. Shouldn't libpng16a be libpng16.a?

Also, please do not use pictures. Just copy the output and format is as a code block. Much easier to copy from  Wink.
meelvanchris
Sr. Member
****
Offline Offline

Activity: 336
Merit: 250



View Profile
April 23, 2014, 12:56:31 PM
 #559


Look at the following line:
Code:
gcc.exe: error: ../libpng-1.6.9/.libs/libpng16a: No such file or directory
That is the problem. Shouldn't libpng16a be libpng16.a?

Yeah it should. Figured that out around same time your were typing prob. But thanks. Altough now im getting erros on the make.... sigh.... to be continued! =)

    ▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄   
   ████████████████████████████████   
     ▀██████████████████████████▀     
        ▀████████████████████▀       
          ████████████████▀         
            █████████████           
            ▀████████████▀           
             ▀██████████▀             
              ██████████             
               ████████               
               ▀██████▀               
                ██████               
                 
.
trade.io.
██████
██████
███
███
███
███
███
███
███
███
███
██████
██████

▄██████████████████▄
███       ▀███████
███       █████████
███       █████████
███       █████████
███              ██
███   ▄▄▄▄▄▄▄▄   ███
███   ▄▄▄▄▄▄▄▄   ███
███              ███
███▄▄▄▄▄▄▄▄▄▄▄▄▄▄███
██████████████████▀

▄██████████████████▄
███████████▀ ███████
█████████▀   ███████
███████▀     ██▀ ███
███ ▀▀       █▄▄████
███          █▀▀▀▀██
███ ▄▄       ███████
██████▄     █▄ ▀███
█████████▄   ███▄███
███████████▄ ███████
▀██████████████████▀

▄██████████████████▄
████████████████████
███████████████▀▀ ██
█████████▀▀     ███
████▀▀     ▄█▀   ███
███▄    ▄██      ███
█████████▀      ▄██
█████████▄     ████
█████████████▄ ▄████
████████████████████
▀██████████████████▀
██████
██████
   ███
   ███
   ███
   ███
   ███
   ███
   ███
   ███
   ███
██████
██████
.
.Join the Trading Revolution.
nitrogenetics
Full Member
***
Offline Offline

Activity: 131
Merit: 104



View Profile
April 23, 2014, 01:23:04 PM
 #560

Have a look at your png_CFLAGS: -I../libgpng-1.6.9/.libs

BTC: 1NWQ4TarCCC7j1XY26KRFFEtLYbPP6S3DH
XRP: rJkbeyRaUYDmcukEyLYVfn56QDM9VhybZG
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 [28] 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!