Bitcoin Forum
July 23, 2018, 08:41:16 AM *
News: Latest stable version of Bitcoin Core: 0.16.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: The filename, directory name, or volume label syntax is incorrect.  (Read 1125 times)
ironsniper
Member
**
Offline Offline

Activity: 92
Merit: 10


View Profile
June 30, 2016, 01:56:32 AM
 #1

i am trying to compile a windows wallet for someone and am getting the following error

Code:
cd C:/coin-master; /bin/sh share/genbuild.sh C:/coin-master/build/build.h
The filename, directory name, or volume label syntax is incorrect.
Makefile.Release:298: recipe for target 'genbuildhook' failed
mingw32-make[1]: *** [genbuildhook] Error 1
mingw32-make[1]: Leaving directory 'C:/coin-master'
makefile:34: recipe for target 'release' failed
mingw32-make: *** [release] Error 2
20:54:44: The process "C:\mingw32\bin\mingw32-make.exe" exited with code 2.
Error while building/deploying project coin (kit: Qt 4.8.6 (4.8.6))
When executing step "Make"

has anyone ever seen this error before and know how to fix it?
"This isn't the kind of software where we can leave so many unresolved bugs that we need a tracker for them." -- Satoshi
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1532335276
Hero Member
*
Offline Offline

Posts: 1532335276

View Profile Personal Message (Offline)

Ignore
1532335276
Reply with quote  #2

1532335276
Report to moderator
1532335276
Hero Member
*
Offline Offline

Posts: 1532335276

View Profile Personal Message (Offline)

Ignore
1532335276
Reply with quote  #2

1532335276
Report to moderator
1532335276
Hero Member
*
Offline Offline

Posts: 1532335276

View Profile Personal Message (Offline)

Ignore
1532335276
Reply with quote  #2

1532335276
Report to moderator
cr1776
Legendary
*
Offline Offline

Activity: 1932
Merit: 1005


View Profile
June 30, 2016, 10:08:16 AM
 #2

"a Windows wallet"? Which one? Version? Windows version?  What version of MinGW is this?
ironsniper
Member
**
Offline Offline

Activity: 92
Merit: 10


View Profile
June 30, 2016, 01:00:09 PM
 #3

"a Windows wallet"? Which one? Version? Windows version?  What version of MinGW is this?
yeah sorry was in a hurry, windows 7 32bit mingw 4.9 and this wallet compiled perfectly under linux and OS X so this error is windows only it seems
mocacinno
Legendary
*
Offline Offline

Activity: 1288
Merit: 1136


http://www.mocacinno.com


View Profile WWW
June 30, 2016, 01:03:10 PM
 #4

"a Windows wallet"? Which one? Version? Windows version?  What version of MinGW is this?
yeah sorry was in a hurry, windows 7 32bit mingw 4.9 and this wallet compiled perfectly under linux and OS X so this error is windows only it seems

It's not the answer to your question (directly), but i usually use gitian if i feel the need to build the bitcoin binaries for windows:
https://github.com/bitcoin/bitcoin/blob/master/doc/gitian-building.md

Seems odd and contra-intuitive to build windows binaries on linux, but i find it a lot easyer to do this than to build on windows directly...

ironsniper
Member
**
Offline Offline

Activity: 92
Merit: 10


View Profile
June 30, 2016, 01:09:00 PM
 #5

"a Windows wallet"? Which one? Version? Windows version?  What version of MinGW is this?
yeah sorry was in a hurry, windows 7 32bit mingw 4.9 and this wallet compiled perfectly under linux and OS X so this error is windows only it seems

It's not the answer to your question (directly), but i usually use gitian if i feel the need to build the bitcoin binaries for windows:
https://github.com/bitcoin/bitcoin/blob/master/doc/gitian-building.md

Seems odd and contra-intuitive to build windows binaries on linux, but i find it a lot easyer to do this than to build on windows directly...
im being perfectly honest, when i first got into compiling wallets i never could get a windows wallet to compile on windows and when i would use gitian it would compile the wallet for linux only, took me a couple of weeks but i got windows compiling figured out
ironsniper
Member
**
Offline Offline

Activity: 92
Merit: 10


View Profile
July 02, 2016, 11:05:37 PM
 #6

i guess everyone is at a loss aswell
ironsniper
Member
**
Offline Offline

Activity: 92
Merit: 10


View Profile
January 22, 2017, 06:22:23 AM
 #7

hey everyone got another wallet with the same issue above however i found this https://github.com/Peershares/Peershares/issues/105 in that someone said about the same error
Quote
The above error was due to sh.exe and the associated dll's missing from C:\MinGW\bin

i checked mine and i do have sh.exe in there and i am guess dll files for it aswell but i am still getting that error, any have any advice?

EDIT i found the problem, i compared the code in the .pro file with a different .pro and found this to be the problem

if you get the same error look for the following in your .pro file and if it looks like this
Code:
# regenerate src/build.h
!win32 || contains(USE_BUILD_INFO, 1) {
    genbuild.depends = FORCE
    genbuild.commands = cd $$PWD; /bin/sh share/genbuild.sh $$OUT_PWD/build/build.h
    genbuild.target = genbuildhook
    PRE_TARGETDEPS += genbuildhook
    QMAKE_EXTRA_TARGETS += genbuild
    DEFINES += HAVE_BUILD_INFO
}

replace it with this

Code:
# regenerate src/build.h
!windows|contains(USE_BUILD_INFO, 1) {
    genbuild.depends = FORCE
    genbuild.commands = cd $$PWD; /bin/sh share/genbuild.sh $$OUT_PWD/build/build.h
    genbuild.target = $$OUT_PWD/build/build.h
    PRE_TARGETDEPS += $$OUT_PWD/build/build.h
    QMAKE_EXTRA_TARGETS += genbuild
    DEFINES += HAVE_BUILD_INFO
}

and that will fix the error
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!