Bitcoin Forum
October 19, 2017, 09:34:58 AM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Fatal internal error in bitcoind.  (Read 735 times)
fumblefingers
Newbie
*
Offline Offline

Activity: 26


View Profile
September 04, 2016, 12:43:48 AM
 #1

On Win7 64 bit, using Armory v 0.93.3 beta with Bitcoin Core v o.12.1

Worked great for a few months ( from a new install, both programs.)

I have to NOT let Armory control Bitcoin core, in the Armory settings, for Armory to work, but it worked great. (Restore wallets, spend easily, etc.)

Couple of weeks ago, when I would manually start bitcoind, as I have to, I would get this:

Loading Blockchain index
Verifying
Activating Best Chain...
 
and the program would throw this error:

Error: a fatal internal error occurred. See debug log for details.

On pastebin, http://pastebin.com/0p1u2ydB

I appended that last couple of days that it work.

Hopefully, I went back far enough.

I'm guessing that I need to delete from some point and let it catch up again.

Any help appreciated.
1508405698
Hero Member
*
Offline Offline

Posts: 1508405698

View Profile Personal Message (Offline)

Ignore
1508405698
Reply with quote  #2

1508405698
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1508405698
Hero Member
*
Offline Offline

Posts: 1508405698

View Profile Personal Message (Offline)

Ignore
1508405698
Reply with quote  #2

1508405698
Report to moderator
goatpig
Moderator
Legendary
*
Offline Offline

Activity: 1638

Armory Developer


View Profile
September 04, 2016, 04:34:23 AM
 #2

Code:
2016-09-01 00:10:32 ERROR: ReadBlockFromDisk: Errors in block header at CBlockDiskPos(nFile=594, nPos=128428074)
2016-09-01 00:10:32 *** Failed to read block

In your bitcoin /databases folder, you will have to delete all blkXXXXX.dat and revXXXXX.dat files from 594 onward. Then start BitcoinQt and let it redownload what's missing (it will recheck the whole chain).

fumblefingers
Newbie
*
Offline Offline

Activity: 26


View Profile
September 04, 2016, 05:24:15 AM
 #3

Bitcoind briskly got to 5 years and  4 weeks behind and and threw the same error.

last couple hundred lines of log:

http://pastebin.com/BSxrXcSs

If I have to delete and start from there, I might as well just start the database over. Last time, that took two weeks. Hope that isn't what I need.
achow101
Staff
Legendary
*
Offline Offline

Activity: 1190


17kKQppUsngUiByDsce4JXoZEjjpvX9bpR


View Profile WWW
September 04, 2016, 01:28:57 PM
 #4

First, upgrade to Armory 0.94.1 and Bitcoin Core to 0.13.0.

Do what goatpig said, but it's the /blocks folder not /databases. You have to delete blk00594.dat and rev00594.dat and onwards. THIS IS NOT DELETEING THE ENTIRE BLOCKCHAIN. You will not be redownloading the entire blockchain. It will however require that you reindex the blockchain (this will be done automatically), but it is not redownloading the entire blockchain. It will only download what you deleted, which is towards the end of the blockchain.

          ▄█████▄
        ▄█████████▄
      ▄████▀   ▀████▄
    ▄████▀   ▄ ▄█▀████▄
  ▄████▀   ▄███▀   ▀████▄
▄████▀   ▄███▀   ▄   ▀████▄
█████   ███▀   ▄███   █████
▀████▄   ▀██▄▄███▀   ▄████▀
  ▀████▄   ▀███▀   ▄████▀
    ▀████▄       ▄████▀
      ▀████▄   ▄████▀
        ▀███  ████▀
          ▀█▄███▀
.
|
.
|
          ▄█████▄
        ▄█████████▄
      ▄████▀   ▀████▄
    ▄████▀   ▄ ▄█▀████▄
  ▄████▀   ▄███▀   ▀████▄
▄████▀   ▄███▀   ▄   ▀████▄
█████   ███▀   ▄███   █████
▀████▄   ▀██▄▄███▀   ▄████▀
  ▀████▄   ▀███▀   ▄████▀
    ▀████▄       ▄████▀
      ▀████▄   ▄████▀
        ▀███  ████▀
          ▀█▄███▀
unthy
fumblefingers
Newbie
*
Offline Offline

Activity: 26


View Profile
September 04, 2016, 02:36:00 PM
 #5

I did PRECIOUSLY what goatpig suggested.

There WERE only the  594.dat entries, nothing following those.

I will install the updated versions and try again.
goatpig
Moderator
Legendary
*
Offline Offline

Activity: 1638

Armory Developer


View Profile
September 04, 2016, 02:37:10 PM
 #6

How much free space is on your disk?

fumblefingers
Newbie
*
Offline Offline

Activity: 26


View Profile
September 04, 2016, 05:52:12 PM
 #7

My blockchain file was 83.9 gigs, and I had 25gigs free on top of that.

Is that not enough?

I installed bitcoin core v0.13, after checking the SHA256 hash, and installed it to the default directory.

It would open and close so fast I couldn't read the error message it threw.

I uninstalled the program  but left the roaming data then reinstalled. Nothing but error messages. Even the damned shortcut stopped working, and the newly created shortcut wouldn't work either. Did that three times.

I've now deleted everything, and am redownloading the blockchain.

Pain in the ass. Angry

And when I go to armory.org, all I see to download is v 0.93. Where is 94? I see a reddit thread claiming that v0.94 is goatpig's, and he has no access to armory.org to post the new version.
achow101
Staff
Legendary
*
Offline Offline

Activity: 1190


17kKQppUsngUiByDsce4JXoZEjjpvX9bpR


View Profile WWW
September 04, 2016, 07:09:09 PM
 #8

My blockchain file was 83.9 gigs, and I had 25gigs free on top of that.

Is that not enough?

I installed bitcoin core v0.13, after checking the SHA256 hash, and installed it to the default directory.

It would open and close so fast I couldn't read the error message it threw.

I uninstalled the program  but left the roaming data then reinstalled. Nothing but error messages. Even the damned shortcut stopped working, and the newly created shortcut wouldn't work either. Did that three times.

I've now deleted everything, and am redownloading the blockchain.

Pain in the ass. Angry
Do you have the debug.log for that?

And when I go to armory.org, all I see to download is v 0.93. Where is 94? I see a reddit thread claiming that v0.94 is goatpig's, and he has no access to armory.org to post the new version.
Indeed, that is the case. Goatpig does not control the old website. Use the new one, https://btcarmory.com/.

          ▄█████▄
        ▄█████████▄
      ▄████▀   ▀████▄
    ▄████▀   ▄ ▄█▀████▄
  ▄████▀   ▄███▀   ▀████▄
▄████▀   ▄███▀   ▄   ▀████▄
█████   ███▀   ▄███   █████
▀████▄   ▀██▄▄███▀   ▄████▀
  ▀████▄   ▀███▀   ▄████▀
    ▀████▄       ▄████▀
      ▀████▄   ▄████▀
        ▀███  ████▀
          ▀█▄███▀
.
|
.
|
          ▄█████▄
        ▄█████████▄
      ▄████▀   ▀████▄
    ▄████▀   ▄ ▄█▀████▄
  ▄████▀   ▄███▀   ▀████▄
▄████▀   ▄███▀   ▄   ▀████▄
█████   ███▀   ▄███   █████
▀████▄   ▀██▄▄███▀   ▄████▀
  ▀████▄   ▀███▀   ▄████▀
    ▀████▄       ▄████▀
      ▀████▄   ▄████▀
        ▀███  ████▀
          ▀█▄███▀
unthy
fumblefingers
Newbie
*
Offline Offline

Activity: 26


View Profile
September 06, 2016, 04:17:47 AM
 #9

No logs. I got tired of fucking with it and started over.

I'm down to 28 weeks behind. Probably finish Tuesday night.

I'll close this out when I'm back up and running.
fumblefingers
Newbie
*
Offline Offline

Activity: 26


View Profile
September 07, 2016, 08:51:01 PM
 #10

So I have Bitcoin Core newly installed, updated and working fine.

Opening Armory v 93 showed my wallet, and the transaction history, and I am sure that I could have sent and received coins.

I downloaded v 0.94.1, checked the Hash, and "installed" it using default actions. It deleted a bunch, then started to unpack the new files, and threw the error:

Error opening the file for writing: ArmoryQt.exe. If I ignored it (which I know wouldn't work,) there was a cascade of other files that threw the same error.

Attempting to install v94 tanked v93, so I tired reinstalling that, only to get exactly the same errors.

So right now I have a fully functional Bitcoind, but no Armory, v93 or v94.

I'm just glad I don't need to send or receive coins right now.

achow101
Staff
Legendary
*
Offline Offline

Activity: 1190


17kKQppUsngUiByDsce4JXoZEjjpvX9bpR


View Profile WWW
September 07, 2016, 10:35:34 PM
 #11

So I have Bitcoin Core newly installed, updated and working fine.

Opening Armory v 93 showed my wallet, and the transaction history, and I am sure that I could have sent and received coins.

I downloaded v 0.94.1, checked the Hash, and "installed" it using default actions. It deleted a bunch, then started to unpack the new files, and threw the error:

Error opening the file for writing: ArmoryQt.exe. If I ignored it (which I know wouldn't work,) there was a cascade of other files that threw the same error.

Attempting to install v94 tanked v93, so I tired reinstalling that, only to get exactly the same errors.

So right now I have a fully functional Bitcoind, but no Armory, v93 or v94.

I'm just glad I don't need to send or receive coins right now.
So Bitcoin Core is working, that's good. I recommend trying to go for a completely clean install of Armory. Find the Armory Data directory. Copy your wallet file out and back it up to a safe place. Then delete the entire folder. Reinstall Armory and try again.

          ▄█████▄
        ▄█████████▄
      ▄████▀   ▀████▄
    ▄████▀   ▄ ▄█▀████▄
  ▄████▀   ▄███▀   ▀████▄
▄████▀   ▄███▀   ▄   ▀████▄
█████   ███▀   ▄███   █████
▀████▄   ▀██▄▄███▀   ▄████▀
  ▀████▄   ▀███▀   ▄████▀
    ▀████▄       ▄████▀
      ▀████▄   ▄████▀
        ▀███  ████▀
          ▀█▄███▀
.
|
.
|
          ▄█████▄
        ▄█████████▄
      ▄████▀   ▀████▄
    ▄████▀   ▄ ▄█▀████▄
  ▄████▀   ▄███▀   ▀████▄
▄████▀   ▄███▀   ▄   ▀████▄
█████   ███▀   ▄███   █████
▀████▄   ▀██▄▄███▀   ▄████▀
  ▀████▄   ▀███▀   ▄████▀
    ▀████▄       ▄████▀
      ▀████▄   ▄████▀
        ▀███  ████▀
          ▀█▄███▀
unthy
fumblefingers
Newbie
*
Offline Offline

Activity: 26


View Profile
September 08, 2016, 11:51:51 PM
 #12

Both updated programs installed and working fine.

Except I "still" have to run bitcoind manually to get Armory to work.

Not a big deal, but is this a bug that could be fixed?

Anyway, thanks to those who helped me. This thread is done. Smiley
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!