Bitcoin Forum
October 20, 2017, 03:37:13 AM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: [SOLVED] Need Help with Ubuntu 14.04 - AMD A8-8650B R7 + Radeon 5450  (Read 2726 times)
megacrypto
Full Member
***
Offline Offline

Activity: 234


View Profile
September 07, 2016, 12:37:09 PM
 #1

Edited: Installed Ubuntu Desktop 14.04.4 and there is some progress, but still not done yet!! https://bitcointalk.org/index.php?topic=1610536.msg16226185#msg16226185

Edited: Changed the PC ... kindly look at https://bitcointalk.org/index.php?topic=1610536.msg16208734#msg16208734


Original Post:

Just started and been at it for the last week with no luck. I have a very modest (if I may say so) setup, but that is only to learn more before investing in some serious parts. My target us GPU mining, and I went and bought the smallest / cheapest card (AMD Radeon 5450 with 2GB RAM). Here is my setup so far:

Motherboard: MSI GeForce7050M-M
CPU: AMD Athlon LE-1640
RAM: 2GB
GPU: XFX Radeon 5450 / 2GB DDR3
OS: Ubuntu 14.04.5

These are the steps I followed so far:
- downloaded the Accelerated AMD Parallel Processing SDK "AMD-APP-SDKInstaller-v3.0.130.136-GA-linux64.tar.bz2"
- and the ADL Display Library “ADL_SDK-V10.1.zip”
- extracted & installed the SDK

Code:
sudo ./ AMD-APP-SDKInstaller-v3.0.130.136-GA-linux64.sh
sudo ln -s /opt/AMDAPPSDK-3.0 /opt/AMDAPP
sudo ln -s /opt/AMDAPP/include/CL /usr/include
sudo ln -s /opt/AMDAPP/lib/x86_64/* /usr/lib/
sudo ldconfig
sudo reboot

- then installed the AMD fglrx drivers

Code:
sudo apt-get install fglrx-updates
sudo aticonfig --adapter=all –initial
sudo aticonfig --lsa

- and I see my card listed as no. 0

- downloaded the cpp-ethereum from git and installed it as follows:

Code:
git clone --recursive https://github.com/ethereum/cpp-ethereum.git
cd cpp-ethereum
./scripts/install_deps.sh
mkdir build
cd build
cmake ..
make

- now when I run ethminer to benchmark it:
Code:
ethminer -M --opencl

- I get that there is no GPU present

- the same goes for the "minergate-cli.deb" when I install it through:

Code:
sudo dpkg -i minergate-cli.deb

I think I'm missing a step in setting up the opencl drivers on m y system, but I can't seem to get my hands on it?

Any help will be highly appreciated!

Thanks




BTC: 1Feqs22qa8hAUC13YJh9z3bBe4FSYsa5nn                    ZEC: t1eYeHJKV6Ku9VzadpS8p1LDBeYXqQtRjvw
ETH: 0x00BEa51b34482d76fC91BA6865Ab92A4A438Cf90       ETC: 0x565EC4035645C4d9AEa5AB58fdF25E0Ea43e0b86
1508470633
Hero Member
*
Offline Offline

Posts: 1508470633

View Profile Personal Message (Offline)

Ignore
1508470633
Reply with quote  #2

1508470633
Report to moderator
1508470633
Hero Member
*
Offline Offline

Posts: 1508470633

View Profile Personal Message (Offline)

Ignore
1508470633
Reply with quote  #2

1508470633
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1508470633
Hero Member
*
Offline Offline

Posts: 1508470633

View Profile Personal Message (Offline)

Ignore
1508470633
Reply with quote  #2

1508470633
Report to moderator
megacrypto
Full Member
***
Offline Offline

Activity: 234


View Profile
September 09, 2016, 03:30:01 AM
 #2

Ok .. did a fresh install of Ubuntu 14.04.5 ... then did the usual update
Code:
sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade

installed ubuntu desktop (minimal)
Code:
sudo apt-get install --no-install-recommends ubuntu-desktop

downloaded the crimson driver 15.12 (radeon-crimson-15.12-15.302-151217a-297685e.zip) ... unzipped it ... ran the installation (got some missing packages and installed them)

created the installation package and installed it ... this the output of the log
Quote
NOTE: If your system has logged the missing packages required for installation, install them in the order as per the log file to resolve package-dependency issues.
Check if system has the tools required for Packages Generation.
Package /home/mylin/fglrx-15.302/fglrx-amdcccle_15.302-0ubuntu1_amd64.deb has been successfully generated
Package /home/mylin/fglrx-15.302/fglrx-core_15.302-0ubuntu1_amd64.deb has been successfully generated
Package /home/mylin/fglrx-15.302/fglrx-dev_15.302-0ubuntu1_amd64.deb has been successfully generated
Package /home/mylin/fglrx-15.302/fglrx_15.302-0ubuntu1_amd64.deb has been successfully generated

ran the configs

Code:
sudo aticonfig --initial
sudo aticonfig --adapter=all --initial

rebooted the system

installed the sdk (AMD-APP-SDKInstaller-v3.0.130.136-GA-linux64.tar.bz2)
Code:
tar -xvjf AMD-APP-SDKInstaller-v3.0.130.136-GA-linux64.tar.bz2
sudo ./AMD-APP-SDK-v3.0.130.136-GA-linux64.sh
sudo ln -s /opt/AMDAPPSDK-3.0 /opt/AMDAPP
sudo ln -s /opt/AMDAPP/include/CL /usr/include
sudo ln -s /opt/AMDAPP/lib/x86_64/* /usr/lib/
sudo ldconfig

installed the opencl headers
Code:
sudo apt-get install opencl-headers

rebooted again (note ... i can't no longer login from X ... for some reason i get the login screen and then it looks like its logging in and then takes me back to the login screen)

installed ethminer
Code:
sudo add-apt-repository -y ppa:ethereum/ethereum-qt
sudo add-apt-repository -y ppa:ethereum/ethereum
sudo add-apt-repository -y ppa:ethereum/ethereum-dev
sudo apt-get update
sudo apt-get install ethminer

tried to run the benchmark
Code:
ethminer -G -M --opencl

and I get this !!!

Quote
Invalid MIT-MAGIC-COOKIE-1 keymodprobe: ERROR: ../libkmod/libkmod-module.c:809 kmod_module_insert_module() could not find module by name='fglrx'
modprobe: ERROR: could not insert 'fglrx': Function not implemented
Error: Fail to load fglrx kernel module!
Error! Fail to load fglrx kernel module! Maybe you can switch to root user to load kernel module directly
modprobe: ERROR: ../libkmod/libkmod-module.c:809 kmod_module_insert_module() could not find module by name='fglrx'
modprobe: ERROR: could not insert 'fglrx': Function not implemented
Error: Fail to load fglrx kernel module!
Error! Fail to load fglrx kernel module! Maybe you can switch to root user to load kernel module directly
modprobe: ERROR: ../libkmod/libkmod-module.c:809 kmod_module_insert_module() could not find module by name='fglrx'
modprobe: ERROR: could not insert 'fglrx': Function not implemented
Error: Fail to load fglrx kernel module!
Error! Fail to load fglrx kernel module! Maybe you can switch to root user to load kernel module directly
Invalid MIT-MAGIC-COOKIE-1 keyNo GPU device with sufficient memory was found. Can't GPU mine. Remove the -G argument

ok .... what am I missing?

BTC: 1Feqs22qa8hAUC13YJh9z3bBe4FSYsa5nn                    ZEC: t1eYeHJKV6Ku9VzadpS8p1LDBeYXqQtRjvw
ETH: 0x00BEa51b34482d76fC91BA6865Ab92A4A438Cf90       ETC: 0x565EC4035645C4d9AEa5AB58fdF25E0Ea43e0b86
QuintLeo
Hero Member
*****
Offline Offline

Activity: 854


View Profile
September 09, 2016, 12:07:00 PM
 #3

It doesn't look like you set up your xorg.conf file?

 aticonfig --initial --force should fix that part.

 without xorg.conf set up right, the fglrx driver never gets loaded.

adaseb
Legendary
*
Offline Offline

Activity: 1386



View Profile
September 09, 2016, 12:59:24 PM
 #4

Return that video card, its no good for mining.

If you are on a budget get a 2nd hand 7950.


FORTUNEJACK.COM[
                            
9 BTC WELCOME PACK FOR 1ST 5 DEPOSITS
FREE 1,000 mBTC daily for LuckyJack winners
[
          
]
megacrypto
Full Member
***
Offline Offline

Activity: 234


View Profile
September 09, 2016, 03:16:52 PM
 #5

It doesn't look like you set up your xorg.conf file?

 aticonfig --initial --force should fix that part.

 without xorg.conf set up right, the fglrx driver never gets loaded.



i actually did that after installing the drivers (but forgot to mention it)

Code:
sudo aticonfig --initial
sudo aticonfig --adapter=all --initial

and then rebooted

BTC: 1Feqs22qa8hAUC13YJh9z3bBe4FSYsa5nn                    ZEC: t1eYeHJKV6Ku9VzadpS8p1LDBeYXqQtRjvw
ETH: 0x00BEa51b34482d76fC91BA6865Ab92A4A438Cf90       ETC: 0x565EC4035645C4d9AEa5AB58fdF25E0Ea43e0b86
megacrypto
Full Member
***
Offline Offline

Activity: 234


View Profile
September 09, 2016, 03:36:27 PM
 #6

Return that video card, its no good for mining.

If you are on a budget get a 2nd hand 7950.



i know its a very weak card for serious mining but i got it because its the cheapest i could find and as a learning process to understand this entire cryptocurrency thing Smiley

BTC: 1Feqs22qa8hAUC13YJh9z3bBe4FSYsa5nn                    ZEC: t1eYeHJKV6Ku9VzadpS8p1LDBeYXqQtRjvw
ETH: 0x00BEa51b34482d76fC91BA6865Ab92A4A438Cf90       ETC: 0x565EC4035645C4d9AEa5AB58fdF25E0Ea43e0b86
QuintLeo
Hero Member
*****
Offline Offline

Activity: 854


View Profile
September 10, 2016, 08:33:42 PM
 #7

double-check your xorg.conf - Ubuntu 14.04 has a nasty bug where it will delete or overwrite that file when it reboots.

 Workaround THAT WORKS is to disable gpumanager in your grub setup.
nerdralph
Sr. Member
****
Offline Offline

Activity: 350


View Profile
September 10, 2016, 08:40:54 PM
 #8

double-check your xorg.conf - Ubuntu 14.04 has a nasty bug where it will delete or overwrite that file when it reboots.

 Workaround THAT WORKS is to disable gpumanager in your grub setup.


Or just comment out the lines in /etc/init/gpu-manager.conf
megacrypto
Full Member
***
Offline Offline

Activity: 234


View Profile
September 10, 2016, 09:58:05 PM
 #9

Well ... I ended up getting a new PC (refurbished, found it for a very good price) :

- HP EliteDesk 705 G2 MT
- CPU:  AMD Pro A8-8650B R7 with 10 compute cores (4C + 6G)
- 4GB RAM
- XFX Radeon 5450 / 2GB DDR3

I installed Ubuntu 14.04.5 with the same steps as in my last post .... and i got to the same point!

Here is what I have so far:

when sudo aticonfig --lsa I get

Code:
* 0. 00:01.0 AMD Radeon(TM) R7 Graphics
  1. 01:00.0 AMD Radeon HD 5450

* - Default adapter

I installed ethminer from repo (same steps as my last post) and when I try to benchmark it (ethminer -G -M --opencl):
Code:
Invalid MIT-MAGIC-COOKIE-1 keymodprobe: ERROR: ../libkmod/libkmod-module.c:809 kmod_module_insert_module() could not find module by name='fglrx'
modprobe: ERROR: could not insert 'fglrx': Function not implemented
Error: Fail to load fglrx kernel module!
Error! Fail to load fglrx kernel module! Maybe you can switch to root user to load kernel module directly
Segmentation fault (core dumped)

now running sudo gpu-manager I get:
Code:
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
grep dmesg status 256
dmesg status 256 == 0? No
/etc/modprobe.d is not a file
grep dmesg status 256
dmesg status 256 == 0? No
/etc/modprobe.d is not a file
/etc/modprobe.d is not a file
/etc/modprobe.d is not a file
Is nvidia loaded? no
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is fglrx loaded? no
Was fglrx unloaded? no
Is fglrx blacklisted? no
Is intel loaded? no
Is radeon loaded? no
[b]Is radeon blacklisted? yes[/b]
Is nouveau loaded? no
Is nouveau blacklisted? no
Is fglrx kernel module available? no
Is nvidia kernel module available? no
Vendor/Device Id: 1002:1313
BusID "PCI:0@0:1:0"
Is boot vga? no
[b]Error: can't access /sys/bus/pci/devices/0000:00:01.0/driver[/b]
[b]The device is not bound to any driver. Skipping...[/b]
Vendor/Device Id: 1002:68f9
BusID "PCI:1@0:0:0"
Is boot vga? yes
[b]Error: can't access /sys/bus/pci/devices/0000:01:00.0/driver[/b]
[b]The device is not bound to any driver. Skipping...
Error : Failed to open /dev/dri
Error : Failed to open /dev/dri
Error : Failed to open /dev/dri[/b]
Does it require offloading? no
last cards number = 0
Has amd? no
Has intel? no
Has nvidia? no
How many cards? 0
Has the system changed? No
main_arch_path x86_64-linux-gnu, other_arch_path i386-linux-gnu
Current alternative: /usr/lib/fglrx/ld.so.conf
Current core alternative: /usr/lib/fglrx-core/ld.so.conf
Is nvidia enabled? no
Is fglrx enabled? yes
Is mesa enabled? no
Is pxpress enabled? no
Is prime enabled? no
Is nvidia available? no
Is fglrx available? yes
Is fglrx-core available? yes
Is mesa available? yes
Is pxpress available? yes
Is prime available? no

I'm looking into this gpu manager issue, but if there are other pointers to do?

BTC: 1Feqs22qa8hAUC13YJh9z3bBe4FSYsa5nn                    ZEC: t1eYeHJKV6Ku9VzadpS8p1LDBeYXqQtRjvw
ETH: 0x00BEa51b34482d76fC91BA6865Ab92A4A438Cf90       ETC: 0x565EC4035645C4d9AEa5AB58fdF25E0Ea43e0b86
megacrypto
Full Member
***
Offline Offline

Activity: 234


View Profile
September 12, 2016, 02:43:38 PM
 #10

Well... I installed a fresh copy of Ubuntu desktop 14.04.4 (not 5), but I first removed the Radeon card.

- Did the install straight forward

- installed the fglrx-updates from the Additional drivers, rebooted, and .... finally got the AMD control center on my desktop (step 1 finally completed)

- installed the APP SDK, as described before, and rebooted, and ... well I lost my desktop but logged in from terminal and everything (aside X) seemed to be working
Code:
tar -xvjf AMD-APP-SDKInstaller-v3.0.130.136-GA-linux64.tar.bz2
sudo ./AMD-APP-SDK-v3.0.130.136-GA-linux64.sh
sudo ln -s /opt/AMDAPPSDK-3.0 /opt/AMDAPP
sudo ln -s /opt/AMDAPP/include/CL /usr/include
sudo ln -s /opt/AMDAPP/lib/x86_64/* /usr/lib/
sudo ldconfig
sudo apt-get install opencl-headers
sudo reboot

- installed the cpp-ethereum from got and compiled it...and finally got OpenCL :-)
Code:
git clone --recursive https://github.com/ethereum/cpp-ethereum.git
cd cpp-ethereum
./scripts/install_deps.sh
mkdir build
cd build
cmake ..
make j4

I forgot, after I installed the fglrx and app SDK, I put back the Radeon card back in.

Now I seem to have a new problem...not enough memory to use the gpu's. I have 4gb on the PC, which allocates 512mb from bios to internal GPU (that's the max the bios gives me) and while the Radeon card has 2gb on it, yet the ethminer does not seem to use it (I'm not next to computer now to write the exact message it says) but it seems that I need to execute some "export" commands to utilize the full memory of the card.

running ./ethminer --list-devices i get the following:
Quote
[OPENCL]:
Listing OpenCL devices.
FORMAT: [deviceID] deviceName
  • Spectre
       CL_DEVICE_TYPE: GPU
        CL_DEVICE_GLOBAL_MEM_SIZE: 536870912
        CL_DEVICE_MAX_MEM_ALLOC_SIZE: 134217728
        CL_DEVICE_MAX_WORK_GROUP_SIZE: 256
[1] Cedar
        CL_DEVICE_TYPE: GPU
        CL_DEVICE_GLOBAL_MEM_SIZE: 1073741824
        CL_DEVICE_MAX_MEM_ALLOC_SIZE: 268435456
        CL_DEVICE_MAX_WORK_GROUP_SIZE: 128

The "Spectre" is the internal GPU & Ceder is the Radeon 5450 card (sudo aticonfig --lsa)
Quote
* 0. 00:01.0 AMD Radeon(TM) R7 Graphics
  1. 01:00.0 AMD Radeon HD 5450

* - Default adapter

when running the benchmark

Code:
ethminer -G -M --opencl

i get the following:

Quote
[OPENCL]:OpenCL device Spectre has insufficient GPU memory.536870912 bytes of memory found < 1423739904 bytes of memory required
[OPENCL]:OpenCL device Cedar has insufficient GPU memory.1073741824 bytes of memory found < 1423739904 bytes of memory required
No GPU device with sufficient memory was found. Can't GPU mine. Remove the -G argument

So now I have two issues:

1. how can I fix this memory issue for the Radeon card?

2. if I add another 4gb to my pc , will that give me access to utilize the apu / ipgu?

of course it would be nice to get my desktop (X) back, but I'm OK for now working from terminal.

BTC: 1Feqs22qa8hAUC13YJh9z3bBe4FSYsa5nn                    ZEC: t1eYeHJKV6Ku9VzadpS8p1LDBeYXqQtRjvw
ETH: 0x00BEa51b34482d76fC91BA6865Ab92A4A438Cf90       ETC: 0x565EC4035645C4d9AEa5AB58fdF25E0Ea43e0b86
megacrypto
Full Member
***
Offline Offline

Activity: 234


View Profile
September 12, 2016, 10:57:48 PM
 #11

got ethminer to work with the Radeon card by issuing the following:

Code:
export GPU_FORCE_64BIT_PTR=0
export GPU_MAX_HEAP_SIZE=100
export GPU_USE_SYNC_OBJECTS=1
export GPU_MAX_ALLOC_PERCENT=90
export GPU_SINGLE_ALLOC_PERCENT=90

right now its generating the DAG file ... hope it completes it!

BTC: 1Feqs22qa8hAUC13YJh9z3bBe4FSYsa5nn                    ZEC: t1eYeHJKV6Ku9VzadpS8p1LDBeYXqQtRjvw
ETH: 0x00BEa51b34482d76fC91BA6865Ab92A4A438Cf90       ETC: 0x565EC4035645C4d9AEa5AB58fdF25E0Ea43e0b86
megacrypto
Full Member
***
Offline Offline

Activity: 234


View Profile
September 12, 2016, 11:34:20 PM
 #12

finally .... my first gpu mining Smiley) not much but I'm looking to learn for now ...

here is the output of ethminer (had to make it use card 1 and not the default 0 whihc doesn't have enough memory for the DAG )

Code:
./ethminer -G -F http://eth.pool.minergate.com:55751/xxxx@xxxxxxxxxxxxx.com --disable-submit-hashrate --opencl-device 1

now this is what I'm getting

Quote
[OPENCL]:OpenCL device Spectre has insufficient GPU memory.536870912 bytes of memory found < 1423739904 bytes of memory required
[OPENCL]:Found suitable OpenCL device [Cedar] with 2147483648 bytes of GPU memory
 ⚡   01:32:55 AM.978|ethminer  pause 321 ms
  ℹ  01:32:55 AM.998|gpuminer0  workLoop 1 #789121f0… #789121f0…
miner  01:32:56 AM.498|ethminer  Mining on PoWhash #b1658d91… : 0 H/s = 0 hashes / 0.5 s
miner  01:32:57 AM.098|ethminer  Mining on PoWhash #b1658d91… : 0 H/s = 0 hashes / 0.599 s
miner  01:32:57 AM.749|ethminer  Mining on PoWhash #b1658d91… : 0 H/s = 0 hashes / 0.651 s
miner  01:32:58 AM.348|ethminer  Mining on PoWhash #b1658d91… : 438367 H/s = 262144 hashes / 0.598 s
miner  01:32:58 AM.947|ethminer  Mining on PoWhash #b1658d91… : 0 H/s = 0 hashes / 0.598 s
miner  01:32:59 AM.547|ethminer  Mining on PoWhash #b1658d91… : 437636 H/s = 262144 hashes / 0.599 s
miner  01:33:00 AM.146|ethminer  Mining on PoWhash #b1658d91… : 437636 H/s = 262144 hashes / 0.599 s
miner  01:33:00 AM.745|ethminer  Mining on PoWhash #b1658d91… : 0 H/s = 0 hashes / 0.598 s
miner  01:33:01 AM.358|ethminer  Mining on PoWhash #b1658d91… : 427641 H/s = 262144 hashes / 0.613 s
miner  01:33:01 AM.959|ethminer  Mining on PoWhash #b1658d91… : 0 H/s = 0 hashes / 0.6 s
miner  01:33:02 AM.559|ethminer  Mining on PoWhash #b1658d91… : 437636 H/s = 262144 hashes / 0.599 s
miner  01:33:03 AM.159|ethminer  Mining on PoWhash #b1658d91… : 437636 H/s = 262144 hashes / 0.599 s
miner  01:33:03 AM.776|ethminer  Mining on PoWhash #b1658d91… : 0 H/s = 0 hashes / 0.617 s
miner  01:33:04 AM.376|ethminer  Mining on PoWhash #b1658d91… : 436906 H/s = 262144 hashes / 0.6 s
miner  01:33:04 AM.979|ethminer  Mining on PoWhash #b1658d91… : 0 H/s = 0 hashes / 0.602 s
miner  01:33:05 AM.578|ethminer  Mining on PoWhash #b1658d91… : 437636 H/s = 262144 hashes / 0.599 s
miner  01:33:05 AM.677|ethminer  Got work package:
miner  01:33:05 AM.677|ethminer    Header-hash: d82fa6a5259e37fe3754a734844bedc6496300d6afee9140f6af53adced86379
miner  01:33:05 AM.677|ethminer    Seedhash: 789121f005cf40651e361085512f0540e36453fb34ca66fbe38e2836348b9f73
miner  01:33:05 AM.677|ethminer    Target: 000010c6f7a0b5ed8d36b4c7f34938583621fafc8b0079a2834d26fa3fcc9ea9
 ⚡   01:33:06 AM.082|ethminer  pause 405 ms
  ℹ  01:33:06 AM.103|gpuminer0  workLoop 1 #789121f0… #789121f0…
miner  01:33:06 AM.603|ethminer  Mining on PoWhash #d82fa6a5… : 0 H/s = 0 hashes / 0.5 s
miner  01:33:07 AM.202|ethminer  Mining on PoWhash #d82fa6a5… : 0 H/s = 0 hashes / 0.599 s
miner  01:33:07 AM.801|ethminer  Mining on PoWhash #d82fa6a5… : 0 H/s = 0 hashes / 0.598 s
miner  01:33:08 AM.400|ethminer  Mining on PoWhash #d82fa6a5… : 437636 H/s = 262144 hashes / 0.599 s
miner  01:33:09 AM.002|ethminer  Mining on PoWhash #d82fa6a5… : 0 H/s = 0 hashes / 0.602 s
  ℹ  01:33:09 AM.602|ethminer  Solution found; Submitting to http://eth.pool.minergate.com:55751/xxxx@xxxxxxxxxxxxx.com ...
  ℹ  01:33:09 AM.602|ethminer    Nonce: e2a1773f12e54bc9
  ℹ  01:33:09 AM.602|ethminer    Mixhash: 8054b82488df307be9fab45341482d0ee464d37ef6a730dfef6411bab95676c1
  ℹ  01:33:09 AM.602|ethminer    Header-hash: d82fa6a5259e37fe3754a734844bedc6496300d6afee9140f6af53adced86379
  ℹ  01:33:09 AM.602|ethminer    Seedhash: 789121f005cf40651e361085512f0540e36453fb34ca66fbe38e2836348b9f73
  ℹ  01:33:09 AM.602|ethminer    Target: 000010c6f7a0b5ed8d36b4c7f34938583621fafc8b0079a2834d26fa3fcc9ea9
  ℹ  01:33:09 AM.602|ethminer    Ethash: 00000c3ec3d4a02b8086f7f715d7b45318343231deb2a63570eb0d1821721e50
  ℹ  01:33:09 AM.702|ethminer  B-) Submitted and accepted.
miner  01:33:09 AM.703|ethminer  Getting work package...
miner  01:33:09 AM.802|ethminer  Got work package:
miner  01:33:09 AM.802|ethminer    Header-hash: d82fa6a5259e37fe3754a734844bedc6496300d6afee9140f6af53adced86379
miner  01:33:09 AM.802|ethminer    Seedhash: 789121f005cf40651e361085512f0540e36453fb34ca66fbe38e2836348b9f73
miner  01:33:09 AM.802|ethminer    Target: 000010c6f7a0b5ed8d36b4c7f34938583621fafc8b0079a2834d26fa3fcc9ea9
 ⚡   01:33:09 AM.821|gpuminer0  Worker stopping 647 ms
  ℹ  01:33:09 AM.821|gpuminer0  workLoop 1 #789121f0… #789121f0…
miner  01:33:10 AM.321|ethminer  Mining on PoWhash #d82fa6a5… : 0 H/s = 0 hashes / 0.5 s
miner  01:33:10 AM.948|ethminer  Mining on PoWhash #d82fa6a5… : 0 H/s = 0 hashes / 0.626 s
miner  01:33:11 AM.549|ethminer  Mining on PoWhash #d82fa6a5… : 0 H/s = 0 hashes / 0.601 s


milestone 1 completed Smiley)

BTC: 1Feqs22qa8hAUC13YJh9z3bBe4FSYsa5nn                    ZEC: t1eYeHJKV6Ku9VzadpS8p1LDBeYXqQtRjvw
ETH: 0x00BEa51b34482d76fC91BA6865Ab92A4A438Cf90       ETC: 0x565EC4035645C4d9AEa5AB58fdF25E0Ea43e0b86
QuintLeo
Hero Member
*****
Offline Offline

Activity: 854


View Profile
September 13, 2016, 11:49:42 AM
 #13

double-check your xorg.conf - Ubuntu 14.04 has a nasty bug where it will delete or overwrite that file when it reboots.

 Workaround THAT WORKS is to disable gpumanager in your grub setup.


Or just comment out the lines in /etc/init/gpu-manager.conf

 Which does NOT always work - the disable it in grub HAS always worked for me.


 I've tried to get my A10 APUs to work with Ethereum - but trying to allocate 2GB to them in the MB BIOS settings has always caused the MB to crash during boot in EVERY motherboard model I've been able to try it in (a couple of my older ones don't even offer the option).
 IMO it's a good thing I have other uses for them - I suspect the hashrate with DDR3 would be sad compared even to a 2GB HD7750 with the SAME number of shaders but much faster DDR5 for RAM.
megacrypto
Full Member
***
Offline Offline

Activity: 234


View Profile
September 13, 2016, 12:09:24 PM
 #14

I tried the the "nomodeset" before , but haven't yet on this install. actually i was about to add another 4gb to my machine's memory to see if the boards apu will be better (the problem is that according to the manual, the bios can only allocate max 1gb to the onboard apu)

As for hashrates ... I'm still trying to figure out this entire hashrates thing Smiley

BTC: 1Feqs22qa8hAUC13YJh9z3bBe4FSYsa5nn                    ZEC: t1eYeHJKV6Ku9VzadpS8p1LDBeYXqQtRjvw
ETH: 0x00BEa51b34482d76fC91BA6865Ab92A4A438Cf90       ETC: 0x565EC4035645C4d9AEa5AB58fdF25E0Ea43e0b86
QuintLeo
Hero Member
*****
Offline Offline

Activity: 854


View Profile
September 13, 2016, 09:45:40 PM
 #15

not "nomodeset"
"nogpumanager"

I've NEVER seen "nomodeset" help on this issue, it seems to be more about "don't reset the boot graphics mode when you LIKE the mode you boot in".

megacrypto
Full Member
***
Offline Offline

Activity: 234


View Profile
September 13, 2016, 09:49:24 PM
 #16

not "nomodeset"
"nogpumanager"

I've NEVER seen "nomodeset" help on this issue, it seems to be more about "don't reset the boot graphics mode when you LIKE the mode you boot in".



ahhh .... ok Smiley)) .... still learning here !!

Right now I'm trying to figure out how to work my cards with different mining apps

BTC: 1Feqs22qa8hAUC13YJh9z3bBe4FSYsa5nn                    ZEC: t1eYeHJKV6Ku9VzadpS8p1LDBeYXqQtRjvw
ETH: 0x00BEa51b34482d76fC91BA6865Ab92A4A438Cf90       ETC: 0x565EC4035645C4d9AEa5AB58fdF25E0Ea43e0b86
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!