Bitcoin Forum
November 24, 2017, 11:45:44 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 [4]  All
  Print  
Author Topic: Using Onboard GPU for normal Work while mining with and AMD GPU?  (Read 27620 times)
notNigel
Full Member
***
Offline Offline

Activity: 182


View Profile
March 16, 2014, 07:29:19 PM
 #61

I want to revive this thread too, but for linux.

Say I have linux mint, a sandy bridge CPU, and two AMD cards. (I do).

How do I use the intel graphics for my desktop, and use the cards for mining with CGminer ?

This would be very nice.

I already tried, but failed. i don't really know what I am doing with the various config files and such. Maybe a cool dude has a solution ?
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
madjihad
Sr. Member
****
Offline Offline

Activity: 245


🌟 æternity🌟 blockchain🌟


View Profile
March 22, 2014, 04:26:09 PM
 #62

I want to revive this thread too, but for linux.

Say I have linux mint, a sandy bridge CPU, and two AMD cards. (I do).

How do I use the intel graphics for my desktop, and use the cards for mining with CGminer ?

This would be very nice.

I already tried, but failed. i don't really know what I am doing with the various config files and such. Maybe a cool dude has a solution ?

That is tricky thing Cool

During setup you can break you X few time, so prepare backups, liveCD and some kind of fallback with internet just in case (like laptop, smartphone, anything that could help you to find answers).

Tested on fresh install of Ubuntu 12.04, i5-3570K(HD4000), AsRock Z77extreme3 and ASUS HD7870 DC2, but it also should work as well on any other combination of Intel HD and AMD graphics. HD7870 connected via DVI and HD4000 via HDMI, integrated graphics selected as primary in BIOS.

It’s not step by step manual, as I were using a system for a while during all configure-use-reconfigure cycle, so I can’t recall all my actions and dependency resolving Smiley But I can share all my current configs and installed software versions.

1. First of all you need to make sure that you have fglrx installed, I’ve got it installed automatically during Ubuntu installation, the version is 2:13.300-0ubuntu0.0.1. According to apt-cache policy it’s fglrx-experimental-13, also I have fglrx-amdcccle-experimental-13 and fglrx-pxpress installed. As for a xorg, I have xserver-xorg 1:7.6+12ubuntu2, xserver-xorg-video-intel-dbg 2:2.17.0-1ubuntu4.4 and xserver-xorg-video-intel 2:2.17.0-1ubuntu4.4.

So if you don’t have fglrx, install it with
Code:
sudo apt-get install fglrx-experimental-13 fglrx-amdcccle-experimental-13 fglrx-pxpress

And if you don’t have intel driver
Code:
sudo apt-get install  xserver-xorg-video-intel-dbg

2. Next you need to create 2 xorg configs in /etc/X11/: one for intel, another for amd. Here is my files:
xorg_intel.conf
Code:
Section "ServerLayout"
    Identifier     "seat0"
    Screen      0  "Screen1" 0 0
EndSection

Section "Files"
    ModulePath     "/usr/lib/xorg/extra-modules"
    ModulePath     "/usr/lib/xorg/modules"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "intel"
    BusID          "PCI:0:2:0"
    Option         "AccelMethod"  "uxa"
    Option         "TearFree"     "true"
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth     24
    SubSection "Display"
     Viewport   0 0
        Depth     24
    EndSubSection
EndSection

xorg_amd.conf
Code:
Section "ServerLayout"
Identifier     "seat1"
Screen      0  "aticonfig-Screen[0]-0" 0 0
#Option      "AutoAddDevices"        "false"
EndSection

Section "Module"
EndSection

Section "Files"
    ModulePath "/usr/lib/fglrx/xorg/modules/"
    ModulePath "/usr/lib/fglrx/xorg/modules/linux"
    ModulePath "/usr/lib/fglrx/xorg/modules/drivers"
    ModulePath "/usr/lib/fglrx/xorg/modules/extensions"
    ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Monitor"
Identifier   "aticonfig-Monitor[0]-0"
Option    "VendorName" "ATI Proprietary Driver"
Option    "ModelName" "Generic Autodetecting Monitor"
Option    "DPMS" "true"
EndSection

Section "Device"
Identifier  "aticonfig-Device[0]-0"
Driver      "fglrx"
BusID       "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device     "aticonfig-Device[0]-0"
Monitor    "aticonfig-Monitor[0]-0"
DefaultDepth     24
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection
As xorg and fglrx have a lot of common libraries (like libglx.so), you need to specify ModulePath to fglrx versions to use 2 drivers simultaneously.

3. To activate intel as a primary driver use switchlibglx from fglrx:
Code:
/usr/lib/fglrx/switchlibglx intel

4. Create user for mining, in my case it’s called  miner. You can do it via GUI, and grant it administrator privileges or via terminal
Code:
adduser miner sudo

5. Configure lightdm: /etc/lightdm/lightdm.conf
Code:
[SeatDefaults]
greeter-session=unity-greeter
allow-guest=false

[Seat:0]
xserver-layout=seat0
xserver-command=/usr/bin/X -novtswitch -keeptty
xserver-config=xorg_intel.conf
user-session=gnome

[Seat:1]
xserver-command=/usr/bin/X -sharevts -novtswitch -isolateDevice PCI:1:0:0 -keeptty
xserver-layout=seat1
xserver-config=xorg_amd.conf
user-session=ubuntu-2d
autologin-user=miner
autologin-user-timeout=0
6. Reboot and prey Cheesy Now you should be able to use intel HD for your main user, and in terminal just calling
Code:
su miner
export DISPLAY=:1
fglrxinfo
get access to your AMD card
Code:
display: :1  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: AMD Radeon HD 7800 Series
OpenGL version string: 1.4 (2.1 (4.3.12682 Compatibility Profile Context 13.30))
Have fun Cheesy

pekv2
Hero Member
*****
Offline Offline

Activity: 770



View Profile
May 12, 2014, 10:19:04 AM
 #63

If anyone comes across this thread that uses UEFI, and has any problems booting up their win7-8 OS on the dedicated graphic cards after disabling the onboard graphics to game after mining or the other way around.

Do a cmos reset from the motherboard. Make sure dedicated gfx card is set to bootup and not onboard or the other way around if that's the way you want it.

I ran into this problem, and for the life of me could not figure out what was going on. UEFI, I believe was getting something mixed up on board ports, causing failed boot from the dedicated gfx card.

cmos saved me a few time already.

What I was doing was using onboard gfx as web browsing etc, and using the gfx card for mining. Well, I rebooted into UEFI, set gfx card as main display device, hit F10, removed the dummy plug, plugged my monitor into the gfx card then I hit Enter =  saving UEFI blindly. On boot up of windows 7, I'd get a greyed out screen after the windows7 emblem as to where you would normally be at the login screen.

I kept getting driver problems. etc as well.

Long story short, I had a intel raid utility problem, where when in UEFI was set to raid, my raid utility would not show, after days of work, I finally reset cmos on the board, that fixed it.

Because of this, I was able to fix the above problem with the dedicated graphics card.

If you ever have a board, card, uefi, any of those type of problems, don't forget clear cmos is your best friend.

Edit:
It's in archival.
Using Onboard GPU for normal Work while mining with and AMD GPU

June 14, 2012, 02:44:06 PM
https://bitcointalk.org/index.php?topic=87611.msg963185#msg963185
Pages: « 1 2 3 [4]  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!