Bitcoin Forum
December 02, 2016, 06:32:06 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Diablo Miner Trouble  (Read 1723 times)
dominatro
Newbie
*
Offline Offline

Activity: 15


View Profile
June 15, 2011, 09:23:26 PM
 #1

Since I can't post in the official thread, I will post the problem here.

I am mining 2 6990s on xp sp3(SDK2.4 Cat 11.6) with crossfire enabled because I can't see the gpus when disabled.
I have been mining for just over a week. The reason I'm using diablo is because that old version is the only miner that i tried that could use all 4 of my gpus.
There are several problems, some of which I'm sure are limited to other factors. But here are all of them.

5-10% rejected shares
 The rejected shares are rarely isolated, but group together with usually 5-20 rejected all at once on all gpus, which indicates there's some type of flaw in the miner, since i got only as high as 1.5% on phoenix.
need to use old version of diablominer since new version only gives me 50-75% of the rate with a very huge rate of hardware errors.
 On the most recent version
frequent disconnects on pools and errors about longpolling too frequently.
speeds are not stable and fluctuate by as much as 10%

The biggest problem is the hardware errors, reduced speeds, and stales. Diablo or experts please help.
1480703526
Hero Member
*
Offline Offline

Posts: 1480703526

View Profile Personal Message (Offline)

Ignore
1480703526
Reply with quote  #2

1480703526
Report to moderator
1480703526
Hero Member
*
Offline Offline

Posts: 1480703526

View Profile Personal Message (Offline)

Ignore
1480703526
Reply with quote  #2

1480703526
Report to moderator
1480703526
Hero Member
*
Offline Offline

Posts: 1480703526

View Profile Personal Message (Offline)

Ignore
1480703526
Reply with quote  #2

1480703526
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480703526
Hero Member
*
Offline Offline

Posts: 1480703526

View Profile Personal Message (Offline)

Ignore
1480703526
Reply with quote  #2

1480703526
Report to moderator
DiabloD3
Legendary
*
Offline Offline

Activity: 1162


DiabloMiner author


View Profile WWW
June 15, 2011, 11:43:54 PM
 #2

Since I can't post in the official thread, I will post the problem here.

I am mining 2 6990s on xp sp3(SDK2.4 Cat 11.6) with crossfire enabled because I can't see the gpus when disabled.
I have been mining for just over a week. The reason I'm using diablo is because that old version is the only miner that i tried that could use all 4 of my gpus.
There are several problems, some of which I'm sure are limited to other factors. But here are all of them.

5-10% rejected shares
 The rejected shares are rarely isolated, but group together with usually 5-20 rejected all at once on all gpus, which indicates there's some type of flaw in the miner, since i got only as high as 1.5% on phoenix.
need to use old version of diablominer since new version only gives me 50-75% of the rate with a very huge rate of hardware errors.
 On the most recent version
frequent disconnects on pools and errors about longpolling too frequently.
speeds are not stable and fluctuate by as much as 10%

The biggest problem is the hardware errors, reduced speeds, and stales. Diablo or experts please help.

I bet you're on eligius. DiabloMiner automatically disconnects connection attempts after 15 seconds, and eligius lags so bad that DM disconnects frequently to save itself. This cannot be fixed in the miner, and its effecting mining speed because the execution threads block waiting for the connection to complete.

Switch to slush's, deepbit, btcguild, or anything that doesn't use pushpoold.

dominatro
Newbie
*
Offline Offline

Activity: 15


View Profile
June 16, 2011, 05:34:44 AM
 #3

Surprisingly this is not on Eligius. It is on mainly DB and slush wouldn't even work. BTCGuild works best now, but it doesn't give good stats there. The hardware errors are everywhere, but pools do seem to affect speeds.

But even with BTCGuild I can't use the newest version because there's too many hardware errors and speed goes max 75%.
Is it normal to get clumps of rejected shares?
DiabloD3
Legendary
*
Offline Offline

Activity: 1162


DiabloMiner author


View Profile WWW
June 16, 2011, 06:14:45 AM
 #4

Surprisingly this is not on Eligius. It is on mainly DB and slush wouldn't even work. BTCGuild works best now, but it doesn't give good stats there. The hardware errors are everywhere, but pools do seem to affect speeds.

But even with BTCGuild I can't use the newest version because there's too many hardware errors and speed goes max 75%.
Is it normal to get clumps of rejected shares?

I think BTCGuild uses pushpool, which explains why its also screwing up.

But as a side note, hardware error != rejected. Do you have a high number of hardware errors or a high number of rejects?

dominatro
Newbie
*
Offline Offline

Activity: 15


View Profile
June 16, 2011, 03:03:45 PM
 #5

Both. On the newest version it just shows all the hardware errors and slows down for some reason.
the rejects are 5-10% regardless of pool
DiabloD3
Legendary
*
Offline Offline

Activity: 1162


DiabloMiner author


View Profile WWW
June 16, 2011, 04:43:27 PM
 #6

Both. On the newest version it just shows all the hardware errors and slows down for some reason.
the rejects are 5-10% regardless of pool

You're probably suffering from the Radeon HW error bug that I can't reproduce. An extremely small number of users suffer from it, and other miners, as far as I can tell, just don't report it (which is even worse).

dominatro
Newbie
*
Offline Offline

Activity: 15


View Profile
June 16, 2011, 08:31:41 PM
 #7

I have a few ideas about what could be related.
This could be a windows XP specific issue.
It could be because of crossfire.
I only get hardware errors on my slave GPUs.

btw, do you have an option to turn off hardware checking in the newest version?
DiabloD3
Legendary
*
Offline Offline

Activity: 1162


DiabloMiner author


View Profile WWW
June 17, 2011, 04:26:24 AM
 #8

I have a few ideas about what could be related.
This could be a windows XP specific issue.
It could be because of crossfire.
I only get hardware errors on my slave GPUs.

btw, do you have an option to turn off hardware checking in the newest version?

Its not OS related, Linux users are getting it. It is also not Crossfire related, as people who turn off Crossfire and people with single GPUs are getting it.

Turning off HW checking would do nothing, as a high number of errors are also causing potential pool shares to evaporate (they're getting about 3/4th as many).

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!