Bitcoin Forum
October 19, 2017, 08:05:34 AM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: [SOLVED] Setting up GPU mining with cgminer on Ubuntu 12.04.2 LTS  (Read 12908 times)
pdl
Newbie
*
Offline Offline

Activity: 2


View Profile
April 13, 2013, 04:10:56 PM
 #1

Hi! I'm having trouble getting cgminer to do GPU mining on my headless Ubuntu 12.04.2 box. I started mining just 2 weeks ago, and it worked. Now it broke, perhaps because of a kernel upgrade and/or reboot in the meantime. Following instructions on the README, I purged and re-installed  the AMD-APP-SDK and then rebooted; also I have said "make clean" and "sudo make install" a few times in the cgminer source directory itself. Compilation seems to work. It says GPU mining is enabled. To make extra sure that there are no problems with permissions, I made the /usr/local/bin/cgminer a "setuid" executable file.

According to "ps aux | grep X" there *is* an X server running on display ":0". I can't see what is being sent there, because the machine is in a dark tiny closet under the stairs (Harry Potter moved out a few years back). Could my problem be related somehow to this setup?

To get "All devices disabled, cannot mine!" I say "DISPLAY=:0 cgminer". My other option is "segfault": to get that, I say "sudo su" to become root, then issue "DISPLAY=:0 xauth +" to make sure any user can do whatever they like to the X server. Then cgminer just breaks (with DISPLAY=:0) no matter who runs it.

In case the commands below are helpful, here are some things I tried:

Code:
$ cat /etc/issue
Ubuntu 12.04.2 LTS
$ uname -a
Linux ninja 3.2.0-40-generic #64-Ubuntu SMP Mon Mar 25 21:22:10 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
$ ps aux | grep Xorg
root      3474  0.0  0.5 165704 40936 tty8     Ss+  08:12   0:00 /usr/bin/Xorg :0 -br -verbose -auth /var/run/gdm/auth-for-gdm-yGC0Kn/database -nolisten tcp
$ lsmod | grep fglrx
fglrx                3264017  49
$ sudo DISPLAY=:0 fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 5450
OpenGL version string: 4.2.11627 Compatibility Profile Context

Code:
$ DISPLAY=:0 cgminer -n
No protocol specified
No protocol specified
 [2013-04-13 09:05:04] CL Platform 0 vendor: Advanced Micro Devices, Inc.                    
 [2013-04-13 09:05:04] CL Platform 0 name: AMD Accelerated Parallel Processing                    
 [2013-04-13 09:05:04] CL Platform 0 version: OpenCL 1.1 AMD-APP-SDK-v2.5 (684.213)                    
 [2013-04-13 09:05:04] Error -1: Getting Device IDs (num)                    
 [2013-04-13 09:05:04] clDevicesNum returned error, no GPUs usable                    
 [2013-04-13 09:05:04] 0 GPU devices max detected

This last one is a bit long. Thanks for any hints you can provide!

Code:
$ cat /etc/X11/xorg.conf
Section "ServerLayout"
Identifier     "aticonfig Layout"
Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
Identifier   "aticonfig-Monitor[0]-0"
Option    "VendorName" "ATI Proprietary Driver"
Option    "ModelName" "Generic Autodetecting Monitor"
Option    "DPMS" "true"
EndSection

Section "Device"
Identifier  "aticonfig-Device[0]-0"
Driver      "fglrx"
BusID       "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device     "aticonfig-Device[0]-0"
Monitor    "aticonfig-Monitor[0]-0"
DefaultDepth     24
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection
[\code]
1508400334
Hero Member
*
Offline Offline

Posts: 1508400334

View Profile Personal Message (Offline)

Ignore
1508400334
Reply with quote  #2

1508400334
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1508400334
Hero Member
*
Offline Offline

Posts: 1508400334

View Profile Personal Message (Offline)

Ignore
1508400334
Reply with quote  #2

1508400334
Report to moderator
1508400334
Hero Member
*
Offline Offline

Posts: 1508400334

View Profile Personal Message (Offline)

Ignore
1508400334
Reply with quote  #2

1508400334
Report to moderator
1508400334
Hero Member
*
Offline Offline

Posts: 1508400334

View Profile Personal Message (Offline)

Ignore
1508400334
Reply with quote  #2

1508400334
Report to moderator
pdl
Newbie
*
Offline Offline

Activity: 2


View Profile
April 14, 2013, 06:48:54 AM
 #2

This is now solved.

Over on IRC, cgminer author Con Kolivas himself (!) kindly suggested using AMD SDK version 2.7 and the AMD Catalyst Driver version 12.8. Both can be found on the AMD downloads area. This worked. Following the cgminer "README" is essential.

I experienced two wrinkles.

1. Installing AMD's driver required first uninstalling the version of fglrx from the Ubuntu repositories (sudo aptitude purge fglrx, sudo service gdm restart [or just reboot], sudo rmmod fglrx).

2. The script "Install-AMD-APP.sh" supplied by AMD in their package didn't seem to do everything that was actually required. I followed the instructions in the cgminer README describing how to install SDK version 2.4, but changing "2.4" to "2.7". After this step, it was possible to compile and run cgminer.
Hornedfrog
Newbie
*
Offline Offline

Activity: 18


View Profile
July 24, 2013, 11:03:07 PM
 #3

This is now solved.

Over on IRC, cgminer author Con Kolivas himself (!) kindly suggested using AMD SDK version 2.7 and the AMD Catalyst Driver version 12.8. Both can be found on the AMD downloads area. This worked. Following the cgminer "README" is essential.

I experienced two wrinkles.

1. Installing AMD's driver required first uninstalling the version of fglrx from the Ubuntu repositories (sudo aptitude purge fglrx, sudo service gdm restart [or just reboot], sudo rmmod fglrx).

2. The script "Install-AMD-APP.sh" supplied by AMD in their package didn't seem to do everything that was actually required. I followed the instructions in the cgminer README describing how to install SDK version 2.4, but changing "2.4" to "2.7". After this step, it was possible to compile and run cgminer.

Thank you for this.  I used your advice to get my 7970 recognized but I get an error trying to start cgminer 3.3.1.  The error is cgminer command not found.  Do I need to reinstall cgminer?
Hogan
Newbie
*
Offline Offline

Activity: 2


View Profile
December 15, 2013, 11:56:20 AM
 #4

Anyone?!

Where I could find the old binaries:
Quote
AMD SDK version 2.7 and the AMD Catalyst Driver version 12.8
As with 13.x catalyst driver I get coredump (cgminer 3.7.2). Some gave a hint to try with 12.X catalyst driver. But it is not awailable anywhere.

Br,
Hogan
corygto
Full Member
***
Offline Offline

Activity: 196


View Profile
January 06, 2014, 01:39:11 AM
 #5

I am having "cldevicesnum returned error" problem as well, and I cannot seem to figure out how to fix it. :/

I would also be interested in getting the binaries for the old software and see if it can possibly help.
R0yalAir
Member
**
Offline Offline

Activity: 84


View Profile
January 06, 2014, 08:31:32 PM
 #6

I am having "cldevicesnum returned error" problem as well, and I cannot seem to figure out how to fix it. :/

I would also be interested in getting the binaries for the old software and see if it can possibly help.

Remove your drivers, the SDK then run a driver cleaner and install 13.4+ drivers *only*

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!