Bitcoin Forum
October 21, 2020, 04:39:54 PM *
News: Latest Bitcoin Core release: 0.20.0 [Torrent]
   Home   Help Search Login Register More  
Pages: [1]
Author Topic: Trouble With CPUMiner  (Read 5035 times)
Offline Offline

Activity: 23
Merit: 0

View Profile
April 16, 2013, 10:34:59 PM

I've recently decided to switch my mining PC from windows to headless Ubuntu, in order to squeeze out a few more hashes. I managed to get cgminer up and running in no time at all, but I've been having some problems with Pooler's CPUminer that I haven't been able to resolve.

I've tried using the stratum proxy(which seems to be working fine with CGminer) to connect to stratum pools, and that worked perfectly, so I'm almost sure it's minerd.

Here's my setup with the stratum proxy:

nice -n 10 ./minerd
./minerd -user xxx -password x -a scrypt


cd mine/stratum-mining-proxy/
sudo ./ -o -p 3334 -gp 9332

This gives me the error:

[2013-04-16 15:26:47] HTTP request failed: The requested URL returned error: 401 Unauthorized
[2013-04-16 15:26:47] json_rpc_call failed, retry after 30 seconds

The stratum proxy says:

2013-04-16 15:26:47,050 WARNING proxy getwork_listener.render_POST # Authorization required

I've tried manually pointing the out the URL to and http://localhost:9332 but these give me the same error.

When I tried running CPUminer without stratum, I pointed to a getwork pool I use this bash script:

nice -n 10 ./minerd
sudo ./minerd -user xxx -password x -a scrypt -url
(I've tried without the / at the end too)

Which gives me this error:

[2013-04-16 15:31:06] HTTP request failed: couldn't connect to host
[2013-04-16 15:31:06] json_rpc_call failed, retry after 30 seconds

Any help or suggestions would be greatly appreciated. I feel like this is a simple problem that I've just become blind to after attempting to fix it for so long.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Hero Member
Offline Offline

Activity: 770
Merit: 502

View Profile
May 15, 2013, 02:40:47 PM

Apparently, this guy is having the same problem. I'm just bouncing it.;topicseen
Pages: [1]
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!