Bitcoin Forum
November 20, 2017, 08:05:34 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: install Electrum server problem  (Read 477 times)
gelius
Full Member
***
Offline Offline

Activity: 221


View Profile
February 12, 2017, 01:14:13 AM
 #1

This manual:
https://github.com/spesmilo/electrum-server/blob/master/HOWTO.md
Step 4.
Code:
sudo ./configure
Database not found in /var/electrum-server.
Do you want to download it from the Electrum foundry to /var/electrum-server ?

chown: invalid user: ‘electrum:electrum’
Yes, i don't have user "electrum". I need useradd?
Code:
sudo python setup.py install
warning: no files found matching '*' under directory 'doc/build/html'
warning: no files found matching 'plyvel/*.pxi'
cc1plus: warning: command line option ‘-Wstrict-prototypes’ is valid for C/ObjC but not for C++
plyvel/_plyvel.cpp:359:24: fatal error: leveldb/db.h: No such file or directory
 #include "leveldb/db.h"
                        ^
compilation terminated.
error: Setup script exited with error: command 'x86_64-linux-gnu-gcc' failed with exit status 1
Code:
sudo apt install gcc
Reading package lists... Done
Building dependency tree
Reading state information... Done
gcc is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
wtf?
Join ICO Now Coinlancer is Disrupting the Freelance marketplace!
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
nerioseole
Hero Member
*****
Offline Offline

Activity: 648


View Profile
February 13, 2017, 12:06:46 AM
 #2

This manual:
https://github.com/spesmilo/electrum-server/blob/master/HOWTO.md
Step 4.
Code:
sudo ./configure
Database not found in /var/electrum-server.
Do you want to download it from the Electrum foundry to /var/electrum-server ?

chown: invalid user: ‘electrum:electrum’
Yes, i don't have user "electrum". I need useradd?
Code:
sudo python setup.py install
warning: no files found matching '*' under directory 'doc/build/html'
warning: no files found matching 'plyvel/*.pxi'
cc1plus: warning: command line option ‘-Wstrict-prototypes’ is valid for C/ObjC but not for C++
plyvel/_plyvel.cpp:359:24: fatal error: leveldb/db.h: No such file or directory
 #include "leveldb/db.h"
                        ^
compilation terminated.
error: Setup script exited with error: command 'x86_64-linux-gnu-gcc' failed with exit status 1
Code:
sudo apt install gcc
Reading package lists... Done
Building dependency tree
Reading state information... Done
gcc is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
wtf?
If Step 4 does not work for you, do Step 5 - which should install leveldb for you.  And download manually the Electrum UTXO database (updated daily) from http://foundry.electrum.org/leveldb-dump/?C=M;O=D

EDIT:  You could also give a try to ElectrumX - instead of Electrum-Server code - apparently is better for your CPU, but uses more GBs. https://github.com/kyuupichan/electrumx

As you can see here: https://1209k.com/bitcoin-eye/ele.php?chain=btc - lots of servers have switched to ElectrumX
mmortal03
Legendary
*
Offline Offline

Activity: 1606


View Profile
June 05, 2017, 01:02:51 AM
 #3

This manual:
https://github.com/spesmilo/electrum-server/blob/master/HOWTO.md
Step 4.
Code:
sudo ./configure
Database not found in /var/electrum-server.
Do you want to download it from the Electrum foundry to /var/electrum-server ?

chown: invalid user: ‘electrum:electrum’
Yes, i don't have user "electrum". I need useradd?
Code:
sudo python setup.py install
warning: no files found matching '*' under directory 'doc/build/html'
warning: no files found matching 'plyvel/*.pxi'
cc1plus: warning: command line option ‘-Wstrict-prototypes’ is valid for C/ObjC but not for C++
plyvel/_plyvel.cpp:359:24: fatal error: leveldb/db.h: No such file or directory
 #include "leveldb/db.h"
                        ^
compilation terminated.
error: Setup script exited with error: command 'x86_64-linux-gnu-gcc' failed with exit status 1
Code:
sudo apt install gcc
Reading package lists... Done
Building dependency tree
Reading state information... Done
gcc is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
wtf?

I ran into this same issue. I had to run the following first: sudo apt-get install libleveldb-dev
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!