Bitcoin Forum
December 08, 2016, 04:25:31 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Windows users do not need to download the 2.4 SDK separately, OpenCL is included  (Read 4264 times)
LegitBit
Full Member
***
Offline Offline

Activity: 140



View Profile
June 16, 2011, 03:35:33 PM
 #1

The only thing Windows miners need are the standard OpenCL drivers which are INCLUDED by default in the regular Graphics drivers in Catalyst 11.5 and 11.6. Earlier versions required you to download a 'stream edition' that no longer applies.

I haven't installed the SDK even once and I've built 3 dedicated miners all running high hash-rates.

The only thing needed to run OpenCL code is the driver, the rest of the SDK is essentially bloat for normal users.

If you happen to have an issue, then you can install the SDK to see if it fixes the issue but it is silly to waste the space upfront, especially if you are using a PXE image or a flash install.

Donate : 1EiAKUmTVtqXsaGLKQQVvLT9DDnHsT7jTZ (Block Explorer)
1481171131
Hero Member
*
Offline Offline

Posts: 1481171131

View Profile Personal Message (Offline)

Ignore
1481171131
Reply with quote  #2

1481171131
Report to moderator
1481171131
Hero Member
*
Offline Offline

Posts: 1481171131

View Profile Personal Message (Offline)

Ignore
1481171131
Reply with quote  #2

1481171131
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481171131
Hero Member
*
Offline Offline

Posts: 1481171131

View Profile Personal Message (Offline)

Ignore
1481171131
Reply with quote  #2

1481171131
Report to moderator
Meatball
Sr. Member
****
Offline Offline

Activity: 322



View Profile
June 16, 2011, 05:53:27 PM
 #2

You're half right.  SDK 2.4 comes packaged with Catalyst 11.5/11.6.  It's listed as "AMD APP SDK Runtime" in the installer.  If you uninstall that, you won't be able to mine.

Also, I've generally found much better hashing performance using SDK 2.1 on any HD 5xxxx cards on the order of 10% or so.  SDK 2.1 will not work with HD 6xxx cards though and you'll need to use SDK 2.4.
LegitBit
Full Member
***
Offline Offline

Activity: 140



View Profile
June 16, 2011, 11:26:03 PM
 #3

That is just the runtime (opencl driver) not the whole Software Development Kit, it was a misleading name, on the new download pages it is now called the OpenCL driver.


The SDK would also include the kernel analyzer and other tools and samples. The naming is confusing I know, but you are not getting the SDK as part of the main graphics suite, just the SDK's opencl driver.

It's like DirectX, you can install the SDK 'runtime' which includes what you need to run games programmed using the DirectX SDK, or you can install the actual SDK which is much larger and includes sample libraries and debugging tools.

The 2.1 SDK includes the old driver, which was not included in the main graphics suite at the time.

Donate : 1EiAKUmTVtqXsaGLKQQVvLT9DDnHsT7jTZ (Block Explorer)
dishwara
Legendary
*
Offline Offline

Activity: 1372

Truth may get delay, but NEVER fails


View Profile
June 19, 2011, 08:33:04 PM
 #4

Please change title from "Windows users do NOT need the 2.4 SDK" to Windows users do NOT need to download AMD APP 2.4 SDK separately.
The title completely gives false belief that Windows users with 6000 series cards can mine without 2.4.
AMD APP 2.4 comes with catalyst 11.5/11.6 as said by Meatball & no need to download separately.
LegitBit
Full Member
***
Offline Offline

Activity: 140



View Profile
June 19, 2011, 10:50:17 PM
 #5

Done.

Donate : 1EiAKUmTVtqXsaGLKQQVvLT9DDnHsT7jTZ (Block Explorer)
dishwara
Legendary
*
Offline Offline

Activity: 1372

Truth may get delay, but NEVER fails


View Profile
June 20, 2011, 06:59:05 AM
 #6

Thanks
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!