Bitcoin Forum
October 24, 2016, 12:20:45 PM *
News: Latest stable version of Bitcoin Core: 0.13.0  [Torrent].
   Home   Help Search Donate Login Register  
Pages: [1]
Author Topic: Re: Newbie restrictions  (Read 790 times)
Offline Offline

Activity: 6

View Profile
June 17, 2011, 03:10:14 PM

The login and posting requirements are annoying for someone like me who only registered to get technical help with a mining client.  So, in hopes of getting a solution faster, here's my problem:

I run Phoenix v1.50.  I have an AMD Radeon HD 4850 and a GeForce GT330 in my system.  Yes, I know these are not powerful mining cards, but every little bit of hashing potential helps.

I execute two mining scripts; one for the GT330 (OpenCL Platform #0) and one for the 4850 (OpenCL Platform #1).  Both call Phoenix in the same way:
[do some minor setup tasks]
phoenix.exe -v -u http://[login]:[password]@[poolHostname]:[poolPort] -k poclbm PLATFORM=0 DEVICE=0 FASTLOOP BFI_INT WORKSIZE=64 AGGRESSION=1
(on the 4850 script, it uses PLATFORM=1 but everything else is the same)

My GT330 will happily start up, connect to the pool, and chug away at it's speedy 19MH/s.  The 4850, however, returns the following content:

C:\phoenix-1.50>phoenix.exe -v -u http://[login]:[password]@[poolHostname]:[poolPort] -k poclbm PLATFORM=1 DEVICE=0 FASTLOOP BFI_INT WORKSIZE=64 AGGRESSION=1
[17/06/2011 10:57:38] Phoenix 1.50 starting...
[17/06/2011 10:57:39] Connected to server
[17/06/2011 10:57:39] Server gave new work; passing to WorkQueue
[17/06/2011 10:57:39] New block (WorkQueue)
[0 Khash/sec] [0 Accepted] [0 Rejected] [RPC]
This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

I look at the application event log and see the following:
Faulting application name: phoenix.exe, version:, time stamp: 0x4918019b
Faulting module name: MSVCR90.dll, version: 9.0.30729.6161, time stamp: 0x4dace5b9
Exception code: 0x40000015
Fault offset: 0x0005beae
Faulting process id: 0xe14
Faulting application start time: 0x01cc2cfee63374a8
Faulting application path: C:\phoenix-1.50\phoenix.exe
Faulting module path: C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_50934f2ebcb7eb57\MSVCR90.dll
Report Id: 24e65b98-98f2-11e0-91f4-782bcb9a70f2
I know that the 4850 is a working card; before I recently replaced it in another machine with a 6950, it was chugging along at about 66MH/s using the same script.  I've verified that OpenCL is working with GPU Caps Viewer 1.12.0 - it sees 2 platforms, with CL devices, and successfully runs OpenCL demos on both platforms.

Just for kicks, I've already tried reinstalling the OpenCL drivers from AMD.  I'm not sure where to go from here.  Could anyone point me in the right direction for allowing me to use both cards as mining clients?

Oh, and before anyone pipes up with the brilliant suggestion of simply removing the lower-performing card, I have to have it to be able to drive the 4 monitors on my desktop.  Smiley

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Offline Offline

Activity: 5

View Profile
June 17, 2011, 07:37:47 PM

Your device number is what should change, not platform.

Try simplifying your command all I have is
phoenix.exe -u -k poclbm DEVICE=0 -v

And the next one is all the same except DEVICE=1
Offline Offline

Activity: 63

View Profile
July 22, 2011, 04:33:04 AM

Hey helios, did you ever figure this out?  I have 4 machines with 4850 cards in them that are running in an office environment when the user is logged on.  The problem is that one of these machines is having this exact message in the event log and won't start the miner.  The other three are happy as can be!

This is happening for me with both poclbm and phoenix.  I have no idea what caused this one to just flake out on me!
Pages: [1]
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!