Bitcoin Forum
November 17, 2018, 01:38:21 AM *
News: Latest Bitcoin Core release: 0.17.0 [Torrent].
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: Error when signing message  (Read 217 times)
Nathan047
Sr. Member
****
Offline Offline

Activity: 504
Merit: 250



View Profile
April 02, 2017, 01:48:19 AM
 #1

I seem to be unable to sign a message with Electrum (Windows, Version 2.7.12). I go to the “Addresses” tab, right click on the address, choose “Sign/Verify Message” and enter the message, only to get “(False, 0)”. Am I doing something wrong or is this just a bug? I’m using an imported private key if that makes a difference.

Error Screenshot

I'm starting a technology blog T4CH.top, check it out!
1542418701
Hero Member
*
Offline Offline

Posts: 1542418701

View Profile Personal Message (Offline)

Ignore
1542418701
Reply with quote  #2

1542418701
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1542418701
Hero Member
*
Offline Offline

Posts: 1542418701

View Profile Personal Message (Offline)

Ignore
1542418701
Reply with quote  #2

1542418701
Report to moderator
1542418701
Hero Member
*
Offline Offline

Posts: 1542418701

View Profile Personal Message (Offline)

Ignore
1542418701
Reply with quote  #2

1542418701
Report to moderator
1542418701
Hero Member
*
Offline Offline

Posts: 1542418701

View Profile Personal Message (Offline)

Ignore
1542418701
Reply with quote  #2

1542418701
Report to moderator
kolloh
Legendary
*
Offline Offline

Activity: 1330
Merit: 1000


View Profile
April 02, 2017, 03:08:14 AM
 #2

I seem to be unable to sign a message with Electrum (Windows, Version 2.7.12). I go to the “Addresses” tab, right click on the address, choose “Sign/Verify Message” and enter the message, only to get “(False, 0)”. Am I doing something wrong or is this just a bug? I’m using an imported private key if that makes a difference.

Error Screenshot

The version of Electrum you are using is outdated. I'd recommend you try downloading the latest version which should fix this bug as shown:
Quote
# Release 2.7.13
* fix message signing with imported keys
Nathan047
Sr. Member
****
Offline Offline

Activity: 504
Merit: 250



View Profile
April 02, 2017, 06:58:14 PM
 #3

I seem to be unable to sign a message with Electrum (Windows, Version 2.7.12). I go to the “Addresses” tab, right click on the address, choose “Sign/Verify Message” and enter the message, only to get “(False, 0)”. Am I doing something wrong or is this just a bug? I’m using an imported private key if that makes a difference.

Error Screenshot
# Release 2.7.13
* fix message signing with imported keys



Hopefully that will fix my problem, I will defiantly update Electrum soon. Thanks for the reply :P.

I'm starting a technology blog T4CH.top, check it out!
Nathan047
Sr. Member
****
Offline Offline

Activity: 504
Merit: 250



View Profile
April 03, 2017, 10:04:16 PM
 #4

I just updated Electrum a few moments ago and I can now sign messages; my problem is now fixed.
Thanks again @kolloh.

Now that my problem is fixed I’ll be locking the thread momentarily.

I'm starting a technology blog T4CH.top, check it out!
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!