Bitcoin Forum
December 10, 2016, 10:27:29 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: 100% cpu usage running multiple GPU's  (Read 1649 times)
xtce
Newbie
*
Offline Offline

Activity: 8



View Profile
June 18, 2011, 02:22:42 AM
 #1

I picked up a 5770 cheap yesterday to run along with a 5830.  Noticed 100% cpu usage once I started mining. I had  0% usage when running one card.  Seems to be a common problem caused by the openCL drivers.  Here's what I did to fix it.  Running WIN7 64 bit / Phenom II dual core cpu.

I have one monitor installed to both cards (HDMI / VGA port)
Boot with both cards plugged in.  Go to screen resolution display settings and on the drop down menu for multiple displays select " Show desktop only on 1" (for 1st installed card)
start up your miner for that card.  Go back to display settings and select "show desktop only on 2" (for 2nd card) Now start up another miner for that card.  
I am now getting 0% cpu usage.  I'm assuming this will work for Windows XP also.  You may have to select extend display or detect first for Windows to recognize both cards before doing the above.

17qvaKjVLVgCi4b8rTe4M2K6XXjS5qbsdL  <<-- open for business
1481408849
Hero Member
*
Offline Offline

Posts: 1481408849

View Profile Personal Message (Offline)

Ignore
1481408849
Reply with quote  #2

1481408849
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Zeth
Newbie
*
Offline Offline

Activity: 26


View Profile
June 18, 2011, 02:34:22 AM
 #2

Or just go to task manager and limit the affinity for the miner.
xtce
Newbie
*
Offline Offline

Activity: 8



View Profile
June 18, 2011, 02:40:09 AM
 #3

I actually tried that from advice on this board.  setting the affinity for each miner to run on a separate core.  cpu usage was 50% on each one.

17qvaKjVLVgCi4b8rTe4M2K6XXjS5qbsdL  <<-- open for business
haydent
Full Member
***
Offline Offline

Activity: 154



View Profile
July 29, 2011, 02:48:53 AM
 #4

i have started a thread at amd dev forum - opencl section about the 100% cpu usage bug with >1 gpu installed. feel free to jump over there and post your support for this issue being addressed...

http://forums.amd.com/devforum/messageview.cfm?catid=390&threadid=153211&enterthread=y

2x Gigabyte 6950 OC @ 920/450 w/ ati tray tools (1 shader modded) - 760Mhs on ozco.in 0% fee aus pool
btc: 1HS5Brzcsh7XkJn566XYbvfpa2JuBRBdss
Botanix
Newbie
*
Offline Offline

Activity: 7


View Profile WWW
August 11, 2011, 03:46:50 AM
 #5

Hello
This is my first post to this forum.

My system:

Windows 7 64bit
2x hd5850 Sapphire Extreme OC to 850MHz
Phenom x2 550
Catalyst 11.6

GuiMiner - 690MH/s total and still can surf on the internet, wach movies not affected by mining. No shut downs also.


I would not worry about high CPU Ussage, the only think You need to worry about is Your electricity bill Smiley. To reduce power consumtion of my CPU I did that:

1. Go to GUIminer ( if You use one ) and set a CPU affinity to one core and the same core for each GPU You use. That should Reduce CPU usage to around 50%
2. Go to CCC and than to "Power" or "Performance" and "CPU power"
3. Reduce CPU processor speed to minimum. In my case from 3100MHz to 800MHz. Or You can reduce CPU speed in BIOS as well.
4. That's all

Result:

Before 1st step. Using 2 Cores, 100% CPU usage, 3100MHz CPU frequency. CPU consuming 86,4W - that's quite a lot.

http://i54.tinypic.com/r905g6.jpg

Before 2nd step. Using one core for 2 GPU. 50-51% CPU usage, 3100MHz CPU frequency. CPU consuming 86,4W. One core is free now so everything else goes faster. NO drop in MH/s.

http://i52.tinypic.com/20keqdt.jpg

After third step. Using 1 Core for both cards. 50-51% CPU usage. 800MHz CPU frequency. NO drop in MH/s. 24W CPU power consumption  Wink

http://i52.tinypic.com/2uqdcao.jpg

http://i55.tinypic.com/2j60j9h.jpg

Savings? 62,4W on two cores. If You have more, than more savings Smiley.

62.4W -> 1.5kWh a day - > 45 kwh a month. In my case that's about 5-6 pound per month.

I hope I helped.

There is also few more things to do to reduce general power consumption of Your computer, disable what You don't use in bios, reduce ram Voltage etc. 

Regards



johnj
Full Member
***
Offline Offline

Activity: 154


View Profile
September 13, 2011, 04:57:37 AM
 #6

I picked up a 5770 cheap yesterday to run along with a 5830.  Noticed 100% cpu usage once I started mining. I had  0% usage when running one card.  Seems to be a common problem caused by the openCL drivers.  Here's what I did to fix it.  Running WIN7 64 bit / Phenom II dual core cpu.

I have one monitor installed to both cards (HDMI / VGA port)
Boot with both cards plugged in.  Go to screen resolution display settings and on the drop down menu for multiple displays select " Show desktop only on 1" (for 1st installed card)
start up your miner for that card.  Go back to display settings and select "show desktop only on 2" (for 2nd card) Now start up another miner for that card.  
I am now getting 0% cpu usage.  I'm assuming this will work for Windows XP also.  You may have to select extend display or detect first for Windows to recognize both cards before doing the above.

Worked for me.  Awesome.

1AeW7QK59HvEJwiyMztFH1ubWPSLLKx5ym
TradeHill Referral TH-R120549
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!