Bitcoin Forum
December 09, 2016, 03:53:21 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 [3]  All
  Print  
Author Topic: Mining Farm - Tech support  (Read 7693 times)
d3c0n808
Member
**
Offline Offline

Activity: 113

Not Goxed


View Profile
July 11, 2011, 12:33:40 AM
 #41

Anyone else had the issue in php 5.3.6 that the workers have a depreciated error.  Basically it will have "> workername box password box  on each worker also this issue causes the graph to not update.  Wondering if anyone ran into this issue yet or not.  I've tried it on two different distributions. Slackware 1337 and Suse 11.4 seems this only affects new kernels.   Ive recompiled php 5.2.19 on both machines and it did not fix it so perhaps its a dependency or an old module of some sort that I didn't remove.... 
Thanks for the bug report, I actually ran into this on my Cloud hosted mining server during the install. I'm doing heavy testing using namecoind(for short block find times and quick,clean bug fixes) if you would like to help out test the new and improved Mining Farm you can check out a taste over at http://216.38.17.198/ This server is aimed at finding its first block(ETA 24 hours at this point), I've already rewritten everything, now its the testing part most of that is already done too I just need to see if the reward distrobution works correctly.

Thanks for yours and everyone's effort!
This is a community project and not just for me so we owe it to us to get this fixed! Lets get this 50% network rate attack problem outta the way by allowing anybody to start their own pool.

Ok just checking I wasn't sure if this issue was widespread or if I'm just an idiot.  Sorry Im not a php programmer so I am unable to fix it myself and push the fix to github but i am more than willing in helping out any way I can

60 GH/s BFL Single SC - Pre-Order Yours Today!
`````` Only $1299.99 - butterflylabs.com ``````
1481298801
Hero Member
*
Offline Offline

Posts: 1481298801

View Profile Personal Message (Offline)

Ignore
1481298801
Reply with quote  #2

1481298801
Report to moderator
1481298801
Hero Member
*
Offline Offline

Posts: 1481298801

View Profile Personal Message (Offline)

Ignore
1481298801
Reply with quote  #2

1481298801
Report to moderator
1481298801
Hero Member
*
Offline Offline

Posts: 1481298801

View Profile Personal Message (Offline)

Ignore
1481298801
Reply with quote  #2

1481298801
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481298801
Hero Member
*
Offline Offline

Posts: 1481298801

View Profile Personal Message (Offline)

Ignore
1481298801
Reply with quote  #2

1481298801
Report to moderator
1481298801
Hero Member
*
Offline Offline

Posts: 1481298801

View Profile Personal Message (Offline)

Ignore
1481298801
Reply with quote  #2

1481298801
Report to moderator
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
July 11, 2011, 01:37:57 AM
 #42

Anyone else had the issue in php 5.3.6 that the workers have a depreciated error.  Basically it will have "> workername box password box  on each worker also this issue causes the graph to not update.  Wondering if anyone ran into this issue yet or not.  I've tried it on two different distributions. Slackware 1337 and Suse 11.4 seems this only affects new kernels.   Ive recompiled php 5.2.19 on both machines and it did not fix it so perhaps its a dependency or an old module of some sort that I didn't remove.... 
Thanks for the bug report, I actually ran into this on my Cloud hosted mining server during the install. I'm doing heavy testing using namecoind(for short block find times and quick,clean bug fixes) if you would like to help out test the new and improved Mining Farm you can check out a taste over at http://216.38.17.198/ This server is aimed at finding its first block(ETA 24 hours at this point), I've already rewritten everything, now its the testing part most of that is already done too I just need to see if the reward distrobution works correctly.

Thanks for yours and everyone's effort!
This is a community project and not just for me so we owe it to us to get this fixed! Lets get this 50% network rate attack problem outta the way by allowing anybody to start their own pool.

Ok just checking I wasn't sure if this issue was widespread or if I'm just an idiot.  Sorry Im not a php programmer so I am unable to fix it myself and push the fix to github but i am more than willing in helping out any way I can

Awesome so my vision of mining farm is already going to use Cheesy
d3c0n808
Member
**
Offline Offline

Activity: 113

Not Goxed


View Profile
July 11, 2011, 04:40:51 AM
 #43

SO I've been mining on your pool for a little while now and I notice on the block statistics page the current block number is 15740

60 GH/s BFL Single SC - Pre-Order Yours Today!
`````` Only $1299.99 - butterflylabs.com ``````
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
July 11, 2011, 04:53:33 AM
 #44

SO I've been mining on your pool for a little while now and I notice on the block statistics page the current block number is 15740

Correct? what is your point?

UPDATE: I've updated the title to Mining Farm - Mining For Namecoins just to clear up and confusion
d3c0n808
Member
**
Offline Offline

Activity: 113

Not Goxed


View Profile
July 11, 2011, 05:04:50 AM
 #45

SO I've been mining on your pool for a little while now and I notice on the block statistics page the current block number is 15740

Correct? what is your point?

UPDATE: I've updated the title to Mining Farm - Mining For Namecoins just to clear up and confusion

Ah thats why I was wondering didn't know it was for namecoins sorry i just thought it was on the bitcoin blockchain



60 GH/s BFL Single SC - Pre-Order Yours Today!
`````` Only $1299.99 - butterflylabs.com ``````
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
July 11, 2011, 05:51:25 AM
 #46

SO I've been mining on your pool for a little while now and I notice on the block statistics page the current block number is 15740

Correct? what is your point?

UPDATE: I've updated the title to Mining Farm - Mining For Namecoins just to clear up and confusion

Ah thats why I was wondering didn't know it was for namecoins sorry i just thought it was on the bitcoin blockchain




No problems, honest mistake Smiley
ziomik
Legendary
*
Offline Offline

Activity: 1820


http://www.bitcoinmarket.net


View Profile WWW
July 14, 2011, 04:26:04 PM
 #47

Slogan is gone and does not work and error

To update slogan:
Code:
http://www.btcfarm.us/adminPanel.php?
and error:
Code:
Unknown column 'enableRequiredEmail' in 'field list'

Thanks Xenland for your works !!  Wink


Problem is importing database:
Code:
mysql -u root -p database < miningfarm_database
Enter password:
ERROR 1062 (23000) at line 61: Duplicate entry '4' for key 'PRIMARY'

 Huh Huh

"Se domani senti due massaie che parlano di bitcoin tra di loro dal macellaio, forse e' il momento di vendere.. se pero' le sentirai fra 10 anni forse staranno solo pagando il conto" GBianchi
---- +++ ----
http://www.bitcoinmarket.net
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
July 14, 2011, 05:42:38 PM
 #48

I'm fixing the admin panel as we speak Smiley

As far as the database, I will speak with you on skype Smiley
TTB
Newbie
*
Offline Offline

Activity: 6


View Profile
July 17, 2011, 08:54:33 AM
 #49

I installed the MiningFarm on a local testserver, and after some minor probs it seems to be doing pretty fine.
So at first: thanks Xenland for that great work.

But here comes the problem:
There seems to be a problem with the Cookie on my page, and i cant figure it out.
So here is what my apache2 log shows right after opening the page and logging in:

Code:

[Sun Jul 17 10:35:40 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: miningfarm#2 in /var/www/index.php on line 18
[Sun Jul 17 10:36:37 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined offset: 1 in /var/www/req/functions.php on line 184, referer: http://192.168.1.5/
[Sun Jul 17 10:37:23 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: miningfarm#2 in /var/www/index.php on line 18, referer: http://192.168.1.5/stats.php
[Sun Jul 17 10:37:39 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: show in /var/www/adminPanel.php on line 3, referer: http://192.168.1.5/
[Sun Jul 17 10:37:39 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: searchUsername in /var/www/adminPanel.php on line 4, referer: http://192.168.1.5/
[Sun Jul 17 10:37:39 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: act in /var/www/adminPanel.php on line 29, referer: http://192.168.1.5/
[Sun Jul 17 10:37:39 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: authPin in /var/www/adminPanel.php on line 30, referer: http://192.168.1.5/
[Sun Jul 17 10:37:39 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined variable: panelTitle in /var/www/adminPanel.php on line 172, referer: http://192.168.1.5/


First line is where $rawCookie = $_COOKIE[$cookieName]; is in the index.php and i think the following errors are based on that.

I hope this is enough information for a solution, will be prroviding more if neccessary, just tell.

I would appreciate some help by getting rid of this error Smiley
Thanks!
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
July 17, 2011, 08:15:41 PM
 #50

I installed the MiningFarm on a local testserver, and after some minor probs it seems to be doing pretty fine.
So at first: thanks Xenland for that great work.

But here comes the problem:
There seems to be a problem with the Cookie on my page, and i cant figure it out.
So here is what my apache2 log shows right after opening the page and logging in:

Code:

[Sun Jul 17 10:35:40 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: miningfarm#2 in /var/www/index.php on line 18
[Sun Jul 17 10:36:37 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined offset: 1 in /var/www/req/functions.php on line 184, referer: http://192.168.1.5/
[Sun Jul 17 10:37:23 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: miningfarm#2 in /var/www/index.php on line 18, referer: http://192.168.1.5/stats.php
[Sun Jul 17 10:37:39 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: show in /var/www/adminPanel.php on line 3, referer: http://192.168.1.5/
[Sun Jul 17 10:37:39 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: searchUsername in /var/www/adminPanel.php on line 4, referer: http://192.168.1.5/
[Sun Jul 17 10:37:39 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: act in /var/www/adminPanel.php on line 29, referer: http://192.168.1.5/
[Sun Jul 17 10:37:39 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: authPin in /var/www/adminPanel.php on line 30, referer: http://192.168.1.5/
[Sun Jul 17 10:37:39 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined variable: panelTitle in /var/www/adminPanel.php on line 172, referer: http://192.168.1.5/


Those errors are they're for developers you need to set your error_reporting to Production value settings(you can find this in your php.ini file)
if memory serves it should be like this
Quote
error_reporting = E_ALL & ~E_NOTICE

As for cookies make sure you don't have any anti-virus software blocking cookies and be sure to search up on how to enable cookies on your browser

What are your server specifications(VPS, Dedicated, Shared Hosting, Cloud, etc, etc)?

First line is where $rawCookie = $_COOKIE[$cookieName]; is in the index.php and i think the following errors are based on that.

I hope this is enough information for a solution, will be prroviding more if neccessary, just tell.

I would appreciate some help by getting rid of this error Smiley
Thanks!
TTB
Newbie
*
Offline Offline

Activity: 6


View Profile
July 19, 2011, 08:02:13 AM
 #51

Hi Xenland,

thx for the answer, i checked on that:

php.ini: correct statements
cookies: allowed (also when a friend of mine connected the output was the same)
edit: No anti virus preventing cookies

after installing the newest version of yours (cd8c45f) the output still looks like this:
Code:
[Tue Jul 19 09:34:36 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: miningfarm#2 in /var/www/index.php on line 18
[Tue Jul 19 09:34:37 2011] [error] [client 192.168.1.8] File does not exist: /var/www/favicon.ico, referer: http://192.168.1.5/
[Tue Jul 19 09:35:04 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: show in /var/www/adminPanel.php on line 3, referer: http://192.168.1.5/accountDetails.php
[Tue Jul 19 09:35:04 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: searchUsername in /var/www/adminPanel.php on line 4, referer: http://192.168.1.5/accountDe$
[Tue Jul 19 09:35:04 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: act in /var/www/adminPanel.php on line 29, referer: http://192.168.1.5/accountDetails.php
[Tue Jul 19 09:35:04 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: authPin in /var/www/adminPanel.php on line 30, referer: http://192.168.1.5/accountDetails.$
[Tue Jul 19 09:35:04 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined variable: panelTitle in /var/www/adminPanel.php on line 172, referer: http://192.168.1.5/accountD$
[Tue Jul 19 09:35:38 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: show in /var/www/adminPanel.php on line 3, referer: http://192.168.1.5/adminPanel.php
[Tue Jul 19 09:35:38 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: searchUsername in /var/www/adminPanel.php on line 4, referer: http://192.168.1.5/adminPane$
[Tue Jul 19 09:35:38 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: header in /var/www/adminPanel.php on line 35, referer: http://192.168.1.5/adminPanel.php
[Tue Jul 19 09:35:38 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: slogan in /var/www/adminPanel.php on line 37, referer: http://192.168.1.5/adminPanel.php
[Tue Jul 19 09:35:38 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined index: emailAuthRequired in /var/www/adminPanel.php on line 42, referer: http://192.168.1.5/admin$
[Tue Jul 19 09:35:38 2011] [error] [client 192.168.1.8] PHP Notice:  Undefined variable: panelTitle in /var/www/adminPanel.php on line 172, referer: http://192.168.1.5/adminPan$


Am I right all the undefined indexes are cookie-based? And do these errors affect the correct output of the page?
I have it running on a ubuntu (newest version) in a virtual machine on vm workstation.

Additional points:
 - cant see that added blog editor (where is it supposed to be?). Blog entries directly in DB are shown correctly on mainpage
 - payout threshhold does always show 0.5, but changed values are correctly inserted into DB, cant find the reason for that behavior ($getCredientals->threshhold seems to be empty, but dont know why)
 - theres a bug in worker page. if u update the shown worker name user.worker it will change to user.user.worker. i solved it by deleting the user show. (obv would be better if in the save to DB statement the "user." would be removed before saving, but my programming skills aren't as good to do that on the fly)
 - By using new Database table structure in updates (i.e. "coinType") it would be nice if the sql dump file would also be updated, just to prevent long searching for occurring errors based on missing fields
 - Am I right that the bitcoin / namecoin chosing option only affects the donations? As an idea i suggest to have all "BTC" statements on the pages as variables based on that choice one made (so i.e. automatic "BTC" or "NMC" account balance)

Thanks in advance for your help.

Edit 2: found out the posted errors ONLY occur when im logged in as admin. with a non admin user account no error messages except that "undefined index: miningfarm"..." occur.
sergio
Sr. Member
****
Offline Offline

Activity: 298


View Profile WWW
July 26, 2011, 11:13:51 AM
 #52

Hi Everyone, I have just set up a mining server based on xenland's version 5.1.4.

The server is http://www.bitcoinmoneda.com, it is in beta state since I just got it up and running.

I have a few questions, are there any known bugs that I should be aware of such on version 5.1.4, since no blocks have been found, the server it is not fully tested.

When browsing the site I get some apache error logs in regards to the database, such as  Undefined
index when php tries to access the database, however it seems to work, however it generates lots of apache error logs.

The other error I found was when loading the database on line 301 in miningfarm_database.sql

-- Dumping data for table `stats_topSharers`
--
'7', 0);
Had no clue where the '7', 0); belongs so I put it in the line above commented out, if you know  what line should be on the file please let me know.

The other problem is that chart for bitcoin value in fiat it is not working on my site, if someone could tell me where to look for the configuration or troubleshooting for that chart.

I think everything else is probably working, so if you would like to join the pool, that would be fantastic it will help test out the site, given the current difficulty level of finding a block, the more miners that join the better.

If you know of any known bugs please let me know, so that I can apply the fixes to the mining server.

Xenland, good job on the  bitcoin mining server software.
Thanks.



sergio
Sr. Member
****
Offline Offline

Activity: 298


View Profile WWW
July 26, 2011, 11:32:24 AM
 #53

Question in regard to mining server v5.1.4

Under account details, and then under Identity details, where it says:

JSON Mining & Worker Data

Righ below there is a very large string of characters that looks like a bitcoin address but it is not.

What is it?
Is it some sort of key ? something that is private ?

Is that something that needs to be changed?

Thanks,
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
July 26, 2011, 10:02:51 PM
 #54

Question in regard to mining server v5.1.4

Under account details, and then under Identity details, where it says:

JSON Mining & Worker Data

Righ below there is a very large string of characters that looks like a bitcoin address but it is not.

What is it?
Is it some sort of key ? something that is private ?

Is that something that needs to be changed?

Thanks,


Yeah that key is just for reference if anybody decides to integrate APIs with mining farm software they can take that key and paste it into a Mining Pool watch websites
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
July 26, 2011, 10:05:08 PM
 #55

Hi Everyone, I have just set up a mining server based on xenland's version 5.1.4.

The server is http://www.bitcoinmoneda.com, it is in beta state since I just got it up and running.

I have a few questions, are there any known bugs that I should be aware of such on version 5.1.4, since no blocks have been found, the server it is not fully tested.

When browsing the site I get some apache error logs in regards to the database, such as  Undefined
index when php tries to access the database, however it seems to work, however it generates lots of apache error logs.

The other error I found was when loading the database on line 301 in miningfarm_database.sql

-- Dumping data for table `stats_topSharers`
--
'7', 0);
Had no clue where the '7', 0); belongs so I put it in the line above commented out, if you know  what line should be on the file please let me know.

The other problem is that chart for bitcoin value in fiat it is not working on my site, if someone could tell me where to look for the configuration or troubleshooting for that chart.

I think everything else is probably working, so if you would like to join the pool, that would be fantastic it will help test out the site, given the current difficulty level of finding a block, the more miners that join the better.

If you know of any known bugs please let me know, so that I can apply the fixes to the mining server.

Xenland, good job on the  bitcoin mining server software.
Thanks.





Sorry about the MySql file error, I thought i fixed it with the latest update. Sounds like you got it working fine. The apache log errors are due to becuase you must set your PHP.ini file to Production Value error settings instead of the development.
sareea
Member
**
Offline Offline

Activity: 76


View Profile
August 10, 2011, 12:23:36 PM
 #56

Hello,
My M/hashes of the pool and the online workers are not being updated and shown .
What should i do ?
my cronjobs are set correctly , the statsupdater.php every 2 minutes.
And my worker is giving 300 M/Hashes/s

And there is no activateaccount.php file .
Pages: « 1 2 [3]  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!