Bitcoin Forum
December 05, 2016, 06:41:14 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: App SDK 2.1 Installation?  (Read 6334 times)
aceman1011
Full Member
***
Offline Offline

Activity: 142


View Profile
June 18, 2011, 01:53:17 PM
 #1

Could someone help me out with the installation of App SDK 2.1? I found it in the archives page on ATI's website, but I can't seem to replace SDK 2.4 with it.
Here's the download page: http://developer.amd.com/sdks/AMDAPPSDK/downloads/pages/AMDAPPSDKDownloadArchive.aspx

Rent my 800 + mh/s rig. PM me!
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
whenhowwho
Member
**
Offline Offline

Activity: 96



View Profile
June 20, 2011, 03:32:33 PM
 #2

uninstall 2.4 then install 2.1

1HUy7T9SyNLTJCVX3p8KzftApYdWgcsRqD
aceman1011
Full Member
***
Offline Offline

Activity: 142


View Profile
June 20, 2011, 04:32:04 PM
 #3

Ah, forgot to post that I solved this. I figured out that out of the 2.1 package you only need the V2 development package, not anything else like the stream kernel anlyzer or V2 samples.

Rent my 800 + mh/s rig. PM me!
whenhowwho
Member
**
Offline Offline

Activity: 96



View Profile
June 21, 2011, 05:10:27 PM
 #4

well at least ya got it sorted

1HUy7T9SyNLTJCVX3p8KzftApYdWgcsRqD
king_pin
Sr. Member
****
Offline Offline

Activity: 375



View Profile WWW
February 14, 2013, 06:17:10 PM
 #5

Can anyone give me a download location for SDK 2.1
Thank you

Help to save a persons life with BITCOIN - http://www.bitcoinsaves.org/en/
crazyates
Legendary
*
Offline Offline

Activity: 938



View Profile
February 14, 2013, 11:17:31 PM
 #6

I dont think you can DL 2.1 anymore. Is there any reason you need 2.1, where 2.5 won't work?

Tips? 1crazy8pMqgwJ7tX7ZPZmyPwFbc6xZKM9
Previous Trade History - Sale Thread
ssateneth
Legendary
*
Offline Offline

Activity: 1288



View Profile
February 15, 2013, 03:00:44 AM
 #7

Here is the installer for 2.1 SDK. It does not contain any of the extra stuff (kernel analyzer, etc). This is the only thing you need as far as an openCL platform for mining is concerned. https://dl.dropbox.com/u/9768004/ATIStreamSDK_dev.msi

Also I found cgminer/bfgminer and guiminer won't find 2.1 SDK normally. Install 2.4/2.5/2.6, then install 2.1 after that (11.12 or 12.1 driver is recommended for 2.1 SDK). Doing it in reverse will cause the higher version to remove access to 2.1. 2.1 will not replace the higher version; it will coexist. You can use GPU Caps Viewer to confirm the installation of opencl platforms. You will need to specify the correct platform to mine on. Pre-2.0 Phoenix uses the PLATFORM command. In 2.0 or higher, the number in bold red specifies the platform.

[cl:1:2]
name = GPU name
kernel = phatk2
AGGRESSION = 3
VECTORS = true
BFI_INT = true
WORKSIZE = 128

In CG/BFGMiner, specify the platform with the "gpu-platform" argument. For me, it's "gpu-platform" : 1 (I use a config file)

king_pin
Sr. Member
****
Offline Offline

Activity: 375



View Profile WWW
February 15, 2013, 01:02:24 PM
 #8

Thank you, but I need the DLL files, because I don't want to use 2-3 platforms on one PC.

Help to save a persons life with BITCOIN - http://www.bitcoinsaves.org/en/
zvs
Legendary
*
Offline Offline

Activity: 1386



View Profile WWW
February 15, 2013, 07:49:39 PM
 #9

i have it at www.nogleg.com/archive/ATIStreamSDK_2.1_dev.msi    

as well (this must be whole package though, based on size.. well, yeah, since it's dev)

what files would be diff for 2.1?  i guess i could run it

Dacentec, best deals for US dedicated servers. They regularly restock $20-$25 Opterons with 8-16GB RAM & 2x1-2TB HDD's (ofc, usually lots of other good stuff to choose from).  I did a Serverbear benchmark of one of my $20/mo Opteron (June last year), it's here.  Have had about a half dozen different servers with Dacentec, & none have failed to sustain at least 40MB/s (burst higher). My favorite is a 12-month rent-to-own ZT Systems 2XL5520 16GB 2x2TB SATA for $40/month (got lucky with the 'off-brand', haven't seen a RTO 2xL5520 for under $50/mo since -- at least for monthly contracts).  wholesaleinternet.com has some ancient 2-core intel CPUs @ $10/mo sometimes (I got an Intel Core 2 6300 @ 1.86GHz, with a 250GB HDD with 46000 hours on it, LOL. $20 @ Dacentec is much better, if you can grab one). joesdatacenter.com (same location as Wholesale Internet) also occasionally has specials (or if you don't want to wait, it has an AMD Opteron 170 @ $16/mo).
king_pin
Sr. Member
****
Offline Offline

Activity: 375



View Profile WWW
February 15, 2013, 10:35:14 PM
 #10

U can install the 2.1 SDK but I need change to PLATFORM 2 and I just want to replace the .dll files which are:

Windows\System32\amdocl64.dll
Windows\System32\amdoclcl64.dll
Windows\System32\OpenCL.dll

Windows\SysWOW64\amdocl.dll
Windows\SysWOW64\amdoclcl.dll
Windows\SysWOW64\OpenCL.dll

Help to save a persons life with BITCOIN - http://www.bitcoinsaves.org/en/
ssateneth
Legendary
*
Offline Offline

Activity: 1288



View Profile
February 16, 2013, 12:29:36 AM
 #11

U can install the 2.1 SDK but I need change to PLATFORM 2 and I just want to replace the .dll files which are:

Windows\System32\amdocl64.dll
Windows\System32\amdoclcl64.dll
Windows\System32\OpenCL.dll

Windows\SysWOW64\amdocl.dll
Windows\SysWOW64\amdoclcl.dll
Windows\SysWOW64\OpenCL.dll


2.1 doesn't work like that. Thats why you can have 2.1 installed along side of 2.4/2.5/2.6. As far as I know, it's not possible to just drop in some DLL files and it works magically like 2.4 or higher. You need to run the installer.. The 2.1 SDK files are installed somewhere else and are not the same filename or filetype.

king_pin
Sr. Member
****
Offline Offline

Activity: 375



View Profile WWW
February 16, 2013, 11:29:38 PM
 #12

IDK, I've never reverted to anything lower than SDK 2.5, but I'm thinking of downclocking my mem to 150-160 for some more efficiency against the ASIC threat.

Help to save a persons life with BITCOIN - http://www.bitcoinsaves.org/en/
PatMan
Hero Member
*****
Offline Offline

Activity: 924


Watch out for the "Neg-Rep-Dogie-Police".....


View Profile WWW
February 27, 2013, 12:41:18 AM
 #13

I've not found a better performing SDK than v2.1, it's still the king. And yes, you must install it after installing the higher vSDK or it will not register/be found by your miner.

"When one person is deluded it is called insanity - when many people are deluded it is called religion" - Robert M. Pirsig.  I don't want your coins, I want change.
Amazon UK BTC payment service - https://bitcointalk.org/index.php?topic=301229.0 - with FREE delivery!
http://www.ae911truth.org/ - http://rethink911.org/ - http://rememberbuilding7.org/
StelioKontos
Jr. Member
*
Offline Offline

Activity: 57


View Profile
December 09, 2013, 12:33:15 AM
 #14

Hi, I need some help.

*edit*: I'm realizing I'm posting this here but I'm actually mining LTCs not BTCs, well my brain is gone lol. If you can help me anyway I'd appreciate Wink

Win 7 64-bit / cgminer 3.7.2 / HD5870 (CPU 875Mhz, MEM 1250Mhz)

I've been using AMD drivers 13.9 with the bundled OpenCL for some days but I'm not satisfied with the performances, around 360Mh/s but with -I 15 and temperature of 88-89.5 C, very HIGH if compared with the ones I've read in other threads in this forum of around 60-70 C ( how do you do that guys btw?! Sad )

So I decided to change the drivers/opencl configuration according to what it's best that it's told to be AMD 11.12 and OpenCL 2.1

It wasn't easy to download them but I finally found them:

11-12_vista64_win7_64_dd_ccc_enu.exe
ATIStreamSDK_dev.msi (opencl 2.1)

So I rebooted in safe mode to remove current display drivers and used an utility found on guru3d, DDU: DDU v9.8.4.exe It worked nice resolution went to 800x600. Did a search for opencl.dll in c:\ and no results were found.

Installed 11.12, rebooted

Installed ATIStreamSDK_dev.msi and according to this, it seems it got installed as platform 2. My gpu cypress is listed as #2 device while the #1 is my cpu i5 750:



Deleted a .bin file in cgminer folder because I read it is compiled according old version of OpenCL so it cgminer would crash.

Now, my cgminer bat file was:

Quote
color 02
setx GPU_MAX_ALLOC_PERCENT 100
D:\cgminer-3.7.2-windows\cgminer.exe --scrypt -o stratum+tcp://lite.coin-pool.com:3333 -u user -p pass -I 15 --thread-concurrency=8000

If I run the same way, I get exactly same Mh/s 360 and 88 C as temperature as before Sad

So I suppose I have to switch to platform 2 and according to cgminer's help it's done with --gpu-platform. Here I don't know if platforms starts from 0 but if the default is -1 I suppose starts from 1, so I tried adding this to cgminer command line:

Quote
color 02
setx GPU_MAX_ALLOC_PERCENT 100
D:\cgminer-3.7.2-windows\cgminer.exe --scrypt -o stratum+tcp://lite.coin-pool.com:3333 -u user -p pass -I 15 --thread-concurrency=8000 --gpu-platform 2

If I run this, I get this:



"clDevicesNum returned error, no GPUs usable"

Any idea how to fix this? Sad
ssateneth
Legendary
*
Offline Offline

Activity: 1288



View Profile
December 11, 2013, 06:07:17 AM
 #15

Cant mine scrypt on sdk 2.1

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!