Bitcoin Forum
December 05, 2016, 04:41:15 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: 5870 overclocking and fan speed [I do donate]  (Read 1655 times)
xioros
Jr. Member
*
Offline Offline

Activity: 56


View Profile
June 19, 2011, 02:45:17 PM
 #1

Hi,

I've just done a clean linux install...
Hashkill works excellent Smiley
But...
It shuts of one of my cards because of overheating...

I used the command:
aticonfig --adapter=x --pplib-cmd "set fan speed 0 100"
I get:
Command succesfull

used it on all my adapters..
However, they won't take off...
they keep running @ standard speed

How do I get my cards running @ max fan speed?

also:

My limits are 900/900 ( core , memory)
How do I get my core higher and my mem lower?

Grtz

/Xio Out

Donate if I helped you :  1L3GxCRZwXEh8VwpPAociZQdTkhSHKGMoY
1480956075
Hero Member
*
Offline Offline

Posts: 1480956075

View Profile Personal Message (Offline)

Ignore
1480956075
Reply with quote  #2

1480956075
Report to moderator
1480956075
Hero Member
*
Offline Offline

Posts: 1480956075

View Profile Personal Message (Offline)

Ignore
1480956075
Reply with quote  #2

1480956075
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
smoki
Jr. Member
*
Offline Offline

Activity: 33


View Profile
June 19, 2011, 03:01:10 PM
 #2

You need to do:

export DISPLAY=:0.0
aticonfig --pplib-cmd "set fanspeed 0 100"

export DISPLAY=:0.1
aticonfig --pplib-cmd "set fanspeed 0 100"

and so on, for all your adapters.

edit: missed the question about changing clocks. To over/underclock, use:
aticonfig --od-setclocks=950,300 --adapter=0

That would set your first video card (adapter=0) to gpu clock 950 and memory clock 300.

19Wsi1QNn7A9YHwbQsjXz4tWxdu72HQ8zM (just in case Smiley)
hugolp
Hero Member
*****
Offline Offline

Activity: 742



View Profile
June 19, 2011, 03:15:07 PM
 #3

To overclock in Linux is better to use AMDOverdriveCtrl. Google it.
xioros
Jr. Member
*
Offline Offline

Activity: 56


View Profile
June 19, 2011, 04:44:11 PM
 #4

thx for the fan command , it works Smiley
Donated 0.2 BTC ( poor right now ^^)

But I can't set the clocks:

ERROR: Set clocks failed for apator 0 Ati radeon 5800 series
Please check that the input values were valid

About AtioverdriveCtrl,
Where can I find a 32 bit version?
I could only find x64 :s

Donate if I helped you :  1L3GxCRZwXEh8VwpPAociZQdTkhSHKGMoY
smoki
Jr. Member
*
Offline Offline

Activity: 33


View Profile
June 19, 2011, 07:08:18 PM
 #5

Strange, I can set the clocks for my two 5870s with aticonfig that are outside the 'Configurable Peak Range'. Might have something to do with the fact that I flashed their bios with already altered clocks (to 920/354). In my case aticonfig reports the range as 600-900 for gpu and 354-1300 for memory, but I'm running them at 950/200 (set with aticonfig). Maybe it's because both clocks set in the bios are already outside of aticonfig's range.

I would use AMDOverdriveCtrl, but my rig is in the basement, without a monitor, keyboard or mouse, so I only control it over ssh. Guess I should have set up a vnc server while I had a monitor still attached Smiley.

19Wsi1QNn7A9YHwbQsjXz4tWxdu72HQ8zM (just in case Smiley)
padrino
Legendary
*
Offline Offline

Activity: 1260



View Profile
June 20, 2011, 02:09:00 AM
 #6


That's because aticonfig can't set values outside of the gpu bios limit.

Get 32bit AMDOverdriveCtrl here:
http://sourceforge.net/projects/amdovdrvctrl/files/deb%20binaries/amdoverdrivectrl_1.2.1_i386.deb/download

As far as I know AMDOverdriveCtrl cannot set them either. I just gave it a shot on my system and it works fine for anything within the bios limit but cannot set anything outside of the limit. Any insight on how to get the tool to do this, happy to send a donation.

1CPi7VRihoF396gyYYcs2AdTEF8KQG2BCR
hugolp
Hero Member
*****
Offline Offline

Activity: 742



View Profile
June 20, 2011, 04:50:58 AM
 #7

Strange, I can set the clocks for my two 5870s with aticonfig that are outside the 'Configurable Peak Range'. Might have something to do with the fact that I flashed their bios with already altered clocks (to 920/354). In my case aticonfig reports the range as 600-900 for gpu and 354-1300 for memory, but I'm running them at 950/200 (set with aticonfig). Maybe it's because both clocks set in the bios are already outside of aticonfig's range.

I would use AMDOverdriveCtrl, but my rig is in the basement, without a monitor, keyboard or mouse, so I only control it over ssh. Guess I should have set up a vnc server while I had a monitor still attached Smiley.

You can use AMCOverdriveCtrl from the command line using configuration files. Use the option -b.
Folax
Full Member
***
Offline Offline

Activity: 126


View Profile
June 21, 2011, 04:21:47 PM
 #8

To overclock in Linux is better to use AMDOverdriveCtrl. Google it.
I use this too for my 2 5870s on Linux (LinuxCoin install) and works great!

My GF thinks I'm useless, if you think otherwise and can proof it to her, please do so and donate:
14wG6u2bAD9q1nLmLL9MST1ZzbTE9Pt8nG
detroit
Member
**
Offline Offline

Activity: 70


View Profile
June 21, 2011, 05:40:40 PM
 #9

Upgrade your Catalyst installation to 11.6 and you can pump your overclock beyond the BIOS limits.

Tradehill.com referral code: TH-R1494
Please consider using it if I've said something useful!
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!