Bitcoin Forum
August 17, 2017, 03:51:37 PM *
News: Latest stable version of Bitcoin Core: 0.14.2  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: [ANN] explorerz.top - cheap and reliable block explorer  (Read 189 times)
whywefight
Hero Member
*****
Offline Offline

Activity: 812


www.explorerz.top


View Profile
July 03, 2017, 08:53:37 PM
 #1



Hey all,

We are offering to host block explorers. You can have a look at those we currently host at explorerz.top
The annual fee is 0.05BTC. For new promising projects, we might accept an amount of the coin itself but will depend on what my research brings up.

If you have any questions feel free to post here or should me a PM.

regards

1502985097
Hero Member
*
Offline Offline

Posts: 1502985097

View Profile Personal Message (Offline)

Ignore
1502985097
Reply with quote  #2

1502985097
Report to moderator
1502985097
Hero Member
*
Offline Offline

Posts: 1502985097

View Profile Personal Message (Offline)

Ignore
1502985097
Reply with quote  #2

1502985097
Report to moderator
1502985097
Hero Member
*
Offline Offline

Posts: 1502985097

View Profile Personal Message (Offline)

Ignore
1502985097
Reply with quote  #2

1502985097
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
whywefight
Hero Member
*****
Offline Offline

Activity: 812


www.explorerz.top


View Profile
July 24, 2017, 08:28:12 PM
 #2

We did a new landing page. Currently, we host explorers for:

DAS
ARC
YST
ENT

Also our Twitter is up now Smiley

whywefight
Hero Member
*****
Offline Offline

Activity: 812


www.explorerz.top


View Profile
August 07, 2017, 06:53:16 PM
 #3

The following coins have been removed as they were hosted for free and seem to be dead:

YST
ENT
ARC
QWT

We added:

USDe

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!