Bitcoin Forum
December 10, 2016, 01:34:50 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: 5850 underclocking itself  (Read 2868 times)
CNMOH
Jr. Member
*
Offline Offline

Activity: 56



View Profile
June 21, 2011, 02:02:37 PM
 #1

So I've been mining for a while now with my two gaming computers, and I wanted to do some slight overclocking to increase my earnings a bit. I overclock my HD 5850 from core speed 725 mhz to 775 mhz. I gain ~30 mhash/s, and everything seems to be fine. But then after a couple of hours, I see my hashrate drops to 150 mhash/s. I open up the CCC and see that clock speed has been dropped to somewhere in the 400 mhz range. I try setting the clock back to default, I even try underclocking it, but nothing works. I then restart my computer, and everything works fine again. I try again, but the same thing happens.

Why does this happen? Is it a security measure when the card gets overheated? The card runs at between 75 - 82 degrees, overclocking doesn't seem to make much of a difference temperature-wise.

Thanks in advance.

1481333690
Hero Member
*
Offline Offline

Posts: 1481333690

View Profile Personal Message (Offline)

Ignore
1481333690
Reply with quote  #2

1481333690
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Jack of Diamonds
Sr. Member
****
Offline Offline

Activity: 252



View Profile
June 21, 2011, 04:53:45 PM
 #2

How well is the card ventilated otherwise?
82c is just the core temp of the chip.

If the VRM (voltage regulator module) goes above 140 celsius, the card will throttle down & use less power to prevent destruction.

82c core clock is not nearly enough for automatic throttling, it would need to be at least 95-105 before it started clocking itself down

1f3gHNoBodYw1LLs3ndY0UanYB1tC0lnsBec4USeYoU9AREaCH34PBeGgAR67fx
RyNinDaCleM
Legendary
*
Offline Offline

Activity: 2002


Legen -wait for it- dary


View Profile
June 21, 2011, 05:17:19 PM
 #3

If temps aren't the problem, try this!
Go into the registry {Run->regedit}
Find this key: [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E968-E325-11CE-BFC1-08002BE10318}]
use the Find Next function in the Edit drop down menu and find all occurrences of "EnableULPS". Right click->modify, and set to 0!
Find next, and repeat!
There may be 10 of these (maybe more, maybe less)!
ULPS or Ultra Low Power State, is standard on ALL ATI/AMD display drivers since 9.x! Changing these settings, will force your card to run at defined clocks, but only if temp throttling isn't what is happening in your situation!

CNMOH
Jr. Member
*
Offline Offline

Activity: 56



View Profile
June 24, 2011, 02:30:28 PM
 #4

I've done some experimenting, and I've discovered that:

1. Sometimes, although rarely, the downclocking will happen even when I haven't overclocked the card.

2. Running a GPU-intensive application, such as a game, resets the card to normal clocks.

I've done the registry hack that RyNinDaCleM suggested, but it made no difference.

Brutus
Newbie
*
Offline Offline

Activity: 26


View Profile
June 24, 2011, 08:53:14 PM
 #5

I'm just going to guess this is a windows machine as you said it was also a gaming machine.

If that's the case have you checked the power plan settings in the Control Panel (win 7)?  This happened on a notebook with a mobility 5850 in that the OS would downclock the chip.  Def apples to oranges but the desktop ver of Win 7 should still have the Power Plan settings that can be adjusted.

Under the Power Plan settings set to High Performance and then click the Advanced link and make sure the ATI Graphics Power Settings are set to Maximize Performance.

I also set the screen saver to none, not blank but none.

...
CNMOH
Jr. Member
*
Offline Offline

Activity: 56



View Profile
June 25, 2011, 05:54:52 PM
 #6

I couldn't find any ATI Graphics Power Settings, so I'm guessing that's mobility-exclusive. However, I turned off Link State Power Management. I'm not completely sure what this does, but hopefully it helps. My screensaver was already set to none.

CNMOH
Jr. Member
*
Offline Offline

Activity: 56



View Profile
June 30, 2011, 11:20:56 AM
 #7

Problem solved!

In case anyone has the same problem:

Oddly enough, this problem was caused by Flash. For some reason, Youtube + Chrome + Hardware acceleration downclocks the card. I have not tested this with my other rig to see if it happens there as well, and I have not tested it with any other browsers, nor have I tested it with different Flash sites. So I don't know if this is a universal Flash thing or not. Either way, there are two ways to solve this:

1. Don't watch Youtube videos. And if you do, make sure to close the tab/window afterwards, as even when idle, Flash seems to downclock the card.

2. (much better solution) Turn off hardware acceleration. Right click -> Settings -> Uncheck "Enable hardware acceleration"

IlbiStarz
Full Member
***
Offline Offline

Activity: 224


View Profile
July 02, 2011, 06:00:11 AM
 #8

That's AMD PowerPlay for you Cheesy

It's better to be pissed off, than to be pissed on.
BTC : 1UgM1rqL9mFtH4PHF8TgvAaceymaKmhmP         LTC : LgCGw2WrRphr94RYS1qXHj2PUuYrTap4vk
FC : 6jc9PEmqxpMSxydfepHtshE4f2jMom1dAJ
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!