Bitcoin Forum
October 20, 2017, 06:35:23 PM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1] 2 3  All
  Print  
Author Topic: Linux Driver for Blockchain Compute 17.30.1029  (Read 9482 times)
Coyn
Jr. Member
*
Offline Offline

Activity: 36

Coyn - Your Coins


View Profile WWW
August 19, 2017, 10:52:16 AM
 #1

We all know that the new Radeon Software Crimson ReLive Edition Beta for Blockchain Compute Driver Version 17.30.1029 was released for Windows a few days ago.
When is this driver actually going to be compiled for Linux? We really need it AMD. Most of the huge farms are running on Linux.

Fix it!  Grin
1508524523
Hero Member
*
Offline Offline

Posts: 1508524523

View Profile Personal Message (Offline)

Ignore
1508524523
Reply with quote  #2

1508524523
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
QuintLeo
Hero Member
*****
Offline Offline

Activity: 854


View Profile
August 19, 2017, 08:47:47 PM
 #2

Try posting on AMD's website, they MIGHT pay attention to that.

 IMO AMD dropped the ball BADLY when they released this driver for Windows AND NOT FOR LINUX, since the bulk of cryptocoin rigs run LINUX.

cpunkt
Newbie
*
Offline Offline

Activity: 6


View Profile
August 29, 2017, 08:48:04 AM
 #3

Here is the solution:
The new ROCm Kernel works great, my hashrate went from 155 > 167Mhs/s with 6*RX470 with Ubuntu 16.4

#Install new ROCm Kernel:

wget -qO - http://repo.radeon.com/rocm/apt/debian/rocm.gpg.key | sudo apt-key add -
sudo sh -c 'echo deb [arch=amd64] http://repo.radeon.com/rocm/apt/debian/ xenial main > /etc/apt/sources.list.d/rocm.list'
sudo apt-get update
sudo apt-get install rocm

#edit grub
sudo nano  /etc/default/grub
#2MB fragments for Ellesmere are enabled with a grub option:
GRUB_CMDLINE_LINUX="amdgpu.vm_fragment_size=9"

sudo update-grub
sudo reboot

choose new Kernel and its done!

Thx to gstoner from ROCm Github.


Feel free to donate if you happy ;-)

ETH:0xccad3d66b29ae2924df835df1417169ca59943b5
BTC:12F7uXSpTwVhf4ppdh92uieAvrevZ4ShEf

Greetz
parshuram
Jr. Member
*
Offline Offline

Activity: 38


View Profile
August 29, 2017, 01:16:37 PM
 #4

This does not works in ethos ! Anything else?
drrobert
Full Member
***
Offline Offline

Activity: 129


View Profile
August 29, 2017, 04:09:42 PM
 #5

did you try with last from amd website 17.30... ?
parshuram
Jr. Member
*
Offline Offline

Activity: 38


View Profile
August 29, 2017, 05:08:33 PM
 #6

did you try with last from amd website 17.30... ?

No...How?
drrobert
Full Member
***
Offline Offline

Activity: 129


View Profile
August 29, 2017, 05:47:15 PM
 #7

did you try with last from amd website 17.30... ?

No...How?
bit easy go on amd web site and get amd for linux there is instruction to install driver
cabledevil
Newbie
*
Offline Offline

Activity: 1


View Profile
August 29, 2017, 06:11:25 PM
 #8

Here is the solution:
The new ROCm Kernel works great, my hashrate went from 155 > 167Mhs/s with 6*RX470 with Ubuntu 16.4

#Install new ROCm Kernel:

wget -qO - http://repo.radeon.com/rocm/apt/debian/rocm.gpg.key | sudo apt-key add -
sudo sh -c 'echo deb [arch=amd64] http://repo.radeon.com/rocm/apt/debian/ xenial main > /etc/apt/sources.list.d/rocm.list'
sudo apt-get update
sudo apt-get install rocm

#edit grub
sudo nano  /etc/default/grub
#2MB fragments for Ellesmere are enabled with a grub option:
GRUB_CMDLINE_LINUX="amdgpu.vm_fragment_size=9"

sudo update-grub
sudo reboot

choose new Kernel and its done!

Thx to gstoner from ROCm Github.


Feel free to donate if you happy ;-)

ETH:0xccad3d66b29ae2924df835df1417169ca59943b5
BTC:12F7uXSpTwVhf4ppdh92uieAvrevZ4ShEf

Greetz

Thank you very much!!! It works!! Went from 18.7mh to 19.9mh on an r9 380
jstefanop
Hero Member
*****
Offline Offline

Activity: 726


View Profile
August 29, 2017, 06:37:04 PM
 #9

I worked with gstoner at AMD to fix this on linux side. Donations welcome Tongue

www.AriseChickun.com 0% fee segwit signaling Litecoin Pool!
FutureBit Moonlander USB Scrypt Stick Miner: https://bitcointalk.org/index.php?topic=1256818.0
LTC:LX5vpxrQE4eLRLPobKwZhw2comkKFCh3p4 - BTC:14w9Lea6kdVzspJk8TQRe7qSYu9LhzJJsh
Serdar_Aydin
Newbie
*
Offline Offline

Activity: 2


View Profile
August 30, 2017, 08:40:50 PM
 #10

Dear Friends,
i tried on two rig, all rig has RX570 GPU,
i complated all steps but system does not working.
when system complate reboot process, it can not connect  mining pool (eu1.ethermine.org:4444) Sad((
badgrav
Newbie
*
Offline Offline

Activity: 1


View Profile
August 30, 2017, 10:03:05 PM
 #11

Dear Friends,
i tried on two rig, all rig has RX570 GPU,
i complated all steps but system does not working.
when system complate reboot process, it can not connect  mining pool (eu1.ethermine.org:4444) Sad((


Me too on rig with 6 of RX 480, tried it twice, no change, and can not connect too..
fandemonium
Newbie
*
Offline Offline

Activity: 2


View Profile
August 31, 2017, 06:19:46 AM
 #12

Here is the solution:
The new ROCm Kernel works great, my hashrate went from 155 > 167Mhs/s with 6*RX470 with Ubuntu 16.4

#Install new ROCm Kernel:

wget -qO - http://repo.radeon.com/rocm/apt/debian/rocm.gpg.key | sudo apt-key add -
sudo sh -c 'echo deb [arch=amd64] http://repo.radeon.com/rocm/apt/debian/ xenial main > /etc/apt/sources.list.d/rocm.list'
sudo apt-get update
sudo apt-get install rocm

#edit grub
sudo nano  /etc/default/grub
#2MB fragments for Ellesmere are enabled with a grub option:
GRUB_CMDLINE_LINUX="amdgpu.vm_fragment_size=9"

sudo update-grub
sudo reboot

choose new Kernel and its done!

Thx to gstoner from ROCm Github.


Feel free to donate if you happy ;-)

ETH:0xccad3d66b29ae2924df835df1417169ca59943b5
BTC:12F7uXSpTwVhf4ppdh92uieAvrevZ4ShEf

Greetz


Has anyone managed to get this working on ethOS? Any instructions for it?
osnwt
Sr. Member
****
Offline Offline

Activity: 249


View Profile
August 31, 2017, 08:03:05 AM
 #13

I worked with gstoner at AMD to fix this on linux side. Donations welcome Tongue

I tried 2 scenarios to install that and both had failed.

#1: ubuntu-16.04.2 server with already installed amdgpu-17.10 (running system).
Attempt to install rocm failed at amdgpu module rebuild stage (version 17.10).
Attempt to boot new kernel resulted in black screen during kernel start at the moment when a video mode should be changed.

#2: ubuntu-16.04.3 desktop (new installation, no yet amdgpu driver - used built-in one).
rocm installation succeeded, after reboot the new kernel is running well.
Attempt to install amdgpu-17.30 failed at module rebuild stage: "headers 4.11 not supported" message, build log contains errors with incompatible argument types of atomic vs struct.
Original amdgpu driver (built-in) mining with the same hash rate as before (2 MH/s lower that it does on Windows).

Any hints from those who has it working: your ubuntu version, amdgpu version (if not built-in), order of installation?
osnwt
Sr. Member
****
Offline Offline

Activity: 249


View Profile
August 31, 2017, 04:43:50 PM
 #14

I tried 2 scenarios to install that and both had failed.
Any hints from those who has it working: your ubuntu version, amdgpu version (if not built-in), order of installation?

Success!

HowTo:
1) Install ubuntu 16.04.3.
2) Install rocm as described above.
3) Add amdgpu parameter as described above. It is the key to success, don't miss that step.
4) Install amdgpu-17.30 as told by AMD.
Kernel module build fails, but correct driver is in the rocm installation. AMD driver is necessary for libOpenCL, etc.
5) Overclock using any tool (if desired).
6) Enjoy!

ETH hashrate under linux seems to be 0.3MH/s lesser than on Windows, it is a known issue and probably just measurement difference (see Claymore's FAQ).

But I should be able to run more than 8 cards per MB, will try ASAP.
laik2
Sr. Member
****
Offline Offline

Activity: 336


View Profile
August 31, 2017, 08:56:32 PM
 #15

I tried 2 scenarios to install that and both had failed.
Any hints from those who has it working: your ubuntu version, amdgpu version (if not built-in), order of installation?

Success!

HowTo:
1) Install ubuntu 16.04.3.
2) Install rocm as described above.
3) Add amdgpu parameter as described above. It is the key to success, don't miss that step.
4) Install amdgpu-17.30 as told by AMD.
Kernel module build fails, but correct driver is in the rocm installation. AMD driver is necessary for libOpenCL, etc.
5) Overclock using any tool (if desired).
6) Enjoy!

ETH hashrate under linux seems to be 0.3MH/s lesser than on Windows, it is a known issue and probably just measurement difference (see Claymore's FAQ).

But I should be able to run more than 8 cards per MB, will try ASAP.

1.Download latest linux 4.12.10 from kernel.org
2.Apply patches from here: https://patchwork.freedesktop.org/project/amd-xorg-ddx/series/?ordering=-last_updated( more advanced way)
3.Compile kernel -> the ubuntu way.
4.Install kernel using dpkg
5. Download amdgpu-pro-17.30 latest, unarchive and edit amdgpu-pro-install, under the --compute function remove amdgpu-pro-dkms.
6. Exec ./amdgpu-pro-install --compute to install only opencl and libdrm
7. dpkg -x amdgpu-pro-dkms.... /out; cd out/usr/src/amdgpu-pro/lib/firmware && rm /lib/firmware/amdgpu/* && cp * /lib/firmware/amdgpu
8. add amdgpu.vm_fragment_size=9 to /etc/default/grub as stated in previous posts.
8.1. add if you are using user to video group usermod -a -G video $user
9. update-grub && update-initramfs -u
10. Reboot and mine.



ZEC: t1KbbHtXqzSS6qHBaPZDKyWnzxhRjr9oCtW
osnwt
Sr. Member
****
Offline Offline

Activity: 249


View Profile
September 01, 2017, 04:13:46 AM
 #16

Much better way, does not pull whole rocm.
But which patches to apply from the link above? All?
cococo42
Newbie
*
Offline Offline

Activity: 14


View Profile
September 01, 2017, 06:12:46 AM
 #17

It works but, as I've said on SMOS thread, using roc kernel and changing boot parameter makes power consumption goes from 1150W to 1550W (on the wall, at least on my rx580 rig). Have you checked your power consumption after this change?
drrobert
Full Member
***
Offline Offline

Activity: 129


View Profile
September 01, 2017, 06:18:04 AM
 #18

It works but, as I've said on SMOS thread, using roc kernel and changing boot parameter makes power consumption goes from 1150W to 1550W (on the wall, at least on my rx580 rig). Have you checked your power consumption after this change?

I use roc kernel on smos and consume it is the same, maybe you changed power step (consume is setup at level of bios of gpu, i have steps from 2 to 7 to my target voltage), check them on console.
cococo42
Newbie
*
Offline Offline

Activity: 14


View Profile
September 01, 2017, 06:44:25 AM
 #19

It works but, as I've said on SMOS thread, using roc kernel and changing boot parameter makes power consumption goes from 1150W to 1550W (on the wall, at least on my rx580 rig). Have you checked your power consumption after this change?

I use roc kernel on smos and consume it is the same, maybe you changed power step (consume is setup at level of bios of gpu, i have steps from 2 to 7 to my target voltage), check them on console.

I've followed these steps:

wget -qO - http://repo.radeon.com/rocm/apt/debian/rocm.gpg.key | sudo apt-key add -
sudo sh -c 'echo deb [arch=amd64] http://repo.radeon.com/rocm/apt/debian/ xenial main > /etc/apt/sources.list.d/rocm.list'
sudo apt-get update
sudo apt-get install rocm

#edit grub
sudo nano  /etc/default/grub
#2MB fragments for Ellesmere are enabled with a grub option:
GRUB_CMDLINE_LINUX="amdgpu.vm_fragment_size=9"

sudo update-grub
sudo reboot

And I haven't changed bios, oc parameters,... So, I have a few questions:
- how to check these power steps on linux console?
- how to change them?
- my power consumption at wall were too high also before change (4x rx580 @ 1150W at wall) with smos (oc 1175-2250 dpm state 2). what about yours?

Thank you in advance
osnwt
Sr. Member
****
Offline Offline

Activity: 249


View Profile
September 01, 2017, 07:17:27 AM
 #20

It works but, as I've said on SMOS thread, using roc kernel and changing boot parameter makes power consumption goes from 1150W to 1550W (on the wall, at least on my rx580 rig). Have you checked your power consumption after this change?
On Windows I had 1162W. After switch to this kernel on Linux I tried to downvolt my rx470 by changing voltage table offsets in the DPM stages (that is, set offset of stage 4 or 6, or directly 1000-1050mV, to stage 7, so power consumption is lesser). At the same time I overclock memory and downclock GPU (mostly the same as on Windows). Used ohgodatool for that in realtime.

At the moment I was unable to get the same power consumption, it went from 1162 to 1300 now.

I know that it is not the best way to downvolt. I tried to change VDDC offset in the BIOS (since realtime VDDC change tools are not publicly available, and I have too few cards to hack it myself). This way works with my Sapphire cards, but it requires many reflashes when tuning every card for a stable operation. So I hoped to use only software ways to overclock and downvolt without changing BIOS (except timings).

Probably I have to use the BIOS way anyway if I want a comparable consumption to Windows rig.

As for the hashrate: even if displayed rates are bit lower (Claymore's miner) than on Windows, actual pool rates are the same. So the consumption is only my headache yet.
Pages: [1] 2 3  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!