Bitcoin Forum
December 05, 2016, 04:38:26 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1] 2 »  All
  Print  
Author Topic: Ubuntu Blacks Out  (Read 3338 times)
||bit
Hero Member
*****
Offline Offline

Activity: 644


View Profile
June 22, 2011, 11:11:43 PM
 #1

Repost from  the techical forum - which found no help. So, figured the miners would know Smiley

I'm new to linux. I loaded Ubuntu 11.04, and then set up the mining rig using these instructions (6xxx install for 64 bit cpu):
http://forum.bitcoin.org/index.php?topic=7514.0

I did choose to install the SSH option just in case I use it later... figured it would not hurt to have the option installed for some later time I might experiment with it.

Symptoms:
I start up Ubuntu. Open a terminal and run one of the four miner instances (two for each 6990 card). I open another terminal window and set the fan speed to 60%.
I would open another terminal window and start another miner.. etc.. All would be cooking along fine. However, after a bit of time [and this is true even if I was ruinning only a single miner instance] the screen goes black, the fans slow down... apparently the miners stop mining. A couple times it seemed to happen when I moved or touched the keyboard or mouse. But that could be coincidental..but does seem suspiciously connected somehow. My keyboard and mouse are fine. So, the whole screen goes black, but there is a cursor at the left top and I can type stuff...but it doesn't do anything expect show what I typed. It's not the terminal...it's some other kind of mode. CNTRL+ALT+DEL reboots it. What is that black screen anyway?

I end up having to reboot each time... start miners...and [soon thereafter] it all shuts down again to the black screen of...frustration.

System:
Anthlon II X...
Two 6990's....

Anyone have any idea(s) on what is wrong?
1480912706
Hero Member
*
Offline Offline

Posts: 1480912706

View Profile Personal Message (Offline)

Ignore
1480912706
Reply with quote  #2

1480912706
Report to moderator
1480912706
Hero Member
*
Offline Offline

Posts: 1480912706

View Profile Personal Message (Offline)

Ignore
1480912706
Reply with quote  #2

1480912706
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480912706
Hero Member
*
Offline Offline

Posts: 1480912706

View Profile Personal Message (Offline)

Ignore
1480912706
Reply with quote  #2

1480912706
Report to moderator
BinaryMage
Hero Member
*****
Offline Offline

Activity: 546


Ad astra.


View Profile
June 22, 2011, 11:21:09 PM
 #2

First, I must warn you that while I have some experience with Linux and Ubuntu, I'm no expert, so don't take what I say as fact.

You could try disabling any power-saving settings, but it seems to me Ubuntu is crashing somehow. Try setting fan speed higher, the 6990s need a lot of air throughput. You could be seeing the Linux equivalent of a BSOD if your cards are overheating. Also try just running Linux for awhile without mining, and see if the problem occurs or not.

-- BinaryMage -- | OTC | PGP
drawoc
Full Member
***
Offline Offline

Activity: 168

Firstbits: 175wn


View Profile
June 22, 2011, 11:34:26 PM
 #3

When you get the black screen, try pressing Ctrl-Alt-F7
If that doesn't do anything, then try Ctrl-Alt-F1

Donate: 175WNXmJ1WVhFgVGKUqEhYtAQGRYAvqPA
detroit
Member
**
Offline Offline

Activity: 70


View Profile
June 22, 2011, 11:48:48 PM
 #4

I second the suggestion to turn that fan speed up or leave it on auto.
Are you overclocking the cards?  Leave the speeds stock, also.
It sounds similar to a crash mode I get on ubuntu from cards that are pushed too far, thermally/speed wise after a while.

Tradehill.com referral code: TH-R1494
Please consider using it if I've said something useful!
||bit
Hero Member
*****
Offline Offline

Activity: 644


View Profile
June 23, 2011, 12:14:14 AM
 #5

First, I must warn you that while I have some experience with Linux and Ubuntu, I'm no expert, so don't take what I say as fact.

You could try disabling any power-saving settings, but it seems to me Ubuntu is crashing somehow. Try setting fan speed higher, the 6990s need a lot of air throughput. You could be seeing the Linux equivalent of a BSOD if your cards are overheating. Also try just running Linux for awhile without mining, and see if the problem occurs or not.

Running it a while without mining results in a screen saver. However, I have seen it go to that black screen without mining. The screen saver setting (the Matrix screen saver Tongue) set for about 45 minutes. It comes up, but when it does, and I touch the mouse or keyboard, it either goes into ogin window or a black screen mode where if I type, it shows text being typed...but nothing come from that... it just displays what I type like any notepad...but no window...since hte whole screen is black. If I press ALT + F1 it displays login prompt (not window) and if I login...it just goes into what seems to be terminal mode.

I let my cards get close to 80C at times. I know that is too hot, but I don't think it is hot enough to make the system choke. It could crash soon after startup.

I'm not sure if I am dealing with two problems with similar symptoms or not.
||bit
Hero Member
*****
Offline Offline

Activity: 644


View Profile
June 23, 2011, 12:20:03 AM
 #6

When you get the black screen, try pressing Ctrl-Alt-F7
If that doesn't do anything, then try Ctrl-Alt-F1

When the screen is black, I found I can type, but it does nothing but display the characters typed. It's not the terminal mode with the prompt, it's just some strange mode. To add to that oddity, lately the screen goes completely black and no typing I do is displayed, BUT I discovered if I just type my login password (even though nothing is on the screen) it comes back to the desktop mode.

I didn't try Ctrl-Alt-F7, yet, but I did try Alt-F1 (without control) which brings me to a login prompt (not the small linux login window). When I login, it makes the whole screen effectively a terminal but no desktop.
||bit
Hero Member
*****
Offline Offline

Activity: 644


View Profile
June 23, 2011, 12:30:05 AM
 #7

I'll do some more testing later tonight when I'm back home. I'll apply the various suggestions from this thread and make a nice little grid to help define and furtherr isoloate the issue.

Anyone here have any experience on what linux will do if the video cards overheat? In this case, two 6990's at times reaching maybe between 80C to 90C...either for a few moments or for sustained periods of many minutes.
BinaryMage
Hero Member
*****
Offline Offline

Activity: 546


Ad astra.


View Profile
June 23, 2011, 12:35:35 AM
 #8

I'll do some more testing later tonight when I'm back home. I'll apply the various suggestions from this thread and make a nice little grid to help define and furtherr isoloate the issue.

Anyone here have any experience on what linux will do if the video cards overheat? In this case, two 6990's at times reaching maybe between 80C to 90C...either for a few moments or for sustained periods of many minutes.

That is too hot for sustained use. You need to leave fan speed on auto. I'm not sure what Linux will do, but it could be what you're experiencing. Sometimes, regardless of OS, the system will just freeze up.

-- BinaryMage -- | OTC | PGP
||bit
Hero Member
*****
Offline Offline

Activity: 644


View Profile
June 23, 2011, 02:43:22 AM
 #9

I'll do some more testing later tonight when I'm back home. I'll apply the various suggestions from this thread and make a nice little grid to help define and furtherr isoloate the issue.

Anyone here have any experience on what linux will do if the video cards overheat? In this case, two 6990's at times reaching maybe between 80C to 90C...either for a few moments or for sustained periods of many minutes.

That is too hot for sustained use. You need to leave fan speed on auto. I'm not sure what Linux will do, but it could be what you're experiencing. Sometimes, regardless of OS, the system will just freeze up.

Thaks for the suggestion. I'l include that in the matrix of things I try. Do you happen to know how to set auto fan speed in linux? I only know how to manually set a fan speed..for that I am using:

Code:
export DISPLAY=:0.0; aticonfig --pplib-cmd "set fanspeed 60"

or it might have been...
Code:
export DISPLAY=:0.0; aticonfig --pplib-cmd "set fanspeed 0 60"

One of those is how I set the fanspeed for for 60% on gpu device 0.0 [then I'd use 0.1, 0.2, 0.3 on the other gpu fan speeds].

detroit
Member
**
Offline Offline

Activity: 70


View Profile
June 23, 2011, 11:17:04 AM
 #10

Set that fan speed to 100 then see if it still locks up.  Then you can work on auto settings or lowering to more tolerable speeds.

Tradehill.com referral code: TH-R1494
Please consider using it if I've said something useful!
nomnomnom
Sr. Member
****
Offline Offline

Activity: 311



View Profile
June 23, 2011, 11:35:02 AM
 #11

If you are at the black window, try ALT+F7 that should switch you back
to the X Server (If it is still alive that is)

If not I would login on the ALT+F1 terminal and check if the X server is still
running, maybe do a ps axu and look for a program called X Smiley or do a  pgrep X or so,
you could also check some logs

dmesg
cat /var/log/syslog
cat /var/log/messages
etc etc... maybe there is info what is happening.

!!! carefull on my sapphire 5850 that turns the fan completly off !!! not sure wtf that is...
but "theoretical" it should work like this to set it back into auto mode
DISPLAY=:0.0 aticonfig --pplib-cmd "set fanspeed 0 auto"


After thinking about it, better don't try to set it back to auto this way, you can
do it with a tool called AMDOverDriveCtrl, go to the Tab Fanspeed and then click default.



nomnomnom
Sr. Member
****
Offline Offline

Activity: 311



View Profile
June 23, 2011, 11:40:53 AM
 #12

ups double
drawoc
Full Member
***
Offline Offline

Activity: 168

Firstbits: 175wn


View Profile
June 23, 2011, 02:17:14 PM
 #13

After you get to the terminal and log in copy the xorg log file to your home directory like this:
cp /var/log/Xorg.0.log ~
(Capitalization is important) and post the logfile here.

Also, try:
sudo service gdm restart
This should restart the x server.
if that doesn't work, try:
sudo service x11-common restart
Never mind, instead try:
startx

Donate: 175WNXmJ1WVhFgVGKUqEhYtAQGRYAvqPA
||bit
Hero Member
*****
Offline Offline

Activity: 644


View Profile
June 23, 2011, 05:19:10 PM
 #14

After you get to the terminal and log in copy the xorg log file to your home directory like this:
cp /var/log/Xorg.0.log ~
(Capitalization is important) and post the logfile here.

Also, try:
sudo service gdm restart
This should restart the x server.
if that doesn't work, try:
sudo service x11-common restart
Never mind, instead try:
startx

Latest data or info. No mining being done during the steps below, it was all only a static testing.

I set the computer so there was no password required to login. And that login was automtic at startup. Rebooting will now bring me to the desktop. Screensaver was set, I thought, to one hour. However, it seeemd to go to screensaver in about 15 minutes (maybe I made a mistake setting it).
I moved the mouse after the screensaver came up, and the small login window was there. So, no black screen yet.
Entered password and it came to desktop. I let it go about the same amount of time to the screen saver again. Repeated the login and it came to desktop again.

Let screen saver reappear and stay on screen saving for 5 hours. This time I tried touching the keyboard. The login window worked again. Desktop viewable again.
BUT I tried nothing until a few minutes later when I wanted to double check my power and screen saver settings.
Once I touched the mouse to check that, it immediately went to a black screen with the following:

Code:
* Stopping System V runlevel compatibility           [ok]
* Starting CUPS printing spooler/server              [ok]
                                                         _

The underscore represents the position of the flashing cursor at the right end of the third line.

Shortly after, while typing this comment on another computer, the screen went black and the text was gone. I touched the keyboard and the above text reappeared.
Maybe the screensaver timeout setting triggered this event, but it was not the animated screen saver.

Pressed CTRL+ALT+F7 ---->nothing.

I copied the Xorg log as you requested. How do I open it from the terminal?

I next typed: sudo service gdm restart
The desktop started, but once I touched the mouse it returned to the screen that I just left. Commands and stuff I had typed were still there.

I next typed: startx
The screen went completely black. No typing becomes viewable.

Hard reboot. Square one. Tongue

[Late entry: it was already set for 15 minutes screen saver with power management already set to 'never' on both options of the computer and the monitor to go to sleep from inactivity.]
drawoc
Full Member
***
Offline Offline

Activity: 168

Firstbits: 175wn


View Profile
June 23, 2011, 06:02:49 PM
 #15

Now in your home directory, there'll be a file named Xorg.0.log
If you could post it on the forum, or upload it somewhere with Firefox, that would be useful.
If you want to read it on the terminal, you can use:
cat Xorg.0.log | less
or you can just log in and use the GUI (The file will still be in your home directory.)

Donate: 175WNXmJ1WVhFgVGKUqEhYtAQGRYAvqPA
||bit
Hero Member
*****
Offline Offline

Activity: 644


View Profile
June 23, 2011, 06:04:49 PM
 #16

Now in your home directory, there'll be a file named Xorg.0.log
If you could post it on the forum, or upload it somewhere with Firefox, that would be useful.
If you want to read it on the terminal, you can use:
cat Xorg.0.log | less
or you can just log in and use the GUI (The file will still be in your home directory.)

It's too long to post. Where to upload it?
drawoc
Full Member
***
Offline Offline

Activity: 168

Firstbits: 175wn


View Profile
June 23, 2011, 06:18:25 PM
 #17

You could put it on pastebin, and post the link here.
http://pastebin.com/

Donate: 175WNXmJ1WVhFgVGKUqEhYtAQGRYAvqPA
||bit
Hero Member
*****
Offline Offline

Activity: 644


View Profile
June 23, 2011, 06:27:46 PM
 #18

You could put it on pastebin, and post the link here.
http://pastebin.com/

Thanks! That's handy! Here's the link:

http://pastebin.com/1Buv9cE3

I'm not exactly sure how to read it, but I'm guessing the line numbers are logged event times in seconds from reboot(?) The ending line number is about what 5 hours would be in seconds - which is about how long it was from bootup to blackout issue.
drawoc
Full Member
***
Offline Offline

Activity: 168

Firstbits: 175wn


View Profile
June 23, 2011, 09:08:11 PM
 #19

I'm not exactly sure how to read it, but I'm guessing the line numbers are logged event times in seconds from reboot(?) The ending line number is about what 5 hours would be in seconds - which is about how long it was from bootup to blackout issue.

Yep, basically.

The problem seems to be a bug in ATI's driver, involving hardware accelerated mouse cursor drawing.
We can try turning that off, and just using software drawn mouse cursors.

EDIT: I forgot to tell you to back up your xorg.conf file before editing it.
In a terminal, run:
Code:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

To edit your xorg.conf, run:
Code:
sudo nano /etc/X11/xorg.conf

That file's separated into sections. At the end of each Device section you see, add a line that says Option "SWCursor" "true"
So, for example:
Code:
Section "Device"
 ...
  Option "SWCursor" "true"
EndSection
Where ... is everything that was in that section before.
Each GPU has its own device section, so you should have four device sections to edit. (2 cards x 2 GPUs/card)

Hopefully that will solve the issue.

Donate: 175WNXmJ1WVhFgVGKUqEhYtAQGRYAvqPA
||bit
Hero Member
*****
Offline Offline

Activity: 644


View Profile
June 24, 2011, 01:32:16 PM
 #20

I'm not exactly sure how to read it, but I'm guessing the line numbers are logged event times in seconds from reboot(?) The ending line number is about what 5 hours would be in seconds - which is about how long it was from bootup to blackout issue.

Yep, basically.

The problem seems to be a bug in ATI's driver, involving hardware accelerated mouse cursor drawing.
We can try turning that off, and just using software drawn mouse cursors.

EDIT: I forgot to tell you to back up your xorg.conf file before editing it.
In a terminal, run:
Code:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

To edit your xorg.conf, run:
Code:
sudo nano /etc/X11/xorg.conf

That file's separated into sections. At the end of each Device section you see, add a line that says Option "SWCursor" "true"
So, for example:
Code:
Section "Device"
 ...
  Option "SWCursor" "true"
EndSection
Where ... is everything that was in that section before.
Each GPU has its own device section, so you should have four device sections to edit. (2 cards x 2 GPUs/card)

Hopefully that will solve the issue.

Ok. I followed your instructions (including the initial backup). I jumped into mining with all four gpu's again. Now to see if it crashes again after some time. I suppose if it does, I can make save another log file.

Something else that is different, is that I put a big fan on top of the computer (blowing into it of course). Average of the four gpu's is about 70C. I will try to cool them more, but it is tolerable enough for this test run I think. The most itme I think I had it running all four before was about 20 minutes.

Where did you learn to read that file that you asked me to upload? Would you point me to the line item in it where you saw an issue? And how you knew it was a problem...I'd love to learn more about linux. Smiley

p.s.  Your patience and help is appreciated. Where can I donate to you? I only have about .75 BTC in my bitcoin wallet, but it's something. Tongue
Pages: [1] 2 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!