Bitcoin Forum
October 23, 2017, 04:20:34 AM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: cgminer splits hash rate between multiple GPUs  (Read 783 times)
Phaedrus
Newbie
*
Offline Offline

Activity: 3


View Profile
May 25, 2013, 12:07:51 AM
 #1

I'm running cgminer on Ubuntu 12.04 with two 5830s and a 6800-based card. I installed everything according to this guide:

http://rdmsnippets.com/2013/03/20/bitcoin-mining-with-ubuntu-12-04-tls-and-cgminer/

If I mine on one card, it gets the full hash rate (200 Mh/s). However, if I mine on all three cards, each card only mines at 1/3 the rate it's supposed to get (68 Mh/s). This is apparently the problem described in the cgminer FAQ:

Quote
Q: I have multiple GPUs and although many devices show up, it appears to be working only on one GPU splitting it up.

A: Your driver setup is failing to properly use the accessory GPUs. Your driver may be configured wrong or you have a driver version that needs a dummy
plug on all the GPUs that aren't connected to a monitor.

I used aticonfig to set up my xorg.conf file, so I don't see where I might have messed up my driver configuration. I've tried adding a dummy plug (well, a resistor) to one of my GPUs, but to no avail. Am I overlooking something? Where should I start looking for problems with the configuration?

Thanks!
1508732434
Hero Member
*
Offline Offline

Posts: 1508732434

View Profile Personal Message (Offline)

Ignore
1508732434
Reply with quote  #2

1508732434
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1508732434
Hero Member
*
Offline Offline

Posts: 1508732434

View Profile Personal Message (Offline)

Ignore
1508732434
Reply with quote  #2

1508732434
Report to moderator
burek
Jr. Member
*
Offline Offline

Activity: 35


View Profile
May 25, 2013, 12:42:38 AM
 #2

Old versions of cgminer have been "splitting" hash rate between cards for me when I was using dynamic intensity. I've always kept it manually at 9.

I never had much luck with mixing 5xxx and 6xxx cards in one rig. For these cards, Catalyst 11.04/11.05 worked best for me with APP SDK version that is provided in drivers.

Difficulty is a bitch. Can't with her, can't without her.
Phaedrus
Newbie
*
Offline Offline

Activity: 3


View Profile
May 25, 2013, 06:02:33 PM
 #3

I should be running the latest version of cgminer, since I just cloned it from the git repository. I've tried setting the intensity manually to 5, but it just splits the hash rate more evenly. Any other thoughts?
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!