Bitcoin Forum
October 20, 2017, 10:22:43 PM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: 6950 on Linux, unlocked shaders, hash rate lower than expected  (Read 2088 times)
Mr2001
Jr. Member
*
Offline Offline

Activity: 42


View Profile
June 25, 2011, 05:28:51 AM
 #1

I'm running a 6950 on Linux with the latest fglrx, and I've used RBE to unlock the shaders and increase the clock to 900 MHz.

When I start poclbm, the hash rate climbs to around 410 Mhps during the first few seconds, then drops down to about 353. According to my sloppy math, I should be getting something like 385 with these tweaks, so I'm wondering what the problem is...

Are my expectations too high, and 350 is right, and the brief display of 400+ Mhps is incorrect?

Could the card be throttling itself for some reason? It's not overheating, the temperature stays around 68C with the fan at 75%.

Could the shaders not actually be unlocked even though RBE says they are? It's this 2GB MSI card which is supposed to be unlockable. Is there a way to check how many shaders are active without installing Windows or moving the card to a Windows box to run GPU-Z?
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1508538163
Hero Member
*
Offline Offline

Posts: 1508538163

View Profile Personal Message (Offline)

Ignore
1508538163
Reply with quote  #2

1508538163
Report to moderator
1508538163
Hero Member
*
Offline Offline

Posts: 1508538163

View Profile Personal Message (Offline)

Ignore
1508538163
Reply with quote  #2

1508538163
Report to moderator
fitty
Sr. Member
****
Offline Offline

Activity: 462


🌟ATLANT ICO: 7/09/17🌟


View Profile
June 25, 2011, 05:40:07 PM
 #2

In Windows you have to make sure the 20% overdrive is on. I'd assume that goes for Linux.

If that gets reset to the deault of 0% then I drop from 400 down to 345 like you said. Fixing that puts my speeds back up. For some reason in Windows it gets reset sometimes (using MSI Afterburner). I'd see if that's an option in linux and adjust it. =)

......ATLANT......
..Real Estate Blockchain Platform..
                     ▄▄▄▄▄▄▄▄▄
                    ████████████░
                  ▄██████████████░
                 ▒███████▄████████░
                ▒█████████░████████░
                ▀███████▀█████████
                  ██████████████
           ███████▐██▀████▐██▄████████░
          ▄████▄█████████▒████▌█████████░
         ███████▄█████████▀██████████████░
        █████████▌█████████▐█████▄████████░
        ▀█████████████████▐███████████████
          █████▀████████ ░███████████████
    ██████▐██████████▄████████████████████████░
  ▄████▄████████▐███████████████░▄▄▄▄░████████░
 ▄██████▄█████████▐█████▄█████████▀████▄█████████░
███████████████████▐█████▄█████████▐██████████████░
▀████████▀█████████▒██████████████▐█████▀█████████
  ████████████████ █████▀█████████████████████████
   ▀██▀██████████ ▐█████████████  ▀██▀██████████
    ▀▀█████████    ▀▀█████████    ▀▀██████████

..INVEST  ●  RENT  ●  TRADE..
  ✓Assurance     ✓Price Discovery     ✓Liquidity     ✓Low Fees





███
███
███
███
███
███





███
███
███
███
███
███
███
███
███
███
███
███

◣Whitepaper ◣ANN ThreadTelegram
◣ Facebook     ◣ Reddit          ◣ Slack


███
███
███
███
███
███
███
███
███
███
███
███





███
███
███
███
███
███



Mr2001
Jr. Member
*
Offline Offline

Activity: 42


View Profile
June 25, 2011, 10:24:26 PM
 #3

Ah, got it. That Power Control option isn't exposed by aticonfig, but I found this thread with code to turn it on. Now I'm at 388 Mhps and 70.5C.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!