getaccountaddress <account> -> getaddress [account]
getnewaddress -> newaddress
sendtoaddress -> send
I think that the get prefix should only be used for getting existing information. Things like making a new address are an action.
These changes will make the API more logical and easier to use. Especially for someone like me who uses bitcoind over SSH and on my local machine also.
sendtoaddress <- the to address part is redundant. Where else would you send it to? (i know IP's are possible but aren't they not recommended/being fazed out?)
getnewaddress <- You have to make a new address before returning it. Therefore you're not 'getting' something that already exists but performing an action.
getaddress should have account be optional. Have the ability to just return an address from the default account "".