Bitcoin Forum
October 20, 2018, 04:10:28 PM *
News: Make sure you are not using versions of Bitcoin Core other than 0.17.0 [Torrent], 0.16.3, 0.15.2, or 0.14.3. More info.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Electrum wallet & Linux  (Read 163 times)
humantraffic
Member
**
Offline Offline

Activity: 364
Merit: 23

"Decentralized Digital Billboards"


View Profile
November 04, 2017, 01:06:01 PM
 #1

Доброго времени суток Wink
Прошу консультации, собственно при установке данного кошелька через терминал с помощью команд:
sudo apt-get install python3-pyqt5 python3-pip
sudo pip3 install https://download.electrum.org/3.0/Electrum-3.0.tar.gz
получаю следующие:
The directory '/home/ice/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/ice/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Collecting https://download.electrum.org/3.0/Electrum-3.0.tar.gz
Downloading https://download.electrum.org/3.0/Electrum-3.0.tar.gz (2.8MB)
100% |████████████████████████████████| 2.8MB 281kB/s
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File "<string>", line 1, in <module>
ImportError: No module named 'setuptools'

----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-ytk5u8b8-build/
You are using pip version 8.1.1, however version 9.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

собственно как апгрейдить pip?  при вводе --upgrade pip пишет что такая команда не найдена.

и собственно второй вопросик, я смог запустить кошелек только скачав архив и запустив "python3 electrum" так его надежно использовать? потому что набирая sudo python3 setup.py install опять же выдает ошибку  Cry

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1540051828
Hero Member
*
Offline Offline

Posts: 1540051828

View Profile Personal Message (Offline)

Ignore
1540051828
Reply with quote  #2

1540051828
Report to moderator
Dark_Soul
Member
**
Offline Offline

Activity: 107
Merit: 10


View Profile
November 26, 2017, 05:58:38 AM
 #2

Доброго времени суток Wink
Прошу консультации, собственно при установке данного кошелька через терминал с помощью команд:
sudo apt-get install python3-pyqt5 python3-pip
sudo pip3 install https://download.electrum.org/3.0/Electrum-3.0.tar.gz
получаю следующие:
The directory '/home/ice/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/ice/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Collecting https://download.electrum.org/3.0/Electrum-3.0.tar.gz
Downloading https://download.electrum.org/3.0/Electrum-3.0.tar.gz (2.8MB)
100% |████████████████████████████████| 2.8MB 281kB/s
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File "<string>", line 1, in <module>
ImportError: No module named 'setuptools'

----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-ytk5u8b8-build/
You are using pip version 8.1.1, however version 9.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

собственно как апгрейдить pip?  при вводе --upgrade pip пишет что такая команда не найдена.

и собственно второй вопросик, я смог запустить кошелек только скачав архив и запустив "python3 electrum" так его надежно использовать? потому что набирая sudo python3 setup.py install опять же выдает ошибку  Cry

Для установки electrum wallet на Линукс нужно в терминал ввести команду $ sudo apt-get install electrum.После того как кошелек установился, его можно найти папке /wallets,файл будет называться default_wallet. Не забудьте зайти в Домашнюю папку и разрешить показ скрытых файлов после чего отобразится скрытая папка /.electrum вашего кошелька.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!