Bitcoin Forum
July 25, 2017, 10:48:33 AM *
News: BIP91 seems stable: there's probably only slightly increased risk of confirmations disappearing. You should still prepare for Aug 1.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: armory won't install onto linux USB boot  (Read 4308 times)
micalith
Hero Member
*****
Offline Offline

Activity: 546



View Profile
June 22, 2013, 09:28:12 AM
 #1

Has anyone managed to run armory in a usb bootable OS? I've tried with ubuntu 11.10, 12.04, and 13.04 and always get the following error when trying to run the armory_0.88.1-beta_amd64.deb installer:

"Dependency is not satisfiable.   python-psutil"

It installs fine on my regular hard-drive ubuntu 11.10

I'm using a Dell latitude e6430,
Intel® Core™ i7-3720QM CPU @ 2.60GHz × 8, 
8GB RAM, 64-bit

nullius in verba
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1500979713
Hero Member
*
Offline Offline

Posts: 1500979713

View Profile Personal Message (Offline)

Ignore
1500979713
Reply with quote  #2

1500979713
Report to moderator
etotheipi
Legendary
*
Offline Offline

Activity: 1428


Core Armory Developer


View Profile WWW
June 23, 2013, 01:32:04 AM
 #2

python-psutil was a dependency added to Armory in version 0.88+.  You could try one of the earlier versions of Armory (0.87.2) or you could download the python-psutil package from here (I don't think it has any dependencies).  I'm not sure why it wouldn't be satisfiable...


Founder and CEO of Armory Technologies, Inc.
Armory Bitcoin Wallet: Bringing cold storage to the average user!
Only use Armory software signed by the Armory Offline Signing Key (0x98832223)

Please donate to the Armory project by clicking here!    (or donate directly via 1QBDLYTDFHHZAABYSKGKPWKLSXZWCCJQBX -- yes, it's a real address!)
cp1
Hero Member
*****
Offline Offline

Activity: 616


Stop using branwallets


View Profile
June 24, 2013, 05:23:14 AM
 #3

Did you run apt-get update?  It sounds like something's out of date.  Here's an excerpt from my guide using xubuntu 12.04

sudo apt-get update
sudo apt-get upgrade
sudo shutdown -r now
sudo apt-get install python-qt4 python-twisted python-psutil
wget https://bitcoinarmory.googlecode.com/files/armory_0.88.1-beta_i386.deb
sudo dpkg -i armory_0.88.1-beta_i386.deb

Guide to armory offline install on USB key:  https://bitcointalk.org/index.php?topic=241730.0
TTBit
Legendary
*
Offline Offline

Activity: 1136


View Profile
August 17, 2013, 03:25:17 PM
 #4

Did you run apt-get update?  It sounds like something's out of date.  Here's an excerpt from my guide using xubuntu 12.04

sudo apt-get update
sudo apt-get upgrade
sudo shutdown -r now
sudo apt-get install python-qt4 python-twisted python-psutil
wget https://bitcoinarmory.googlecode.com/files/armory_0.88.1-beta_i386.deb
sudo dpkg -i armory_0.88.1-beta_i386.deb


I'm having trouble as well. New install of 12.04. Can anyone tell what I'm missing? Thank you.

Code:
$ sudo apt-get install python-qt4 python-twisted python-psutil
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python-qt4 is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-psutil:i386 : Depends: python2.7:i386 but it is not going to be installed
                      Depends: python:i386 (>= 2.7.1-0ubuntu2) but it is not going to be installed
                      Depends: python:i386 (< 2.8) but it is not going to be installed
 python-twisted : Depends: python-twisted-conch (>= 1:11.0) but it is not going to be installed
                  Depends: python-twisted-mail (>= 11.0) but it is not going to be installed
                  Depends: python-twisted-lore (>= 11.0) but it is not going to be installed
                  Depends: python-twisted-news (>= 11.0) but it is not going to be installed
                  Depends: python-twisted-runner (>= 11.0) but it is not going to be installed
                  Depends: python-twisted-words (>= 11.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

good judgment comes from experience, and experience comes from bad judgment
polrpaul
Full Member
***
Offline Offline

Activity: 238


Love the Bitcoin.


View Profile WWW
August 17, 2013, 03:30:03 PM
 #5

what version of Python are you running?

BTC.sx - Leveraged Bitcoin Trading. Simply use Bitcoin to take advantage of a rising or falling Bitcoin price.
TTBit
Legendary
*
Offline Offline

Activity: 1136


View Profile
August 17, 2013, 06:32:03 PM
 #6

what version of Python are you running?

Is this correct?

Code:
$ python
Python 2.7.3 (default, Apr 10 2013, 06:20:15)
[GCC 4.6.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>

good judgment comes from experience, and experience comes from bad judgment
TTBit
Legendary
*
Offline Offline

Activity: 1136


View Profile
August 17, 2013, 06:39:55 PM
 #7


edit:

I had to

Code:
sudo rm -fR /var/lib/apt/lists/*

and then run the update. Don't know why it worked, but it did.

good judgment comes from experience, and experience comes from bad judgment
Lavender
Jr. Member
*
Offline Offline

Activity: 37


View Profile
August 30, 2013, 08:29:58 PM
 #8

Per the below document, I used the following packages with success on Tails live CD:

https://docs.google.com/document/d/1YoqeEisXpq4b4eYKjADRaIkopgrN5Ye3OGixPhV_9A8/edit

armory_0.88.1-beta_i386.deb

python-twisted-conch_10.1.0-1_all.deb 
python-twisted-runner_10.1.0-2_i386.deb
python-twisted-core_10.1.0-3_all.deb   
python-twisted-web_10.1.0-1_all.deb
python-crypto_2.1.0-2+squeeze1_i386.deb 
python-twisted-lore_10.1.0-1_all.deb   
python-twisted-words_10.1.0-1_all.deb
python-openssl_0.10-1_i386.deb           
python-twisted-mail_10.1.0-1_all.deb   
python-twisted_10.1.0-3_all.deb
python-pyasn1_0.0.11a-1_all.deb         
python-twisted-names_10.1.0-1_all.deb
python-twisted-bin_10.1.0-3_i386.deb     
python-twisted-news_10.1.0-1_all.deb
python-psutil_0.1.3-1_all.deb

Here are the download links:

http://packages.debian.org/stable/python/python-crypto
http://packages.debian.org/stable/python/python-openssl
http://packages.debian.org/stable/python/python-psutil
http://packages.debian.org/stable/python/python-pyasn1
http://packages.debian.org/stable/python/python-twisted
http://packages.debian.org/stable/python/python-twisted-bin
http://packages.debian.org/stable/python/python-twisted-conch
http://packages.debian.org/stable/python/python-twisted-core
http://packages.debian.org/stable/python/python-twisted-lore
http://packages.debian.org/stable/python/python-twisted-mail
http://packages.debian.org/stable/python/python-twisted-names
http://packages.debian.org/stable/python/python-twisted-news
http://packages.debian.org/stable/python/python-twisted-runner
http://packages.debian.org/stable/python/python-twisted-web
http://packages.debian.org/stable/python/python-twisted-words
Cryptocables
Full Member
***
Offline Offline

Activity: 227


crypt0queen


View Profile WWW
November 25, 2013, 03:18:13 AM
 #9

I'm having this problem with a new machine as well. My other one is fine, but for this particular version I'm encountering the python qt4 etc. "depends on, and is not install" issues others have reported here as well. Not able to proceed further until this is fixed, any ideas?

I tried the fR suggestion here and still encountering problems.


Pre-Req Errors
Code:
$ sudo apt-get install python-qt4 python-twisted python-psutilReading package lists... Done
Building dependency tree      
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 python-qt4 : Depends: libqt4-designer (>= 4:4.8.0-1~) but it is not going to be installed
              Depends: libqt4-help (>= 4:4.8.0-1~) but it is not going to be installed
              Depends: libqt4-scripttools (>= 4:4.8.0-1~) but it is not going to be installed
              Depends: libqt4-test (>= 4:4.8.0-1~) but it is not going to be installed
              Depends: libqtassistantclient4 (>= 4.6.3) but it is not going to be installed
              Depends: libqtwebkit4 (>= 2.2~2011week36) but it is not going to be installed
              Depends: sip-api-8.1
 python-twisted : Depends: python-twisted-conch (>= 1:11.0) but it is not going to be installed
                  Depends: python-twisted-mail (>= 11.0) but it is not going to be installed
                  Depends: python-twisted-lore (>= 11.0) but it is not going to be installed
                  Depends: python-twisted-news (>= 11.0) but it is not going to be installed
                  Depends: python-twisted-runner (>= 11.0) but it is not going to be installed
                  Depends: python-twisted-words (>= 11.0) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).



Installation Attempt:

Code:
Unpacking replacement armory ...
dpkg: dependency problems prevent configuration of armory:
 armory depends on python-qt4; however:
  Package python-qt4 is not installed.
 armory depends on python-twisted; however:
  Package python-twisted is not installed.
 armory depends on python-psutil; however:
  Package python-psutil is not installed.
dpkg: error processing armory (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
 armory

Doesnt help:
Code:
sudo rm -fR /var/lib/apt/lists/*

♥ Queen's Cryptocable Extravaganza! ♥         /l、    ~Ships same day~            http://www.twitter.com/Cryptocables
     Home of the Bitcoin Neon Sign              (゚、 。 7   `Based in ♥ USA                 contact: #freenode - crypt0queen
     http://www.cryptocables.com                 l、 ~ヽ       `meow!                  http://www.twitter.com/crypt0queen
                                                               じしf_, )ノ
Cryptocables
Full Member
***
Offline Offline

Activity: 227


crypt0queen


View Profile WWW
November 25, 2013, 04:21:28 AM
 #10

Ok so I fixed my issue

If anyone is running into this issue, do the following:


sudo apt-get update
sudo apt-get clean and sudo apt-get autopurge
Repair all of your packages and software in the software center
re-try installing the package again, should be good to go this time around

for some reason the  python package was corrupted.

♥ Queen's Cryptocable Extravaganza! ♥         /l、    ~Ships same day~            http://www.twitter.com/Cryptocables
     Home of the Bitcoin Neon Sign              (゚、 。 7   `Based in ♥ USA                 contact: #freenode - crypt0queen
     http://www.cryptocables.com                 l、 ~ヽ       `meow!                  http://www.twitter.com/crypt0queen
                                                               じしf_, )ノ
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!