Bitcoin Forum
September 23, 2018, 07:33:57 AM *
News: ♦♦ New info! Bitcoin Core users absolutely must upgrade to previously-announced 0.16.3 [Torrent]. All Bitcoin users should temporarily trust confirmations slightly less. More info.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Node Config Question: Any way to force incoming peers to be updated peers?  (Read 157 times)
Whammo
Newbie
*
Offline Offline

Activity: 2
Merit: 0


View Profile
November 16, 2017, 11:53:23 PM
 #1

Node is up running like a champ!

My question is: I'm running /Satoshi:0.15.1/

Anyway to require incoming nodes to be only Satoshi 0.15+? I realize they are backwards compatible and TOR is diff.

Just wanted to ensure my node only supports Bitcoin Core.

Thanks in advance!

 Grin

edit - looking for configuration file code!
1537688037
Hero Member
*
Offline Offline

Posts: 1537688037

View Profile Personal Message (Offline)

Ignore
1537688037
Reply with quote  #2

1537688037
Report to moderator
1537688037
Hero Member
*
Offline Offline

Posts: 1537688037

View Profile Personal Message (Offline)

Ignore
1537688037
Reply with quote  #2

1537688037
Report to moderator
1537688037
Hero Member
*
Offline Offline

Posts: 1537688037

View Profile Personal Message (Offline)

Ignore
1537688037
Reply with quote  #2

1537688037
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1537688037
Hero Member
*
Offline Offline

Posts: 1537688037

View Profile Personal Message (Offline)

Ignore
1537688037
Reply with quote  #2

1537688037
Report to moderator
achow101
Moderator
Legendary
*
Offline Offline

Activity: 1526
Merit: 1650


3F1Y9yquzvY6RWvKbw2n2zeo9V5mvBhADU


View Profile WWW
November 17, 2017, 01:47:31 AM
 #2

No, there is no way to force peers be a certain version. However you can write a script which checks the list of connected peers and bans any peer which is not a certain version. Note that the user agent string which announces the version number can be faked, so it is not necessarily reliable to trust that.

Whammo
Newbie
*
Offline Offline

Activity: 2
Merit: 0


View Profile
November 17, 2017, 01:53:06 AM
 #3

Cool. Thanks. I'll write something. I thought I was missing something when no searches turned up.

 Smiley
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!