Bitcoin Forum
September 20, 2018, 01:56:29 AM *
News: ♦♦ Bitcoin Core users must update to 0.16.3 [Torrent]. More info.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Cgminer intensity command?  (Read 4715 times)
kgonepostl
Full Member
***
Offline Offline

Activity: 124
Merit: 100



View Profile
June 25, 2013, 03:09:20 AM
 #1

I'm using my machine to still mine bitcoins but I see it drop a few hundred megahashes. Is there a way to set priority for the video card being used? Here's my bat script. I put this bat script together after watching a youtube video. So I'm not very good. I'm a big n00b when it comes to cgminer.

start /D "C:\cgmine" cgminer.exe -o deepbit.net:8332 -u username -p password -d 0 -o mint.bitminter.com:8332 -u username -p password -d 0 --temp-target 85 --auto-fan --temp-overheat 90 --gpu-engine 870 --gpu-memclock 300

I'm using a 6950 and a 7950. Thanks in advance!!
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1537408589
Hero Member
*
Offline Offline

Posts: 1537408589

View Profile Personal Message (Offline)

Ignore
1537408589
Reply with quote  #2

1537408589
Report to moderator
crazyates
Legendary
*
Offline Offline

Activity: 952
Merit: 1000



View Profile
June 25, 2013, 04:19:17 AM
 #2

start /D "C:\cgmine" cgminer.exe -o deepbit.net:8332 -u username -p password -d 0 -o mint.bitminter.com:8332 -u username -p password -d 0 --temp-target 85 --auto-fan --temp-overheat 90 --gpu-engine 870 --gpu-memclock 300

A few things.

1) You're telling CGMiner to use the first gpu (device 0) twice, but you're never telling it to use the second device (usually device 1).

2) CGMiner can't natively clock 6xxx or 7xxx cards down to 300MHz. I would use "--gpu-memdiff -125"

3) Bitminter is good, but why are you using Deepbit? It used to be "THE" pool, but now there are WAY better pools out there. I would choose a different one, esp one that supports stratum.

4) I see you're not specifying an intensity. I would add an intensity of 7 for normal GPU BTC mining.

5) 85C is a little hot to be running a GPU, as I would recommend 70-75C. If you really want to run it at 85C, that's up to you, tho.

New code:
Quote
start /D "C:\cgmine" cgminer.exe -d 0,1 -o mint.bitminter.com:3333 -u username -p password --temp-target 85 --auto-fan  --auto-gpu --gpu-engine 500-870,500-870 --gpu-memdiff -125,-150 --gpu-fan 25-80 -I 7

Tips? 1crazy8pMqgwJ7tX7ZPZmyPwFbc6xZKM9
Previous Trade History - Sale Thread
kgonepostl
Full Member
***
Offline Offline

Activity: 124
Merit: 100



View Profile
June 25, 2013, 04:26:57 AM
 #3

start /D "C:\cgmine" cgminer.exe -o deepbit.net:8332 -u username -p password -d 0 -o mint.bitminter.com:8332 -u username -p password -d 0 --temp-target 85 --auto-fan --temp-overheat 90 --gpu-engine 870 --gpu-memclock 300

A few things.

1) You're telling CGMiner to use the first gpu (device 0) twice, but you're never telling it to use the second device (usually device 1).

2) CGMiner can't natively clock 6xxx or 7xxx cards down to 300MHz. I would use "--gpu-memdiff -125"

3) Bitminter is good, but why are you using Deepbit? It used to be "THE" pool, but now there are WAY better pools out there. I would choose a different one, esp one that supports stratum.

4) I see you're not specifying an intensity. I would add an intensity of 7 for normal GPU BTC mining.

5) 85C is a little hot to be running a GPU, as I would recommend 70-75C. If you really want to run it at 85C, that's up to you, tho.

New code:
Quote
start /D "C:\cgmine" cgminer.exe -d 0,1 -o mint.bitminter.com:3333 -u username -p password --temp-target 85 --auto-fan  --auto-gpu --gpu-engine 500-870,500-870 --gpu-memdiff -125,-150 --gpu-fan 25-80 -I 7

I have two towers. One houses a 7950 and the other a 6950. So You're suggesting I get rid of the -d command? I'll set bitminter as the primary. Thanks for the heads up. I added --gpu-memdiff -125 to my command list.

I hate to correct you but from what I understand cgminer by default has a intensity of 7 set by default. I just basically want to watch youtube and not loose hundreds of megahashes while doing so. I use educational videos on youtube to help me understand subjects in college. I watch them all the time but I want my gpu to have priority while doing so.

It's weird that you say it can't manage my memory clock but I just checked trixx and it's set to 300....

Here's my current bat file. Lemme know what's wrong with it.

start /D "C:\cgmine" cgminer.exe -o mint.bitminter.com:8332 -u username -p password -o deepbit.net:8332 -u username -p password --temp-target 85 --auto-fan --temp-overheat 90 --gpu-engine 870 --gpu-memclock 300 --gpu-memdiff -125
crazyates
Legendary
*
Offline Offline

Activity: 952
Merit: 1000



View Profile
June 25, 2013, 04:42:29 AM
 #4

start /D "C:\cgmine" cgminer.exe -o deepbit.net:8332 -u username -p password -d 0 -o mint.bitminter.com:8332 -u username -p password -d 0 --temp-target 85 --auto-fan --temp-overheat 90 --gpu-engine 870 --gpu-memclock 300

A few things.

1) You're telling CGMiner to use the first gpu (device 0) twice, but you're never telling it to use the second device (usually device 1).

2) CGMiner can't natively clock 6xxx or 7xxx cards down to 300MHz. I would use "--gpu-memdiff -125"

3) Bitminter is good, but why are you using Deepbit? It used to be "THE" pool, but now there are WAY better pools out there. I would choose a different one, esp one that supports stratum.

4) I see you're not specifying an intensity. I would add an intensity of 7 for normal GPU BTC mining.

5) 85C is a little hot to be running a GPU, as I would recommend 70-75C. If you really want to run it at 85C, that's up to you, tho.

New code:
Quote
start /D "C:\cgmine" cgminer.exe -d 0,1 -o mint.bitminter.com:3333 -u username -p password --temp-target 85 --auto-fan  --auto-gpu --gpu-engine 500-870,500-870 --gpu-memdiff -125,-150 --gpu-fan 25-80 -I 7

I have two towers. One houses a 7950 and the other a 6950. So You're suggesting I get rid of the -d command? I'll set bitminter as the primary. Thanks for the heads up. I added --gpu-memdiff -125 to my command list.

I hate to correct you but from what I understand cgminer by default has a intensity of 7 set by default. I just basically want to watch youtube and not loose hundreds of megahashes while doing so. I use educational videos on youtube to help me understand subjects in college. I watch them all the time but I want my gpu to have priority while doing so.

Ah ok, I didn't realize the two towers were in two separate computes. In that case, you can get rid of the -d command altogether. Also, on my 7970, it defaults to -I 6, which works, but i think -I 7 works better. I've also had issues where not specifying an intensity sometimes acts wonky, so I always add it in.

Also, the 6950 can only go 125MHz below the core clock, but the 7950 can go 150MHz below the core clock. And a 6950 might be good at 870, but I'm assuming a 7950 could go a little higher than that.

6950:
Quote
start /D "C:\cgmine" cgminer.exe -o mint.bitminter.com:3333 -u username -p password --temp-target 85 --auto-fan  --auto-gpu --gpu-engine 500-870 --gpu-memdiff -125 --gpu-fan 25-80 -I 7

7950:
Quote
start /D "C:\cgmine" cgminer.exe -o mint.bitminter.com:3333 -u username -p password --temp-target 85 --auto-fan  --auto-gpu --gpu-engine 500-970 --gpu-memdiff -150 --gpu-fan 25-80 -I 7

Tips? 1crazy8pMqgwJ7tX7ZPZmyPwFbc6xZKM9
Previous Trade History - Sale Thread
kgonepostl
Full Member
***
Offline Offline

Activity: 124
Merit: 100



View Profile
June 25, 2013, 04:44:43 AM
 #5

****edited because I'm an idiot Shocked
kgonepostl
Full Member
***
Offline Offline

Activity: 124
Merit: 100



View Profile
June 25, 2013, 04:52:10 AM
 #6

start /D "C:\cgmine" cgminer.exe -o deepbit.net:8332 -u username -p password -d 0 -o mint.bitminter.com:8332 -u username -p password -d 0 --temp-target 85 --auto-fan --temp-overheat 90 --gpu-engine 870 --gpu-memclock 300

A few things.

1) You're telling CGMiner to use the first gpu (device 0) twice, but you're never telling it to use the second device (usually device 1).

2) CGMiner can't natively clock 6xxx or 7xxx cards down to 300MHz. I would use "--gpu-memdiff -125"

3) Bitminter is good, but why are you using Deepbit? It used to be "THE" pool, but now there are WAY better pools out there. I would choose a different one, esp one that supports stratum.

4) I see you're not specifying an intensity. I would add an intensity of 7 for normal GPU BTC mining.

5) 85C is a little hot to be running a GPU, as I would recommend 70-75C. If you really want to run it at 85C, that's up to you, tho.

New code:
Quote
start /D "C:\cgmine" cgminer.exe -d 0,1 -o mint.bitminter.com:3333 -u username -p password --temp-target 85 --auto-fan  --auto-gpu --gpu-engine 500-870,500-870 --gpu-memdiff -125,-150 --gpu-fan 25-80 -I 7

I have two towers. One houses a 7950 and the other a 6950. So You're suggesting I get rid of the -d command? I'll set bitminter as the primary. Thanks for the heads up. I added --gpu-memdiff -125 to my command list.

I hate to correct you but from what I understand cgminer by default has a intensity of 7 set by default. I just basically want to watch youtube and not loose hundreds of megahashes while doing so. I use educational videos on youtube to help me understand subjects in college. I watch them all the time but I want my gpu to have priority while doing so.

Ah ok, I didn't realize the two towers were in two separate computes. In that case, you can get rid of the -d command altogether. Also, on my 7970, it defaults to -I 6, which works, but i think -I 7 works better. I've also had issues where not specifying an intensity sometimes acts wonky, so I always add it in.

Also, the 6950 can only go 125MHz below the core clock, but the 7950 can go 150MHz below the core clock. And a 6950 might be good at 870, but I'm assuming a 7950 could go a little higher than that.

6950:
Quote
start /D "C:\cgmine" cgminer.exe -o mint.bitminter.com:3333 -u username -p password --temp-target 85 --auto-fan  --auto-gpu --gpu-engine 500-870 --gpu-memdiff -125 --gpu-fan 25-80 -I 7

7950:
Quote
start /D "C:\cgmine" cgminer.exe -o mint.bitminter.com:3333 -u username -p password --temp-target 85 --auto-fan  --auto-gpu --gpu-engine 500-970 --gpu-memdiff -150 --gpu-fan 25-80 -I 7





You have been very helpful. Now that you know my cards what pools do you suggest I use? Not that my cards matter. I'm lookin to get the best bang for my buck here.
crazyates
Legendary
*
Offline Offline

Activity: 952
Merit: 1000



View Profile
June 25, 2013, 04:52:48 AM
 #7

I added --gpu-memdiff -125 to my command list.

It's weird that you say it can't manage my memory clock but I just checked trixx and it's set to 300....

Well hey, this kind of information is important. If Trixx (or MSI AB, which I prefer) is also managing the memory speed, then you should remove those settings from the CGMiner command. Also, download GPU-z and use the sensors tab to verify that the GPU is actually setting the mem clocks down to 300, and not just reporting it as 300 and using the defaults without you knowing it. Yes, this does happen, and yes, it is annoying.

New command, using Trixx to set the core clock and memory speeds.
Quote
start /D "C:\cgmine" cgminer.exe -o mint.bitminter.com:3333 -u username -p password --temp-target 85 --auto-fan  --gpu-fan 25-80 -I 7

Tips? 1crazy8pMqgwJ7tX7ZPZmyPwFbc6xZKM9
Previous Trade History - Sale Thread
crazyates
Legendary
*
Offline Offline

Activity: 952
Merit: 1000



View Profile
June 25, 2013, 04:58:03 AM
 #8

You have been very helpful. Now that you know my cards what pools do you suggest I use? Not that my cards matter. I'm lookin to get the best bang for my buck here.

As I said, you should look HERE, and choose one you think looks good. I personally use Ozcoin, Bitminter, Slush, or Eclipse, but those are personal preferences. I choose a pool based off how much I trust the pool op as much as their feature list and/or pool fees.

Tips? 1crazy8pMqgwJ7tX7ZPZmyPwFbc6xZKM9
Previous Trade History - Sale Thread
kgonepostl
Full Member
***
Offline Offline

Activity: 124
Merit: 100



View Profile
June 25, 2013, 05:01:34 AM
 #9

My gpu keeps pushing the fan to 100% with that bat script you suggested. Is that ok to push it to 100 every 1-2 minutes?
crazyates
Legendary
*
Offline Offline

Activity: 952
Merit: 1000



View Profile
June 25, 2013, 06:18:47 AM
 #10

My gpu keeps pushing the fan to 100% with that bat script you suggested. Is that ok to push it to 100 every 1-2 minutes?
The bat settings I gave you should cap the fan speed at 80%, not 100%. Try checking to make sure Trixx or some other software isn't controlling the fan speed instead of CGMiner?

But yes, it is safe to fun the fans at 100%. Some people run them that high 24/7. It can sometimes decrease the life of the fan, by wearing the bearings, but it can also extend the life of the GPU by keeping the temps down. If you can handle the noise, I'd say go as high on the fan as you're comfortable with.

Tips? 1crazy8pMqgwJ7tX7ZPZmyPwFbc6xZKM9
Previous Trade History - Sale Thread
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!