Bitcoin Forum
December 05, 2016, 08:29:27 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: linux screen is acting weird  (Read 1125 times)
carlo
Full Member
***
Offline Offline

Activity: 132


View Profile
June 29, 2011, 12:53:47 PM
 #1

Hello,

i cant use "screen -dmS title comand". It does this:

Code:
user@lnx-box:/home/user/poclbm# screen -dmS test ./start.sh
user@lnx-box:/home/user/poclbm# screen -r
There is no screen to be resumed.

just running the shell script "start.sh":

Code:
user@lnx-box:/home/user/poclbm# ./start.sh
Startming Miner: 1
No protocol specified
pit.deepbit.net:8332 29/06/2011 14:46:08, Setting pool xxxx @ pit.deepbit.net:8332
pit.deepbit.net:8332 29/06/2011 14:46:09, Using new LP URL .....
pit.deepbit.net:8332 29/06/2011 14:46:09, LP connected to pit.deepbit.net:8332
pit.deepbit.net:8332 120018 khash/s^C

This also works:

Code:
screen -S test
*enter*
./start
*CTRL+A - D*

Heres there is my start.sh:
Code:
export AMDAPPSDKROOT=${HOMEDIR}/ati-stream-sdk-v2.1-lnx64/
export AMDAPPSDKSAMPLESROOT=${HOMEDIR}/ati-stream-sdk-v2.1-lnx64/
export LD_LIBRARY_PATH=${AMDAPPSDKROOT}lib/x86_64:${LD_LIBRARY_PATH}
echo "Startming Miner: 1"
DISPLAY=:0 python poclbm.py -d1 --host=xxxxxxxx --port=xxxx --user=xxxxxx --pass=xxxxxxxx

Now i dont know, why i cant auto-detach on startup ?

Thanks for all ideas and the whole support here in the forum.

1480926567
Hero Member
*
Offline Offline

Posts: 1480926567

View Profile Personal Message (Offline)

Ignore
1480926567
Reply with quote  #2

1480926567
Report to moderator
1480926567
Hero Member
*
Offline Offline

Posts: 1480926567

View Profile Personal Message (Offline)

Ignore
1480926567
Reply with quote  #2

1480926567
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480926567
Hero Member
*
Offline Offline

Posts: 1480926567

View Profile Personal Message (Offline)

Ignore
1480926567
Reply with quote  #2

1480926567
Report to moderator
1480926567
Hero Member
*
Offline Offline

Posts: 1480926567

View Profile Personal Message (Offline)

Ignore
1480926567
Reply with quote  #2

1480926567
Report to moderator
drawoc
Full Member
***
Offline Offline

Activity: 168

Firstbits: 175wn


View Profile
June 29, 2011, 09:11:47 PM
 #2

Maybe start.sh is just dying right away?
I assume you've defined ${HOMEDIR} as a variable in your .bashrc? If so, you might want to make sure your script runs with bash and not some other interpreter by adding this in the beginning of your script:
Code:
#!/bin/bash

Donate: 175WNXmJ1WVhFgVGKUqEhYtAQGRYAvqPA
Grinder
Legendary
*
Offline Offline

Activity: 1269


View Profile
June 29, 2011, 09:19:30 PM
 #3

Try adding
#!/bin/bash
cd /home/user/poclbm

to the beginning of the script. If it still doesn't work, add -L to the screen command to log the output.
carlo
Full Member
***
Offline Offline

Activity: 132


View Profile
July 01, 2011, 01:59:25 PM
 #4

Thanks a lot ... with the -L parameter i found out that im too stupid for typing corret.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!