Bitcoin Forum
December 09, 2016, 02:22:02 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: GUIMiner no OpenCL devices found Debian Linux  (Read 4127 times)
rexguitly
Newbie
*
Offline Offline

Activity: 2


View Profile
June 30, 2011, 11:23:43 PM
 #1

Hi!

I am using Debian Sid which is very similiar to Ubuntu and it is very hard to find good instructions on the net for this, as I also have a NVidia GeForce 8600M GT.
My first question: Do i really need something form the ATI Steam SDK? This seems weird but all manuals on the net lack information about this.

I tried several python miners like Poclbm-mod, Poclbm and GUIMiner. I have OpenCL and PyOpenCL installed form the repositories and the GUIMiner for example starts like a charm with a good error message:

Quote
No OpenCL devices were found...

With Poclbm-mod and Poclbm i get the following error message:

Quote
platforms = cl.get_platforms()
pyopencl.LogicError: clGetPlatformIDs failed: invalid/unknown error code

This seems to be the same error, OpenCL does not work probably. Does anyone know how to handle this error?
Or is there another method to do GPU bitcoin mining on Debian Linux?

Greetz

1481250122
Hero Member
*
Offline Offline

Posts: 1481250122

View Profile Personal Message (Offline)

Ignore
1481250122
Reply with quote  #2

1481250122
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481250122
Hero Member
*
Offline Offline

Posts: 1481250122

View Profile Personal Message (Offline)

Ignore
1481250122
Reply with quote  #2

1481250122
Report to moderator
Jaime Frontero
Full Member
***
Offline Offline

Activity: 126


View Profile
July 01, 2011, 01:20:18 AM
 #2

i'm not really certain how nvidia cards work - although i do use debian testing - but i am pretty sure that any ATI program is not going to work.  the ATI SDK is only for ATI/AMD cards.

i'd recommend you give hashkill a shot, here:

http://forum.bitcoin.org/index.php?topic=6819.0

it's simple to use, works with ATI and nvidia, and doesn't require much in the way of hardware-specific software.

look through the thread - but the destructions are in the first post.

rexguitly
Newbie
*
Offline Offline

Activity: 2


View Profile
July 01, 2011, 02:37:34 PM
 #3

I give up. Hashkill gives me this:
Quote
[error] (ocl-threads.c:97) clGetPlatformIDs returned error (no OpenCL installed?)

The coder of haskill says that ICD needs to be installed here. But i already installed the package nvidia-opencl-icd. This is a debian issue or sth.

I give up.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!