Bitcoin Forum
June 21, 2018, 01:39:32 AM *
News: Latest stable version of Bitcoin Core: 0.16.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Ubuntu poclbm + stream issue, 1BTC reward  (Read 1506 times)
AndyRossy
Sr. Member
****
Offline Offline

Activity: 448
Merit: 250


View Profile
July 01, 2011, 05:04:18 PM
 #1

Hi guys, wondering if someone could be as kind as to help me

poclbm only detects the CPU (not the cards - 2 x 6950's)

here's some outputs/logs:

andrew@sky:~/bc$ python poclbm.py
No protocol specified
No device specified or device not found, use -d to specify one of the following

  •     AMD Sempron(tm) 140 Processor


andrew@sky:~/bc$ sudo aticonfig --list-adapters
* 0. 01:00.0 AMD Radeon HD 6900 Series
  1. 02:00.0 AMD Radeon HD 6900 Series

* - Default adapter



andrew@sky:~/bc$ lspci
....
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
01:00.0 VGA compatible controller: ATI Technologies Inc Cayman PRO [AMD Radeon 6900 Series]
01:00.1 Audio device: ATI Technologies Inc Device aa80
02:00.0 VGA compatible controller: ATI Technologies Inc Cayman PRO [AMD Radeon 6900 Series]
02:00.1 Audio device: ATI Technologies Inc Device aa80
....

andrew@sky:~/bc$ lsmod | grep fglr
fglrx                2490187  120

andrew@sky:~/bc$ dmesg | grep fglr
[    9.542661] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[   10.107514] [fglrx] Maximum main memory to use for locked dma buffers: 1884 MBytes.
[   10.107587] [fglrx]   vendor: 1002 device: 6719 count: 1
[   10.107590] [fglrx]   vendor: 1002 device: 6719 count: 2
[   10.107849] [fglrx] ioport: bar 4, base 0xc000, size: 0x100
[   10.107900] [fglrx] ioport: bar 4, base 0xd000, size: 0x100
[   10.108326] [fglrx] Kernel PAT support is enabled
[   10.108347] [fglrx] module loaded - fglrx 8.86.5 [May 24 2011] with 2 minors
[   11.875173] fglrx_pci 0000:01:00.0: irq 49 for MSI/MSI-X
[   11.875672] [fglrx] Firegl kernel thread PID: 1118
[   11.875706] [fglrx] Firegl kernel thread PID: 1119
[   11.875739] [fglrx] Firegl kernel thread PID: 1120
[   11.876016] [fglrx] IRQ 49 Enabled
[   12.443914] fglrx_pci 0000:02:00.0: irq 50 for MSI/MSI-X
[   12.444486] [fglrx] Firegl kernel thread PID: 1122
[   12.444521] [fglrx] Firegl kernel thread PID: 1123
[   12.444554] [fglrx] Firegl kernel thread PID: 1124
[   12.444973] [fglrx] IRQ 50 Enabled
[   12.660510] [fglrx] Gart USWC size:628 M.
[   12.660513] [fglrx] Gart cacheable size:247 M.
[   12.660517] [fglrx] Reserved FB block: Shared offset:0, size:1000000
[   12.660520] [fglrx] Reserved FB block: Unshared offset:fb07000, size:1f9000
[   12.660522] [fglrx] Reserved FB block: Unshared offset:3fff4000, size:c000
[   12.967517] [fglrx] Gart USWC size:628 M.
[   12.967520] [fglrx] Gart cacheable size:247 M.
[   12.967525] [fglrx] Reserved FB block: Shared offset:0, size:1000000
[   12.967527] [fglrx] Reserved FB block: Unshared offset:fb07000, size:1f9000
[   12.967529] [fglrx] Reserved FB block: Unshared offset:3fff4000, size:c000

andrew@sky:~/bc$ fglrxinfo
No protocol specified
Error: unable to open display (null)
andrew@sky:~/bc$

andrew@sky:~/bc$ tail -n6 ~/.bashrc
fi
export AMDAPPSDKSAMPLESROOT=/home/andrew/AMD-APP-SDK-v2.4-lnx32/
export LD_LIBRARY_PATH=${AMDAPPSDKROOT}lib/x86:${LD_LIBRARY_PATH}
export AMDAPPSDKROOT=/home/andrew/AMD-APP-SDK-v2.4-lnx32/
export ATISTREAMSDKROOT=/home/andrew/AMD-APP-SDK-v2.4-lnx32/
export LIBRARY_PATH=$LIBRARY_PATH:$ATISTREAMSDKROOT/lib/x86/



I'll ship 1 BTC to whoever gives me the solution, and yes, X is running and I did do aticonfig --adapters=all initial + reboot.  

*hopeful*
1529545172
Hero Member
*
Offline Offline

Posts: 1529545172

View Profile Personal Message (Offline)

Ignore
1529545172
Reply with quote  #2

1529545172
Report to moderator
1529545172
Hero Member
*
Offline Offline

Posts: 1529545172

View Profile Personal Message (Offline)

Ignore
1529545172
Reply with quote  #2

1529545172
Report to moderator
1529545172
Hero Member
*
Offline Offline

Posts: 1529545172

View Profile Personal Message (Offline)

Ignore
1529545172
Reply with quote  #2

1529545172
Report to moderator
The World's Betting Exchange

Bet with play money. Win real Bitcoin. 5BTC Prize Fund for World Cup 2018.

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1529545172
Hero Member
*
Offline Offline

Posts: 1529545172

View Profile Personal Message (Offline)

Ignore
1529545172
Reply with quote  #2

1529545172
Report to moderator
1529545172
Hero Member
*
Offline Offline

Posts: 1529545172

View Profile Personal Message (Offline)

Ignore
1529545172
Reply with quote  #2

1529545172
Report to moderator
jondecker76
Full Member
***
Offline Offline

Activity: 238
Merit: 100


View Profile
July 01, 2011, 05:22:26 PM
 #2

Is pyOpenCl installed?


RollerBot Advanced Trading Platform
https://bitcointalk.org/index.php?topic=447727.0
BTC Donations for development: 1H36oTJsi3adFh68wwzz95tPP2xoAoTmhC
AndyRossy
Sr. Member
****
Offline Offline

Activity: 448
Merit: 250


View Profile
July 01, 2011, 05:26:44 PM
 #3

yes was installed, this is fixed now - ty to tortib on irc.
Naven
Newbie
*
Offline Offline

Activity: 21
Merit: 0


View Profile
July 01, 2011, 06:42:21 PM
 #4

http://foreverrising.wordpress.com/2011/04/16/bitcoin-mining-and-ubuntu-10-10-ati-radeon-5xxx/
Look into section about SDK.

My wallet address - 1NCTVzXgkjmCEL3UuS4RSgHKKqRBtDHnC4 Smiley

If u got to much BTCs - 1PrbRQReXHTM9uXsivMuKDgbQMqxWxJVzA
drawoc
Full Member
***
Offline Offline

Activity: 168
Merit: 100

Firstbits: 175wn


View Profile
July 01, 2011, 07:33:15 PM
 #5

Try running:
Code:
export DISPLAY=:0
Before running poclbm.
Also, are you running this from a virtual terminal (Ctrl-Alt-F1), or an xterm? (Xterm is preferred)

Donate: 175WNXmJ1WVhFgVGKUqEhYtAQGRYAvqPA
Ookami
Newbie
*
Offline Offline

Activity: 21
Merit: 0


View Profile
July 04, 2011, 01:33:20 PM
 #6

Try installing an X-Server if not already done. It sadly won't work without one - which is the last thing one looks if setting up a box thats not supposed to have a monitor attached ^^



1HfPrtm6Jdbn3Egd8HTc3zQmiKTNfXQavz (if that helped *g*)

whopper
Newbie
*
Offline Offline

Activity: 24
Merit: 0

SysAdmin & Programmer


View Profile
July 04, 2011, 02:47:53 PM
 #7

Hey there,

is this ubuntu server? try the following:

sudo apt-get install xinit
screen -S x
sudo xinit

leave screen with "ctrl+a", "d"

try again Wink

also you can try CLInfo with the following command and see if your gpu is listed:
/opt/ati-stream-sdk-v2.1-lnx64/samples/opencl/bin/x86_64/CLInfo
AndyRossy
Sr. Member
****
Offline Offline

Activity: 448
Merit: 250


View Profile
July 04, 2011, 04:06:32 PM
 #8

I dont know why people are posted here ! It was solved in post #2 or 3, the problem was - for those that get similar, that the current user did not have access to the X session (as he wasnt logged into it)
drawoc
Full Member
***
Offline Offline

Activity: 168
Merit: 100

Firstbits: 175wn


View Profile
July 04, 2011, 05:24:01 PM
 #9

Ah well, you weren't too clear - I interpreted this to only mean that pyOpencl was installed:
yes was installed, this is fixed now - ty to tortib on irc.

I see now that you intended to say that you fixed your issue. Sorry.

Donate: 175WNXmJ1WVhFgVGKUqEhYtAQGRYAvqPA
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!