Bitcoin Forum
October 17, 2018, 04:40:10 AM *
News: Make sure you are not using versions of Bitcoin Core other than 0.17.0 [Torrent], 0.16.3, 0.15.2, or 0.14.3. More info.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: compiling bitcoin 0.9.4 problem  (Read 31 times)
myapple
Member
**
Offline Offline

Activity: 100
Merit: 10


View Profile
December 18, 2017, 11:52:38 AM
 #1

I am compiling bitcoin wallet 0.9.4
In the guide it says
Cd /c/bitcoin-0.9.4

./autogen.sh

CPPFLGS=“-|/c/....

Autually how to run this since CPPFLGS is not a command
Where to put this code? Run command it was not recognized
1539751210
Hero Member
*
Offline Offline

Posts: 1539751210

View Profile Personal Message (Offline)

Ignore
1539751210
Reply with quote  #2

1539751210
Report to moderator
1539751210
Hero Member
*
Offline Offline

Posts: 1539751210

View Profile Personal Message (Offline)

Ignore
1539751210
Reply with quote  #2

1539751210
Report to moderator
1539751210
Hero Member
*
Offline Offline

Posts: 1539751210

View Profile Personal Message (Offline)

Ignore
1539751210
Reply with quote  #2

1539751210
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1539751210
Hero Member
*
Offline Offline

Posts: 1539751210

View Profile Personal Message (Offline)

Ignore
1539751210
Reply with quote  #2

1539751210
Report to moderator
1539751210
Hero Member
*
Offline Offline

Posts: 1539751210

View Profile Personal Message (Offline)

Ignore
1539751210
Reply with quote  #2

1539751210
Report to moderator
1539751210
Hero Member
*
Offline Offline

Posts: 1539751210

View Profile Personal Message (Offline)

Ignore
1539751210
Reply with quote  #2

1539751210
Report to moderator
myapple
Member
**
Offline Offline

Activity: 100
Merit: 10


View Profile
December 18, 2017, 12:05:37 PM
 #2

I am according to the guide
https://bitcointalk.org/index.php?topic=149479.0

But it is not clear for bitcoin 0.9.4 and for qt on 0.8.6 it not works
For 0.8.6 it compiled one bitcoind but cannot for qt
achow101
Moderator
Legendary
*
expert
Offline Offline

Activity: 1554
Merit: 1701


3F1Y9yquzvY6RWvKbw2n2zeo9V5mvBhADU


View Profile WWW
December 18, 2017, 03:25:30 PM
 #3

Why are you trying to compile such old software?

You should use the latest Bitcoin Core and follow the build instructions provided by Core: https://github.com/bitcoin/bitcoin/blob/master/doc/build-windows.md

cr1776
Legendary
*
Offline Offline

Activity: 2030
Merit: 1008


View Profile
December 18, 2017, 03:35:57 PM
 #4

I am compiling bitcoin wallet 0.9.4
In the guide it says
Cd /c/bitcoin-0.9.4

./autogen.sh

CPPFLGS=“-|/c/....

Autually how to run this since CPPFLGS is not a command
Where to put this code? Run command it was not recognized

CPPFLGS is a variable/macro used to include directories.  make then uses them as part of the build process.  Are you using the shell as mentioned in the instructions you are following?  (e.g. Install msys shell ).  Perhaps you are using the wrong shell?

And to reiterate what achow101 said, is there a reason to use 0.9.4 vs 0.15.1?
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!