Bitcoin Forum
October 18, 2017, 06:44:54 PM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: has anyone compile namecoin-qt successfully ?  (Read 865 times)
bluebelt
Newbie
*
Offline Offline

Activity: 4


View Profile
July 26, 2013, 04:47:28 AM
 #1

Hi, everybody!

I try to compile  namecoin-qt and always end up with a loooot of errors. I followed instructions on the namecoin official site. but I'm not quite sure if i had them all installed, i run salix btw. I installed boost, qt-4.8, don't know if it include 'qt4-linguist-tools libqt4-dev', I run 'slapt-get search' for them , got zero outcome.

the following are some errors at the make step, have no idea what it means
Code:
../src/main.h:250:5: warning:未使用的变量‘fWrite’ [-Wunused-variable]
../src/main.h:250:5: warning:未使用的变量‘fRead’ [-Wunused-variable]
In file included from ../src/util.cpp:6:0:
/usr/include/boost/program_options/detail/config_file.hpp: In instantiation of ‘bool boost::program_options::detail::basic_config_file_iterator<charT>::getline(std::string&) [with charT = char; std::string = std::basic_string<char>]’:
../src/util.cpp:1103:1:   required from here
/usr/include/boost/program_options/detail/config_file.hpp:163:13: error:‘to_internal’ was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
In file included from /usr/include/boost/program_options/detail/parsers.hpp:9:0,
                 from /usr/include/boost/program_options/parsers.hpp:265,
                 from ../src/util.cpp:7:
/usr/include/boost/program_options/detail/convert.hpp:75:34: 附注:‘template<class T> std::vector<std::basic_string<char> > boost::program_options::to_internal(const std::vector<T>&)’ declared here, later in the translation unit
../src/util.cpp:972:41: warning:忽略声明有 warn_unused_result 属性的‘size_t fwrite(const void*, size_t, size_t, FILE*)’的返回值 [-Wunused-result]
In file included from ../src/script.h:8:0,
                 from ../src/main.h:10,
                 from ../src/headers.h:100,
                 from ../src/util.cpp:4:
../src/keystore.h: 在成员函数‘virtual bool CKeyStore::HaveKey(const std::vector<unsigned char>&) const’中:
../src/keystore.h:60:5: warning:在有返回值的函数中,控制流程到达函数尾 [-Wreturn-type]
make: *** [build/util.o] error 1

please help!
1508352294
Hero Member
*
Offline Offline

Posts: 1508352294

View Profile Personal Message (Offline)

Ignore
1508352294
Reply with quote  #2

1508352294
Report to moderator
1508352294
Hero Member
*
Offline Offline

Posts: 1508352294

View Profile Personal Message (Offline)

Ignore
1508352294
Reply with quote  #2

1508352294
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1508352294
Hero Member
*
Offline Offline

Posts: 1508352294

View Profile Personal Message (Offline)

Ignore
1508352294
Reply with quote  #2

1508352294
Report to moderator
1508352294
Hero Member
*
Offline Offline

Posts: 1508352294

View Profile Personal Message (Offline)

Ignore
1508352294
Reply with quote  #2

1508352294
Report to moderator
markm
Legendary
*
Offline Offline

Activity: 1974



View Profile WWW
July 26, 2013, 04:49:23 AM
 #2

I couldn't get it to compile on Fedora Core 17 too where I compile all the other coins, so I gave up on it for now.

Hopefully some future version will work.

-MarkM-

Browser-launched Crossfire client now online (select CrossCiv server for Galactic  Milieu)
Free website hosting with PHP, MySQL etc: http://hosting.knotwork.com/
dego
Sr. Member
****
Offline Offline

Activity: 389



View Profile
July 26, 2013, 05:16:40 AM
 #3

As it is stated: just 控制流程到达函数尾

ICON
███
███
███
███
███
.....HYPERCONNECT THE WORLD.....
Blockchain Multiverse
███
███
███
███
███

  JOIN ICO NOW ! 

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!