Bitcoin Forum
December 06, 2016, 08:33:39 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: [ERROR] Pushpoold "unkown-work" $50 Bounty  (Read 3776 times)
redshark1802
Jr. Member
*
Offline Offline

Activity: 44


View Profile
July 08, 2011, 12:24:57 PM
 #1

Hello,

i've played a bit aroung with pushpoold and everything worked just fine.
But when I asked a friend for a little test something strange happened.
I have about 100MH/s my friend has 1500MH/s.
As soon as my friend joined for testing i got a lot of stales,
I looked it up in the datase and the reason is "unknown-work".
Where does this come from?

Help with this would be really nice.


regards, redshark1802

ps: things I've tried so far with help from the irc-channnel
-checking that the blockchain is complete
-checking if the time is correct
-decreased the speed from my friend to 300MH/s


-my friend has no problems at all
-unknown is like 90% of the work sent

If the post above is something worth to you, please consider donating Wink.
1HYek9jXvbMDYyYwN7rxy9i3oDWgCYhATx
1481013219
Hero Member
*
Offline Offline

Posts: 1481013219

View Profile Personal Message (Offline)

Ignore
1481013219
Reply with quote  #2

1481013219
Report to moderator
1481013219
Hero Member
*
Offline Offline

Posts: 1481013219

View Profile Personal Message (Offline)

Ignore
1481013219
Reply with quote  #2

1481013219
Report to moderator
1481013219
Hero Member
*
Offline Offline

Posts: 1481013219

View Profile Personal Message (Offline)

Ignore
1481013219
Reply with quote  #2

1481013219
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481013219
Hero Member
*
Offline Offline

Posts: 1481013219

View Profile Personal Message (Offline)

Ignore
1481013219
Reply with quote  #2

1481013219
Report to moderator
AnnihilaT
Full Member
***
Offline Offline

Activity: 196



View Profile
July 09, 2011, 02:14:44 AM
 #2

  

Try adding this to your server.json config

Code:
  # disable X-Rollntime support
   "roll.ntime.disable" : true

Dont forget to add an extra comma at the end of the config option above it if you put this at the end of your config.  


redshark1802
Jr. Member
*
Offline Offline

Activity: 44


View Profile
July 09, 2011, 02:23:58 PM
 #3

Thanks for the hint Smiley.
I'm now testing, with and without the patch suggested by redditorrex.
so far it's not looking that good :/.


edit: it got a little bit better.

If the post above is something worth to you, please consider donating Wink.
1HYek9jXvbMDYyYwN7rxy9i3oDWgCYhATx
AnnihilaT
Full Member
***
Offline Offline

Activity: 196



View Profile
July 09, 2011, 02:53:29 PM
 #4

Thanks for the hint Smiley.
I'm now testing, with and without the patch suggested by redditorrex.
so far it's not looking that good :/.


edit: it got a little bit better.

did you upgrade to newest pushpoold 0.5.1 and newest bitcoind and restart them both after editing the server.json file ?
redshark1802
Jr. Member
*
Offline Offline

Activity: 44


View Profile
July 09, 2011, 02:56:50 PM
 #5

yes I did, this is frustrating. I have no clue where this comes from.

If the post above is something worth to you, please consider donating Wink.
1HYek9jXvbMDYyYwN7rxy9i3oDWgCYhATx
AnnihilaT
Full Member
***
Offline Offline

Activity: 196



View Profile
July 09, 2011, 03:02:11 PM
 #6

yes I did, this is frustrating. I have no clue where this comes from.

can you post your server.josn file (edit the passwords and usernames out tho)
redshark1802
Jr. Member
*
Offline Offline

Activity: 44


View Profile
July 09, 2011, 03:08:14 PM
 #7

here is the config:
Code:
{
   "listen" : [

      { "port" : 8342 },


      { "port" : 8332, "protocol" : "http-json" },
          { "port" : 8335, "protocol" : "http-json",
        "proxy" : "XXX.XXX.XXX.XXX" },

      { "host" : "127.0.0.1", "port" : 8338, "protocol" : "binary" }
   ],

   "database" : {
      "engine" : "mysql",

      "host" : "localhost",

      "port" : 3306,


      "name" : "XXXXXXXX",

      "username" : "XXXXXXXXXXXXXX",

      "password" : "XXXXXXXXXXXXXXXXXXXx",

      "sharelog" : true,
      "stmt.pwdb":"SELECT password FROM pool_worker WHERE username = ?",

 "stmt.sharelog":"INSERT INTO shares (rem_host, username, our_result, upstream_result, reason, solution) VALUES (?, ?, ?, ?, ?, ?)"
   },

   "memcached" : {
      "servers" : [
         { "host" : "127.0.0.1", "port" : 11211 }
      ]
   },

   "pid" : "/home/XXXXXX/bitcoin/pushpool.pid",


   "forcehost" : "localhost.localdomain",

   "log.requests" : "/home/XXXXXX/bitcoin/request.log",
  "log.shares" : "/home/XXXXXX/bitcoin/shares.log",

   "longpoll.disable" : false,


   "auth.cred_cache.expire" : 75,
   "rpc.url" : "http://127.0.0.1:10000/",

   "rpc.user" : "XXXXXXXXXXXXXXXXXXXX",
   "rpc.pass" : "XXXXXXXXXXXXXX",


   "rpc.target.rewrite" : true,
   "roll.ntime.disable" : true
}

and thx for your help




If the post above is something worth to you, please consider donating Wink.
1HYek9jXvbMDYyYwN7rxy9i3oDWgCYhATx
jgarzik
Legendary
*
Offline Offline

Activity: 1470


View Profile
July 09, 2011, 05:08:51 PM
 #8

i've played a bit aroung with pushpoold and everything worked just fine.
But when I asked a friend for a little test something strange happened.
I have about 100MH/s my friend has 1500MH/s.
As soon as my friend joined for testing i got a lot of stales,
I looked it up in the datase and the reason is "unknown-work".

pushpool keeps a log of the last 120 seconds' worth of work received from bitcoind.

unknown-work error occurs when a miner submits work that is not in that log.


Jeff Garzik, bitcoin core dev team and BitPay engineer; opinions are my own, not my employer.
Donations / tip jar: 1BrufViLKnSWtuWGkryPsKsxonV2NQ7Tcj
redshark1802
Jr. Member
*
Offline Offline

Activity: 44


View Profile
July 09, 2011, 05:12:58 PM
 #9

Is this the  "auth.cred_cache.expire" : 75, option?
And if not how do I get pushpool do keep it longer, or is the problem
somewhere else on the host?

If the post above is something worth to you, please consider donating Wink.
1HYek9jXvbMDYyYwN7rxy9i3oDWgCYhATx
AnnihilaT
Full Member
***
Offline Offline

Activity: 196



View Profile
July 09, 2011, 05:23:24 PM
 #10

Is this the  "auth.cred_cache.expire" : 75, option?
And if not how do I get pushpool do keep it longer, or is the problem
somewhere else on the host?

I dont think so...  i think this option is how long it caches the authentication credentials (login/pass) for the worker  but could be horribly wrong Smiley  Havent looked at that part of the code yet.   check config.c in the src and that should give you a clue.

maybe also check that your system time is correct and you not drifting crazily? i dunno... im outta ideas for ya man.... that option i mentioned solved my issue (started when someone joined the pool with 30 GH/s)
redshark1802
Jr. Member
*
Offline Offline

Activity: 44


View Profile
July 09, 2011, 05:27:24 PM
 #11

you're right.
but the problem is very strange.
i figured out it has to be something wrong with the log.
i've received work and submitted within 120seconds.
where does pushpool log this, in memcached?

If the post above is something worth to you, please consider donating Wink.
1HYek9jXvbMDYyYwN7rxy9i3oDWgCYhATx
jgarzik
Legendary
*
Offline Offline

Activity: 1470


View Profile
July 09, 2011, 05:27:57 PM
 #12

Is this the  "auth.cred_cache.expire" : 75, option?

No.

Quote
And if not how do I get pushpool do keep it longer, or is the problem
somewhere else on the host?

The problem is with miners submitting old work.  They should not submit work older than 60 seconds, much less 120 seconds.


Jeff Garzik, bitcoin core dev team and BitPay engineer; opinions are my own, not my employer.
Donations / tip jar: 1BrufViLKnSWtuWGkryPsKsxonV2NQ7Tcj
redshark1802
Jr. Member
*
Offline Offline

Activity: 44


View Profile
July 09, 2011, 05:31:16 PM
 #13

Is this the  "auth.cred_cache.expire" : 75, option?

No.

Quote
And if not how do I get pushpool do keep it longer, or is the problem
somewhere else on the host?

The problem is with miners submitting old work.  They should not submit work older than 60 seconds, much less 120 seconds.



increasing the askrate of the miner would help against this?
but why do I have no troubles on other pools?

If the post above is something worth to you, please consider donating Wink.
1HYek9jXvbMDYyYwN7rxy9i3oDWgCYhATx
redshark1802
Jr. Member
*
Offline Offline

Activity: 44


View Profile
July 09, 2011, 05:56:21 PM
 #14

I've tried increasing the askrate and it helps a litte bit.
their are still 50% unknown-works, how can i check that pushpool logs everything right?

If the post above is something worth to you, please consider donating Wink.
1HYek9jXvbMDYyYwN7rxy9i3oDWgCYhATx
redshark1802
Jr. Member
*
Offline Offline

Activity: 44


View Profile
July 10, 2011, 09:55:23 AM
 #15

the problem is still present.
i pledge 50$ for a solution. I'd pay via paypal since I have not much BTC.

If the post above is something worth to you, please consider donating Wink.
1HYek9jXvbMDYyYwN7rxy9i3oDWgCYhATx
redshark1802
Jr. Member
*
Offline Offline

Activity: 44


View Profile
July 10, 2011, 07:05:50 PM
 #16

After some testing, with the help from denisx in the irc, we figured out that this issue seems to
bo related to pushpool, phoenix and perhaps nvidia, all combined.
He runs a pool too and when I've pointed my phoenixminer at his pool, the same results.

Now, when I do the same thing with poclbm against my and his pool I have no unknown-work, in fact ~0 stales.
Tested with different versions of phoenix and pushpool.

diablo-miner and poclbm are working great.
additionally denisx reported that some members of his pool with nvidia cards have problems too.

If the post above is something worth to you, please consider donating Wink.
1HYek9jXvbMDYyYwN7rxy9i3oDWgCYhATx
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!