Bitcoin Forum
December 15, 2017, 10:31:53 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: [CLOSED] Final Fantasy XIV: Realm Reborn Pre-Order  (Read 408 times)
Damnsammit
Sr. Member
****
Offline Offline

Activity: 406



View Profile
August 19, 2013, 06:55:00 PM
 #1

Not even sure how this would work, but I am looking to get this game after getting my family hooked on it this weekend.  My three-year-old told me that I have to play it tonight and didn't understand that the beta is closed until Friday.

Figured I would try to get it on here as I'd rather spend Bitcoins on video games than USD if at all possible.

Let me know if you can do this... guess you would need my Square Enix ID?
1513377114
Hero Member
*
Offline Offline

Posts: 1513377114

View Profile Personal Message (Offline)

Ignore
1513377114
Reply with quote  #2

1513377114
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Maidak
Legendary
*
Offline Offline

Activity: 1092


bitcoinminerz.com


View Profile WWW
August 19, 2013, 07:22:17 PM
 #2

They wont need your square enix ID to do so, I believe I actually have a left over CD key to a collectors edition as I bought about 30 of those games for intentions on reselling let me look around send me a PM on how much your willing to offer for a collectors edition CD key.

Buy & Sell Bitcoin | Escrow | BitcoinminerZ.com | MMOclub.com Contact by SMS/Call(717)454-4274 or email maidak@mmoclub.com for fast service!
Damnsammit
Sr. Member
****
Offline Offline

Activity: 406



View Profile
August 19, 2013, 07:38:50 PM
 #3

Not really wanting to get the Collector's Edition... was just trying to get the cheapest PC version possible, but I sent you a PM.

.3btc?
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!