Bitcoin Forum
December 07, 2016, 12:52:12 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Testing Bitcoin on Ubuntu 10.04 LTS x64 Makes System Unresponsive  (Read 2121 times)
daemox
Newbie
*
Offline Offline

Activity: 2


View Profile
July 12, 2010, 03:40:21 AM
 #1

Hello,

I'm interested in Bitcoin, but while generating coins it rendered my system pretty much unusable (system became very unresponsive, even after manually adjusting Bitcoin's priority down).

If there are any suggestions for getting Bitcoin to function better I'd love to hear them.

Thank you,
daemox
1481115132
Hero Member
*
Offline Offline

Posts: 1481115132

View Profile Personal Message (Offline)

Ignore
1481115132
Reply with quote  #2

1481115132
Report to moderator
1481115132
Hero Member
*
Offline Offline

Posts: 1481115132

View Profile Personal Message (Offline)

Ignore
1481115132
Reply with quote  #2

1481115132
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
NewLibertyStandard
Sr. Member
****
Offline Offline

Activity: 252



View Profile WWW
July 12, 2010, 05:21:02 AM
 #2

If you have a multi core processor, free up a core in the options. If you have hyper threading enabled, don't use more than half your cores. If you have a single core, you'll be just as well off purchasing or working for bitcoins because generating them will likely take a very long time.

Treazant: A Fullever Rewarding Bitcoin - Backup Your Wallet TODAY to Double Your Money! - Dual Currency Donation Address: 1Dnvwj3hAGSwFPMnkJZvi3KnaqksRPa74p
asdfman
Newbie
*
Offline Offline

Activity: 17


View Profile
July 12, 2010, 08:36:16 AM
 #3

bitcoin manually changes the thread priorities when it generates coins, I think there is a bug in which they are switching to the MAX priority, instead of the MIN.. I myself just ripped out the whole priority changing part so that whatever I change it to, stays.. these 2 threads describe both:

http://bitcointalk.org/index.php?topic=72.0
http://bitcointalk.org/index.php?topic=285.0

As the computer I put bitcoind, is my primary linux machine, I was unable to keep bitcoind running until making my changes..
TrafficTiger
Newbie
*
Offline Offline

Activity: 5


View Profile
July 12, 2010, 02:56:52 PM
 #4

I was attracted to Bitcoin by many things, and included was the statement about its running in the background when the CPU was idle. I installed 0.3.0 in Ubuntu 64-bit Maverick Meerkat (10.10), and for long periods of time it pins the CPU at 100%, according to the Conky monitor.

As the original poster noted, it is impossible to do anything else while the CPU is captured.

My CPU is an AMD Athlon 64-bit 7550 Dual Core 2511 MHz 512 KB cache.

TT
laszlo
Full Member
***
Offline Offline

Activity: 199


View Profile
July 12, 2010, 03:01:46 PM
 #5

Please try running with 'nice -n 19 ./bitcoin'
or renice +19 1234 where 1234 is the pid of the running bitcoin.

There is a bug in the released linux version which prevents it from successfully lowering its own priority.

BC: 157fRrqAKrDyGHr1Bx3yDxeMv8Rh45aUet
daemox
Newbie
*
Offline Offline

Activity: 2


View Profile
July 13, 2010, 05:23:55 PM
 #6

Thanks for the prompt (and concise) replies. I am currently re-testing, and I caught one mistake I made. I was originally running Bitcoin as root. I am currently re-testing sans the root and the unresponsive system issues hasn't re-manifested itself.

I'm going to give the wiki a read and learn more about this setup (like where I can use this), but so far so good.

Cheers,
daemox
TrafficTiger
Newbie
*
Offline Offline

Activity: 5


View Profile
July 14, 2010, 01:11:15 PM
 #7

Please try running with 'nice -n 19 ./bitcoin'

That seems to be doing the trick. Thanks for the suggestion.

Somewhere I got the suggestion I should use -proxy=127.0.0.1:9050 in the command line, but it looks like it won't run with that setting.

TT
D҉ataWraith
Member
**
Offline Offline

Activity: 60



View Profile
July 14, 2010, 01:56:29 PM
 #8

Somewhere I got the suggestion I should use -proxy=127.0.0.1:9050 in the command line, but it looks like it won't run with that setting.

That command makes Bitcoin run via TOR if that is availabe. TOR makes it impossible to trace a transaction to your IP address, since communication travels through a chain of 3 proxy servers. If TOR is not running on the same computer, it doesn't work, as you have observed.

1NvcPV6xi6yqo5yg8aWSkNdasPSAsGtt1m
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!