Bitcoin Forum
September 25, 2018, 02:17:22 PM *
News: ♦♦ New info! Bitcoin Core users absolutely must upgrade to previously-announced 0.16.3 [Torrent]. All Bitcoin users should temporarily trust confirmations slightly less. More info.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Autostart Bitcoin-Qt Ubuntu  (Read 55 times)
Skruber
Newbie
*
Offline Offline

Activity: 4
Merit: 0


View Profile
January 23, 2018, 02:42:57 PM
 #1


I use ubuntu 16.04 LTS, after restarting the computer, the bitcoin purse starts automatically and always asks for the storage of blocks, how to solve this problem? What would the purse load and continue synchronization automatically.
1537885042
Hero Member
*
Offline Offline

Posts: 1537885042

View Profile Personal Message (Offline)

Ignore
1537885042
Reply with quote  #2

1537885042
Report to moderator
1537885042
Hero Member
*
Offline Offline

Posts: 1537885042

View Profile Personal Message (Offline)

Ignore
1537885042
Reply with quote  #2

1537885042
Report to moderator
1537885042
Hero Member
*
Offline Offline

Posts: 1537885042

View Profile Personal Message (Offline)

Ignore
1537885042
Reply with quote  #2

1537885042
Report to moderator
Make a difference with your Ether.
Donate Ether for the greater good.
SPRING.WETRUST.IO
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1537885042
Hero Member
*
Offline Offline

Posts: 1537885042

View Profile Personal Message (Offline)

Ignore
1537885042
Reply with quote  #2

1537885042
Report to moderator
LoyceV
Legendary
*
Offline Offline

Activity: 1246
Merit: 1995


Let's make Bitcointalk great again!


View Profile WWW
January 23, 2018, 02:45:42 PM
 #2

I'm not sure what you're asking.

Do you want to disable the auto-start? If so:
In Bitcoin Core, click Settings > Options > Main tab (default) > toggle Start Bitcoin Core on system login.

Or does it give you an error message about "storage of blocks"? If so, what is the exact error?

Skruber
Newbie
*
Offline Offline

Activity: 4
Merit: 0


View Profile
January 23, 2018, 03:10:18 PM
 #3

I'm not sure what you're asking.

Do you want to disable the auto-start? If so:
In Bitcoin Core, click Settings > Options > Main tab (default) > toggle Start Bitcoin Core on system login.

Or does it give you an error message about "storage of blocks"? If so, what is the exact error?
No, I do not want to disable autorun. When I start the bitcoin purse manually or through autorun, the window always appears, made a screenshot: http://joxi.ru/4AkqNq4IM978ym

I thought it should appear one-time, but it appears every time you start .. how do I fix it?
LoyceV
Legendary
*
Offline Offline

Activity: 1246
Merit: 1995


Let's make Bitcointalk great again!


View Profile WWW
January 23, 2018, 03:11:06 PM
 #4

I thought it should appear one-time, but it appears every time you start .. how do I fix it?
Did you set this download location in the past? If so, can you check what DataDir is mentioned in ~/.config/Bitcoin/Bitcoin-Qt.conf ?
One way to answer this question: enter this in a console:
Code:
grep DataDir ~/.config/Bitcoin/Bitcoin-Qt.conf

Did it ever finish synchronisation completely? I can't read the Russian text, but since it's in red: does it mean you don't have enough diskspace on that location (or on the default location)?

What happens if you just click "OK"?

Skruber
Newbie
*
Offline Offline

Activity: 4
Merit: 0


View Profile
January 23, 2018, 03:17:17 PM
 #5

I thought it should appear one-time, but it appears every time you start .. how do I fix it?
Did you set this download location in the past? If so, can you check what DataDir is mentioned in ~/.config/Bitcoin/Bitcoin-Qt.conf ?
One way to answer this question: enter this in a console:
Code:
grep DataDir ~/.config/Bitcoin/Bitcoin-Qt.conf
Result on the screenshot http://joxi.ru/zANWqWgcldoPBr
LoyceV
Legendary
*
Offline Offline

Activity: 1246
Merit: 1995


Let's make Bitcointalk great again!


View Profile WWW
January 23, 2018, 05:31:44 PM
 #6

Result on the screenshot http://joxi.ru/zANWqWgcldoPBr
So it does save to that location.

Did it ever finish synchronisation completely? Or does it mean you don't have enough diskspace on that location (or on the default location)? Enter this in a console:
Code:
du -h /media/roman/04A24F39A24F2E8C/Bitcoin | tail -n 1
df -h | grep media

Skruber
Newbie
*
Offline Offline

Activity: 4
Merit: 0


View Profile
January 25, 2018, 07:17:54 AM
 #7

Result on the screenshot http://joxi.ru/zANWqWgcldoPBr
So it does save to that location.

Did it ever finish synchronisation completely? Or does it mean you don't have enough diskspace on that location (or on the default location)? Enter this in a console:
Code:
du -h /media/roman/04A24F39A24F2E8C/Bitcoin | tail -n 1
df -h | grep media
Here is a screenshot http://joxi.ru/ZrJM7MlU1OKw4A
LoyceV
Legendary
*
Offline Offline

Activity: 1246
Merit: 1995


Let's make Bitcointalk great again!


View Profile WWW
January 25, 2018, 10:29:22 AM
 #8

Here is a screenshot http://joxi.ru/ZrJM7MlU1OKw4A
Your computer doesn't have enough disk space available to store the whole blockchain. It may still fit at the moment, but it will be full very soon.
I see three possible solutions:
1. Get a bigger hard drive.
2. Use Bitcoin Core in pruned mode (add -prune=550 to the command line so it fits in less than 10 GB; after this you can't use it to load old wallet.dat files or import keys).
3. Instead of Bitcoin Core, use a wallet that doesn't require you to download the full blockchain (for instance Electrum).

alko89
Jr. Member
*
Offline Offline

Activity: 105
Merit: 3


View Profile
January 25, 2018, 12:03:55 PM
Merited by AGD (1)
 #9

You don't need to start bitcoin wallet to start synching. What you need to start is `bitcoind`. The easiest way to do this is using Ubuntu systemd. I don't know how my exactly systemd file looks like, I can send it to you when I come home. Check if Ubuntu allready has a default systemd service for bitcoind.

After you'll have your service set up. You can enable it with `sudo systemctl enable bitcoind.service` -> enable is to enable service to start on boot. You can also use `start` to start the service once, `stop` to shut it down and `restart` to restart it.

Here is the systemd.service file from github.
https://github.com/bitcoin/bitcoin/blob/master/contrib/init/bitcoind.service

You will have to modify it to start up as the user you login with.
...
[Service]
...
User=CHANGEME
...

Hope it helps Smiley

❍ E M M A R E S (http://emmares.io/)  ❍
Email as you know it, will never be the same.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!