Bitcoin Forum
December 02, 2016, 10:32:29 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Running Phoenix.py on a Mac?  (Read 723 times)
drfuzzy
Newbie
*
Offline Offline

Activity: 6


Dr. Fuzzy


View Profile WWW
July 13, 2011, 10:37:24 PM
 #1

Help...

I've downloaded, compiled and installed PyOpenCL (version 2011-1.1).  It works fine with poclbm-mod.py

Twisted is supposed to be included with MacOSX 10.6 (and can't be upgraded by users w/o serious breakage).

BUT... when I run Phoenix, I get an import error:

------------------------------------
[~/Library/Miners] fuzzy% cd phoenix-1.50

[~/Library/Miners/phoenix-1.50] fuzzy% ls
ConsoleLogger.py   Miner.py      WorkQueue.py      minerutil
KernelInterface.py   QueueReader.py      kernels         phoenix.py

[~/Library/Miners/phoenix-1.50] fuzzy% python --version
Python 2.6.1

[~/Library/Miners/phoenix-1.50] fuzzy% python -c "import numpy; print numpy.version.version"
1.2.1

[~/Library/Miners/phoenix-1.50] fuzzy% ./phoenix.py
/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/twisted/internet/_sslverify.py:5: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import itertools, md5
Traceback (most recent call last):
  File "./phoenix.py", line 29, in <module>
    import minerutil
  File "/Users/fuzzy/Library/Miners/phoenix-1.50/minerutil/__init__.py", line 25, in <module>
    from RPCProtocol import RPCClient
  File "/Users/fuzzy/Library/Miners/phoenix-1.50/minerutil/RPCProtocol.py", line 26, in <module>
    from twisted.web.iweb import IBodyProducer
ImportError: cannot import name IBodyProducer

-------------------------------------

Any ideas?

--Fuzzy



"If brute force isn't working, you're not using enough!"
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!