Bitcoin Forum
December 17, 2017, 04:46:20 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: trouble getting cg miner to run  (Read 1518 times)
dantose
Newbie
*
Offline Offline

Activity: 2


View Profile
September 03, 2013, 04:33:38 AM
 #1

First off, complete newb to this.

I'm trying to mine on give-me-coins mining pool.

I installed cgminer via this guide: http://pfigue.github.io/blog/2013/03/01/installing-cgminer-on-ubuntu/

I get all the way through that and everything appears to be in order, but when i go to run it via this command:

Code:
./cgminer -scrypt -o ltc.give-me-coins.com:3333 -u [my pool username] -p [my pool password]

It returns:
Code:
./cgminer: -s: 'crypt' is not a number   

If I try taking the "-scrypt" out, it doesn't return any errors, but doesn't appear to do anything either.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1513485980
Hero Member
*
Offline Offline

Posts: 1513485980

View Profile Personal Message (Offline)

Ignore
1513485980
Reply with quote  #2

1513485980
Report to moderator
SpeedDemon13
Hero Member
*****
Offline Offline

Activity: 518



View Profile WWW
September 03, 2013, 04:44:41 AM
 #2

First off, complete newb to this.

I'm trying to mine on give-me-coins mining pool.

I installed cgminer via this guide: http://pfigue.github.io/blog/2013/03/01/installing-cgminer-on-ubuntu/

I get all the way through that and everything appears to be in order, but when i go to run it via this command:

Code:
./cgminer -scrypt -o ltc.give-me-coins.com:3333 -u [my pool username] -p [my pool password]

It returns:
Code:
./cgminer: -s: 'crypt' is not a number   

If I try taking the "-scrypt" out, it doesn't return any errors, but doesn't appear to do anything either.

I run cgminer in CMD with the following: cgminer --scrypt - w 256 --lookup-gap 2 -I 18 --thread-concurrency 7500 -g 1 --gpu-engine 900 --gpu-memclock 1100 - o <pool URL:port number> -u <Username> -p <Password>
 
Looks like your missing just one dash "-", it's suppose to be "--" before the scrypt flag. ie. --scrypt

CRYPTSY exchange: https://www.cryptsy.com/users/register?refid=9017 BURST= BURST-TE3W-CFGH-7343-6VM6R BTC=1CNsqGUR9YJNrhydQZnUPbaDv6h4uaYCHv ETH=0x144bc9fe471d3c71d8e09d58060d78661b1d4f32 SHF=0x13a0a2cb0d55eca975cf2d97015f7d580ce52d85 EXP=0xd71921dca837e415a58ca0d6dd2223cc84e0ea2f SC=6bdf9d12a983fed6723abad91a39be4f95d227f9bdb0490de3b8e5d45357f63d564638b1bd71 CLAMS=xGVTdM9EJpNBCYAjHFVxuZGcqvoL22nP6f SOIL=0x8b5c989bc931c0769a50ecaf9ffe490c67cb5911
vektor
Newbie
*
Offline Offline

Activity: 7


View Profile
September 03, 2013, 04:55:03 AM
 #3

# cgminer --scrypt -o http://foo.bar:#### -u cryptoAddress -p foobar


the abstraction layer defines your cryptography in OpenCL between CPU/GPU (an interface), which means that you don't have to explicitly cast "w 256", as it's implied by the engines you're using. aces.snu.ac.kr/~jlee/Jaejin_Lees_Home/Pact11_tutorial.html

Free and open source Bioinformatics developer  | Fields: Number Theory, Simulation, Mathematical Biology | Logic programmer for hire
dantose
Newbie
*
Offline Offline

Activity: 2


View Profile
September 03, 2013, 05:01:40 AM
 #4

First off, complete newb to this.

I'm trying to mine on give-me-coins mining pool.

I installed cgminer via this guide: http://pfigue.github.io/blog/2013/03/01/installing-cgminer-on-ubuntu/

I get all the way through that and everything appears to be in order, but when i go to run it via this command:

Code:
./cgminer -scrypt -o ltc.give-me-coins.com:3333 -u [my pool username] -p [my pool password]

It returns:
Code:
./cgminer: -s: 'crypt' is not a number  

If I try taking the "-scrypt" out, it doesn't return any errors, but doesn't appear to do anything either.

I run cgminer in CMD with the following: cgminer --scrypt - w 256 --lookup-gap 2 -I 18 --thread-concurrency 7500 -g 1 --gpu-engine 900 --gpu-memclock 1100 - o <pool URL:port number> -u <Username> -p <Password>
 
Looks like your missing just one dash "-", it's suppose to be "--" before the scrypt flag. ie. --scrypt

Just tried that, returned
Code:
./cgminer: --scrypt: unrecognized option

Quote
# cgminer --scrypt -o http://foo.bar:#### -u cryptoAddress -p foobar


the abstraction layer defines your cryptography in OpenCL between CPU/GPU (an interface). aces.snu.ac.kr/~jlee/Jaejin_Lees_Home/Pact11_tutorial.html

That is complete greek to me. If i created a user on give-me-coins.com with username Phil_McKrackin with password ZOMG!Password! should the command look like
Code:
./cgminer --scrypt -o ltc.give-me-coins.com:3333 -u Phil_McKrackin -p ZOMG!Password!
SpeedDemon13
Hero Member
*****
Offline Offline

Activity: 518



View Profile WWW
September 03, 2013, 05:08:51 AM
 #5

First off, complete newb to this.

I'm trying to mine on give-me-coins mining pool.

I installed cgminer via this guide: http://pfigue.github.io/blog/2013/03/01/installing-cgminer-on-ubuntu/

I get all the way through that and everything appears to be in order, but when i go to run it via this command:

Code:
./cgminer -scrypt -o ltc.give-me-coins.com:3333 -u [my pool username] -p [my pool password]

It returns:
Code:
./cgminer: -s: 'crypt' is not a number  

If I try taking the "-scrypt" out, it doesn't return any errors, but doesn't appear to do anything either.

I run cgminer in CMD with the following: cgminer --scrypt - w 256 --lookup-gap 2 -I 18 --thread-concurrency 7500 -g 1 --gpu-engine 900 --gpu-memclock 1100 - o <pool URL:port number> -u <Username> -p <Password>
 
Looks like your missing just one dash "-", it's suppose to be "--" before the scrypt flag. ie. --scrypt

Just tried that, returned
Code:
./cgminer: --scrypt: unrecognized option

Quote
# cgminer --scrypt -o http://foo.bar:#### -u cryptoAddress -p foobar


the abstraction layer defines your cryptography in OpenCL between CPU/GPU (an interface). aces.snu.ac.kr/~jlee/Jaejin_Lees_Home/Pact11_tutorial.html

That is complete greek to me. If i created a user on give-me-coins.com with username Phil_McKrackin with password ZOMG!Password! should the command look like
Code:
./cgminer --scrypt -o ltc.give-me-coins.com:3333 -u Phil_McKrackin -p ZOMG!Password!

Strange, should work. You can re-download cgminer again and maker sure it's the Scrypt base verson. If that give you trouble, try guiminer scrypt version: http://guiminer.org/guiminer-scrypt.html . Simple and easy to use. Gives you the option to either use cgminer or reaper with a gui interface instead.

CRYPTSY exchange: https://www.cryptsy.com/users/register?refid=9017 BURST= BURST-TE3W-CFGH-7343-6VM6R BTC=1CNsqGUR9YJNrhydQZnUPbaDv6h4uaYCHv ETH=0x144bc9fe471d3c71d8e09d58060d78661b1d4f32 SHF=0x13a0a2cb0d55eca975cf2d97015f7d580ce52d85 EXP=0xd71921dca837e415a58ca0d6dd2223cc84e0ea2f SC=6bdf9d12a983fed6723abad91a39be4f95d227f9bdb0490de3b8e5d45357f63d564638b1bd71 CLAMS=xGVTdM9EJpNBCYAjHFVxuZGcqvoL22nP6f SOIL=0x8b5c989bc931c0769a50ecaf9ffe490c67cb5911
Zanatos666
Sr. Member
****
Offline Offline

Activity: 280


Sometimes man, just sometimes.....


View Profile
September 03, 2013, 02:26:48 PM
 #6

If you installed cgminer using the referenced guide, and you are trying to mine scrypt, it wont work.  

cgminer does not enable scrypt mining by default, when you ./configure it, you have to add the argument of --enable-scrypt.  By default, cgminer only enables gpu mining in linux, so if you are mining scrypt or asics, you have to enable those options when compiling, which is why its telling you that it doesnt recognize --scrypt as being valid.

So, redo install cgminer and use these options (also, that guide enables cpumining, which cgminer doesnt even support anymore).

Code:
$ sudo su
# cd /opt/
# git clone git://github.com/ckolivas/cgminer.git
# cd cgminer/
# ./autogen.sh
# CFLAGS="-O2 -Wall -march=native" ./configure --enable-scrypt --enable-bflsc --enable-icarus --enable-avalon
# make -j8

This will enable scrypt mining, as well as support for BFL ASICS, Avalon devices, and block erupters in case you want to add them later.

Squiggly letters, written really fast, with a couple of dots for good measure.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!