Bitcoin Forum
April 26, 2018, 06:01:20 AM *
News: Latest stable version of Bitcoin Core: 0.16.0  [Torrent]. (New!)
   Home   Help Search Donate Login Register  
Pages: [1]
Author Topic: HELP WITH MY 10 BRAND NEW ASIC USB'S!!! CGMINER 3.1.1  (Read 3049 times)
Offline Offline

Activity: 12
Merit: 0

View Profile
September 04, 2013, 12:33:40 AM

So today I just got my 10 USB's. Ive been stuck using BITMINTER b.c thats all I can get to work right now =(

. I am trying to figure out how to start CG Miner with my 10 USBs in a ANKER 10 USB Hub on a Windows 7 Acer Aspire...

I have got the CGMINER program to open when I click on it in its folder but it will come up with.....

 No Devices Detected....and that I need to add atleast 1 pool.

So I know b.c I have 10USB I need to add the extra COM PORTS in so I try to open it the right way by trying this in the run window.

C:\Users\Buddys Adamo\Downloads\cgminer-3.1.1-windows\cgminer-3.1.1-windows\cgminer-nogpu.exe -o []:[8332] -u [username taken out].[worker name taken out] -p [password taken out] --icarus-options 115200:1:1 --icarus-timing 3.0=100 -S \\.\COM3 -S \\.\COM4 -S \\.\COM5 -S \\.\COM6 -S \\.\COM7 -S \\.\COM8 -S \\.\COM9 -S \\.\COM10 -S \\.\COM11 -S \\.\COM12

I TRIED running that in the RUN window 3 times until I saw that its to long of a RUN command to even fit. I read all over the forums here that you need to download the drivers and such...I have downloaded them. I have downloaded the  3.1/  31-May-2013 14:32 (version of CGMINER is 3.1)off the <<----WEBPAGE.

I also downloaded the drivers..ahhh screw it ...these are the directions i followed ....

STEP 1: Download and install CGMiner.

A windows binary can be found here:

STEP 2: Download and install this driver.

The driver can be found here:

This driver will allow you to “see” your Block Erupters in the Printers and Devices section of the PC’s Control Panel.

STEP 3: Plug in the USB miners.

If you have more than one Erupter, consider that they consume about 560 milliamps. You will most likely need a powered USB hub. I have 4 Erupters and they work very nicely as pictured in a Plugable 7 Port USB 3.0 Hub with 4A Power Adapter (VIA VL812 Chipset – USB 2.0 compatible) from

STEP 4: Note down the COM Numbers for each Device.

- In Windows 7, go to Control Panel
- Click on Printers and Devices
- You should see USB devices similar to what is shown below:

Silicon Labs CP210x USB to UART Bridge (COM3)
Silicon Labs CP210x USB to UART Bridge (COM4)
Silicon Labs CP210x USB to UART Bridge (COM5)
Silicon Labs CP210x USB to UART Bridge (COM6)

STEP 5: Create a Desktop Shortcut.

To launch cgminer, create a shortcut with a target command line that looks like this:

C:\cgminer\cgminer-nogpu.exe -o [pool]:[port] -u [username].[worker] -p [password] --icarus-options 115200:1:1 --icarus-timing 3.0=100 -S //./COM3 -S //./COM4 -S //./COM5 -S //./COM6

Notice that pool, port, username, worker and password are private credentials you provide for your pool worker.

Notice that COM3, COM4, COM5, COM6 are the COM numbers for my four miners. Yours will be different depending on what is reported in your Device Manager. You would need as many of these in your target line as you have miners.

STEP 6: Launch CGMiner.


I tried to run the program making the shortcut and putting this in 1st...

C:\cgminer\cgminer-nogpu.exe -o [pool]:[port] -u [username].[worker] -p [password] --icarus-options 115200:1:1 --icarus-timing 3.0=100 -S //./COM3 -S //./COM4 -S //./COM5 -S //./COM6

BUT ALL I C:\ cgminer refers to a location that is unavailable ... Says it could be on this hard drive or a network. Please Make sure you inserted it correctly...if problem persists then your file could have been moved to a different location...SO THENNN...I TRY THIS..

go to run tab and type in this run command.

C:\Users\Buddys Adamo\Downloads\cgminer-3.1.1-windows\cgminer-3.1.1-windows\cgminer-nogpu.exe


but it pretty much says it needs atleast one pool and such...I know the reason its saying that b.c the other articles of text

-o []:[8332] -u [username taken out].[worker name taken out] -p [password taken out] --icarus-options 115200:1:1 --icarus-timing 3.0=100 -S \\.\COM3 -S \\.\COM4 -S \\.\COM5 -S \\.\COM6 -S \\.\COM7 -S \\.\COM8 -S \\.\COM9 -S \\.\COM10 -S \\.\COM11 -S \\.\COM12

are not inserted...I tried to insert them on the end of the

C:\Users\Buddys Adamo\Downloads\cgminer-3.1.1-windows\cgminer-3.1.1-windows\cgminer-nogpu.exe

but its too long and auto cuts off right at the ( \\.\COM3)...

This is so aggravating ! Someone please just tell me what to type/do to get CGMINER to open correctly with the correct info I know it needs to work...Im just having some trouble that I cant find solutions to anywhere....I have 10 USBS with correct ports shown above...all drivers installed I have the 3.1.1 that works with the 3.0 USB hubs...I got everything where I think it should be...obv missing something somewhere.....the usb asics work on bitminter...but I need CGMINER b.c my BFL is here in like 2 days...please help...

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Sr. Member
Offline Offline

Activity: 280
Merit: 250

Sometimes man, just sometimes.....

View Profile
September 04, 2013, 12:44:03 PM

Okay, I have 3 suggestions.

1) You have too many plugged into one hub.  That doesnt solve the "no devices found" problem, but generally I have always found it better to run 1 less BE in a hub than what the maximum is.

2) Download and run bfgminer.  Once you have downloaded the drivers for your BE you wont need to do anything with drivers (will get to that later with cgminer setup).  Then you would run bfgminer with bfgminer.exe -o [url of pool] -u [username of pool] -p [password of pool] -S All --icarus-options 115200:1:1 --icarus-timing 3.0=100 -G     The -G is to disable it from using your GPU's, unless you also want to use your GPU(s), then in that case delete that part.

3) If you want to use cgminer, then you need to do a little tricking with the drivers, as well as use an updated version of cgminer.  People still like using 3.1.1 because it was the last version to use the old FTDI windows drivers, instead of winusb and people dont want to mess around with switching the drivers.  However, the newer versions just acts better, and there are far less configuring you have to do once you switch over the drivers.  So....

  • Download the latest version of cgminer (as of this writing I believe its 3.4.1)
  • Also download zadig (also available from ckoivas git)
  • Unplug all of your erupters except for one
  • Start zadig, go to options, and tell it to show all devices
  • Find your BE and select it, then below it will show the current driver, and a list next to it of available drivers.  Select the winusb driver and then change it
  • Now when you plug in the rest of your BE's they should all associate themselves with the winusb driver
  • Fire up cgminer like normal and input your pool, username, password.  Thats it.  No other options needed unless you want to disable your GPU (again using -G, or running cgminer-nogpu.exe)

Squiggly letters, written really fast, with a couple of dots for good measure.
Offline Offline

Activity: 1666
Merit: 1000

View Profile
September 04, 2013, 01:29:47 PM

Start with one miner.

If this works then use 2 miners.

If this works then use 10 miners.

Use a power meter in the power connector, and control the electric current to what is allowed by the hub.

Do not use more than 80% of the maximum allowed power of the hub on the long run.

Offline Offline

Activity: 12
Merit: 0

View Profile
September 04, 2013, 03:02:33 PM

for a quick test, why not try the bitminter client, its an all in one java app, will auto detect any usb devices..

Good for a test of usb to com port, at least then you will know its not a config problem with your CGMiner settings.

Hope this helps..

Offline Offline

Activity: 12
Merit: 0

View Profile
September 04, 2013, 03:55:25 PM

Thanks all for the help...I just got my 8.2 G BFL Jap today!!!

So I am currently still runing BitMinter and I have all 10 sticks on the hub running 335.9 on each.

I also have the 8.2 BFL Jap in the Serial port USB on the side of the computer...all is running well!

I will have to try and figure this out with the given instruction!

With BFG does it pool better b.c BitMinter is Java, am I loosing out potential coin that could be the script program going to make everything run better numbers...or am I going to pull better numbers from a 50BTC pool instead running BFG or CG?

Sorry im so noob but Im learning pretty quick...
Pages: [1]
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!