Bitcoin Forum
October 18, 2017, 06:42:23 PM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Help bulding CGminer for Scrypt on windowsXP using XFX 5780 HD  (Read 539 times)
gristlelump
Member
**
Offline Offline

Activity: 105


View Profile
September 04, 2013, 08:05:44 PM
 #1

Let me start off by saying hello.  I'm new to crypto-currencies.  I have successfully set up my wallets for BTC, LTC and FTC.  I have also successfully set up my Nvidia card (with CUDAminer) and several CPUs (at work with Poolers miner and stratum proxy) to mine FTC and LTC through Give-me-coins.com.  Now that I have conquered those hurdles I would like to start mining at a greater hash rate so I picked up a used XFX 5780 for $100.  I installed it to the 2nd PCI-E slot on my mother baord with my Galaxy 520GT in the first slot.  After a few hiccups I got CPUZ to recognize it as well as MISafterburner to control it.  Using GUIminer on Opencl I even got it to mine BTC from my pool mining at about 400 hash but CGminer on the same interface doesn't work.  Open cl mining recognizes the ATi card as Cypress core.  I attempted to build CGminer for my hardware but it is eluding me.  There seems to be a lot of conflicting info on proper drivers.  I have seen threads saying that my card is best suited to certain driver combinations while others say only other will work.  I have ATI 11.6 SDK 2.4 and current ADL installed.  I have tried to follow the build instructions in the Windows32 and Scrypt readme on the download site but building it doesn't seem to work.  All the indicated files have been downloaded and placed in the proper folders per the instructions but I believe I have downloaded and placed additional files which I don't need which pertain to builds for ASIC and other hardware.  It's hard to tell as the instruction set seems lacking.  Any help would be much appreciated.  Please don't bag on my setup....I'm in the process of educating myself and testing whether or not I want to invest in larger GPU mining rigs.  this is what I have to work with and won't be downloading LINUX.

Hardware Specs.
WindowsXp 32bit SP3
Asus A8N-SLI Motherboard
Athalon 3200+ single core CPU
2MB system RAM
PCI-E slot 1  Nvidia Galaxy 520GT
PCI-E slot 2  ATI XFX 5780 HD
no dummy plug installed.  520GT plugged into DVI and 5780 HD plugged into HDMI slot.  Both cards are recognized in system manager and are spanned in dual monitor configuration with both plugged into single monitor.

1508352143
Hero Member
*
Offline Offline

Posts: 1508352143

View Profile Personal Message (Offline)

Ignore
1508352143
Reply with quote  #2

1508352143
Report to moderator
1508352143
Hero Member
*
Offline Offline

Posts: 1508352143

View Profile Personal Message (Offline)

Ignore
1508352143
Reply with quote  #2

1508352143
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1508352143
Hero Member
*
Offline Offline

Posts: 1508352143

View Profile Personal Message (Offline)

Ignore
1508352143
Reply with quote  #2

1508352143
Report to moderator
1508352143
Hero Member
*
Offline Offline

Posts: 1508352143

View Profile Personal Message (Offline)

Ignore
1508352143
Reply with quote  #2

1508352143
Report to moderator
gristlelump
Member
**
Offline Offline

Activity: 105


View Profile
September 05, 2013, 07:09:07 PM
 #2

Decided to just use the prebuilt Binaries but am now running into a second problem.  I can get CGminer to load but it is only recognizing the card in the first PCI slot.  I have a dual card system with an Invidia gt520 in the first PCI-E slot and the XFX 5870 HD.  Cgminer will only mine on the Nvidia card although it gives and error of Multiple OpenCl devices and ADL devices being misdetected.  I tried to use the -n function in a bat file but I get a brief flash of readout and then the program shuts down.  I have been able to mine BTC on OpenCL via GIUminer on the ATI card but for some reason it's giving me errors for scrypt mining with CGminer.  Any suggestions?

1.  Is there anyway to generate a Log file so I can read the error output message?

2.  Is there a command to put in the Bat file to ignore the primary card (nvidia) and only work off the secondary card (ati).  Since I can't get -n command to function it I don't even know if it is being detected?  It is being detected by cpuz and the system registry and I have been able to mine BTC with it but not Litecoin

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!