Bitcoin Forum
September 22, 2018, 04:26:16 AM *
News: ♦♦ New info! Bitcoin Core users absolutely must upgrade to previously-announced 0.16.3 [Torrent]. All Bitcoin users should temporarily trust confirmations slightly less. More info.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: How to autostart bfgminer at Raspberrypi start  (Read 5727 times)
Pablito89
Full Member
***
Offline Offline

Activity: 280
Merit: 104


pablitobitcoin.com


View Profile WWW
September 26, 2013, 01:21:15 PM
 #1

Hey guys, i usually do these commands into the terminal for get bfgminer starts on Raspbian on my Raspberry:

cd
cd bfgminer
sudo ./bfgminer url -u user -p pass -S all

How could i automatize that?


Thanks Smiley

   ⚡⚡ PRiVCY ⚡⚡   ▂▃▅▆█ PRiVCY (PRIV) is a new PoW/PoS revolutionary privacy project  ☞ Best privacy crypto-market! █▆▅▃▂
    Own Your Privacy! ───────────────── WebsiteGithub  |  Bitcointalk  |  Twitter  |  Discord  |  Explorer ─────────────────
   ✯✯✯✯✯                 ✈✈✈[Free Airdrop - Starts 9th June][Tor]✈✈✈ ║───────────║ Wallet ➢ Windows  |  macOS  |  Linux
1537590376
Hero Member
*
Offline Offline

Posts: 1537590376

View Profile Personal Message (Offline)

Ignore
1537590376
Reply with quote  #2

1537590376
Report to moderator
1537590376
Hero Member
*
Offline Offline

Posts: 1537590376

View Profile Personal Message (Offline)

Ignore
1537590376
Reply with quote  #2

1537590376
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1537590376
Hero Member
*
Offline Offline

Posts: 1537590376

View Profile Personal Message (Offline)

Ignore
1537590376
Reply with quote  #2

1537590376
Report to moderator
1537590376
Hero Member
*
Offline Offline

Posts: 1537590376

View Profile Personal Message (Offline)

Ignore
1537590376
Reply with quote  #2

1537590376
Report to moderator
Zanatos666
Sr. Member
****
Offline Offline

Activity: 280
Merit: 250


Sometimes man, just sometimes.....


View Profile
September 26, 2013, 04:43:03 PM
 #2

First I would run bfgminer as you stated above, then once its started type S to display the settings, then type W to write a config file.  This should save it for you so next time all you have to do is just start bfgminer without the -S all afterwards (I could be wrong, never done it that way, but seems like what you would do).

Now, auto starting is the next step. I know this works for Minepeon, but I dont know about Raspbian, but they are similar so why not give it a try.

Try:

sudo systemctl enable bfgminer.service
sudo systemctl start bfgminer.service

Reboot and see if that works.  I

Squiggly letters, written really fast, with a couple of dots for good measure.
Pablito89
Full Member
***
Offline Offline

Activity: 280
Merit: 104


pablitobitcoin.com


View Profile WWW
September 26, 2013, 07:26:21 PM
 #3

First I would run bfgminer as you stated above, then once its started type S to display the settings, then type W to write a config file.  This should save it for you so next time all you have to do is just start bfgminer without the -S all afterwards (I could be wrong, never done it that way, but seems like what you would do).

Now, auto starting is the next step. I know this works for Minepeon, but I dont know about Raspbian, but they are similar so why not give it a try.

Try:

sudo systemctl enable bfgminer.service
sudo systemctl start bfgminer.service

Reboot and see if that works.  I

I did the first step, but "systemctl" command is not found

   ⚡⚡ PRiVCY ⚡⚡   ▂▃▅▆█ PRiVCY (PRIV) is a new PoW/PoS revolutionary privacy project  ☞ Best privacy crypto-market! █▆▅▃▂
    Own Your Privacy! ───────────────── WebsiteGithub  |  Bitcointalk  |  Twitter  |  Discord  |  Explorer ─────────────────
   ✯✯✯✯✯                 ✈✈✈[Free Airdrop - Starts 9th June][Tor]✈✈✈ ║───────────║ Wallet ➢ Windows  |  macOS  |  Linux
Zanatos666
Sr. Member
****
Offline Offline

Activity: 280
Merit: 250


Sometimes man, just sometimes.....


View Profile
September 26, 2013, 07:36:53 PM
 #4

First I would run bfgminer as you stated above, then once its started type S to display the settings, then type W to write a config file.  This should save it for you so next time all you have to do is just start bfgminer without the -S all afterwards (I could be wrong, never done it that way, but seems like what you would do).

Now, auto starting is the next step. I know this works for Minepeon, but I dont know about Raspbian, but they are similar so why not give it a try.

Try:

sudo systemctl enable bfgminer.service
sudo systemctl start bfgminer.service

Reboot and see if that works.  I

I did the first step, but "systemctl" command is not found

Try this first

sudo apt-get update
sudo apt-get install systemd

Once you do that, try running those commands again.

Squiggly letters, written really fast, with a couple of dots for good measure.
Pablito89
Full Member
***
Offline Offline

Activity: 280
Merit: 104


pablitobitcoin.com


View Profile WWW
September 26, 2013, 07:43:28 PM
 #5

First I would run bfgminer as you stated above, then once its started type S to display the settings, then type W to write a config file.  This should save it for you so next time all you have to do is just start bfgminer without the -S all afterwards (I could be wrong, never done it that way, but seems like what you would do).

Now, auto starting is the next step. I know this works for Minepeon, but I dont know about Raspbian, but they are similar so why not give it a try.

Try:

sudo systemctl enable bfgminer.service
sudo systemctl start bfgminer.service

Reboot and see if that works.  I

I did the first step, but "systemctl" command is not found

Try this first

sudo apt-get update
sudo apt-get install systemd

Once you do that, try running those commands again.

Now on

sudo systemctl enable bfgminer.service

Operation failed: No such file or directory

   ⚡⚡ PRiVCY ⚡⚡   ▂▃▅▆█ PRiVCY (PRIV) is a new PoW/PoS revolutionary privacy project  ☞ Best privacy crypto-market! █▆▅▃▂
    Own Your Privacy! ───────────────── WebsiteGithub  |  Bitcointalk  |  Twitter  |  Discord  |  Explorer ─────────────────
   ✯✯✯✯✯                 ✈✈✈[Free Airdrop - Starts 9th June][Tor]✈✈✈ ║───────────║ Wallet ➢ Windows  |  macOS  |  Linux
Zanatos666
Sr. Member
****
Offline Offline

Activity: 280
Merit: 250


Sometimes man, just sometimes.....


View Profile
September 26, 2013, 08:10:28 PM
 #6

First I would run bfgminer as you stated above, then once its started type S to display the settings, then type W to write a config file.  This should save it for you so next time all you have to do is just start bfgminer without the -S all afterwards (I could be wrong, never done it that way, but seems like what you would do).

Now, auto starting is the next step. I know this works for Minepeon, but I dont know about Raspbian, but they are similar so why not give it a try.

Try:

sudo systemctl enable bfgminer.service
sudo systemctl start bfgminer.service

Reboot and see if that works.  I

I did the first step, but "systemctl" command is not found

Try this first

sudo apt-get update
sudo apt-get install systemd

Once you do that, try running those commands again.

Now on

sudo systemctl enable bfgminer.service

Operation failed: No such file or directory

Odd....try:

sudo unmask bfgminer.service

Then try and enable and start it agian.  If not, then its over my head.

Squiggly letters, written really fast, with a couple of dots for good measure.
Pablito89
Full Member
***
Offline Offline

Activity: 280
Merit: 104


pablitobitcoin.com


View Profile WWW
September 27, 2013, 07:35:13 AM
 #7

First I would run bfgminer as you stated above, then once its started type S to display the settings, then type W to write a config file.  This should save it for you so next time all you have to do is just start bfgminer without the -S all afterwards (I could be wrong, never done it that way, but seems like what you would do).

Now, auto starting is the next step. I know this works for Minepeon, but I dont know about Raspbian, but they are similar so why not give it a try.

Try:

sudo systemctl enable bfgminer.service
sudo systemctl start bfgminer.service

Reboot and see if that works.  I

I did the first step, but "systemctl" command is not found

Try this first

sudo apt-get update
sudo apt-get install systemd

Once you do that, try running those commands again.

Now on

sudo systemctl enable bfgminer.service

Operation failed: No such file or directory

Odd....try:

sudo unmask bfgminer.service

Then try and enable and start it agian.  If not, then its over my head.

command not found.
ty anyway bro.

   ⚡⚡ PRiVCY ⚡⚡   ▂▃▅▆█ PRiVCY (PRIV) is a new PoW/PoS revolutionary privacy project  ☞ Best privacy crypto-market! █▆▅▃▂
    Own Your Privacy! ───────────────── WebsiteGithub  |  Bitcointalk  |  Twitter  |  Discord  |  Explorer ─────────────────
   ✯✯✯✯✯                 ✈✈✈[Free Airdrop - Starts 9th June][Tor]✈✈✈ ║───────────║ Wallet ➢ Windows  |  macOS  |  Linux
wetjet43
Newbie
*
Offline Offline

Activity: 57
Merit: 0



View Profile
November 02, 2013, 02:27:17 AM
 #8

What is the right way to start bfgminer as a service? "systemctl enable bfgminer.service" doesn't work.
Thanks.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!