Bitcoin Forum
December 08, 2016, 04:17:20 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: [CentOS] Bitcoind prints out some errors! help!  (Read 872 times)
Flowz
Member
**
Offline Offline

Activity: 114


Bitcoin = Money for the people, by the people.


View Profile
July 20, 2011, 07:47:04 AM
 #1

Code:
./bitcoind: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by ./bitcoind)
./bitcoind: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./bitcoind)
./bitcoind: /lib/libc.so.6: version `GLIBC_2.7' not found (required by ./bitcoind)
./bitcoind: /lib/libc.so.6: version `GLIBC_2.11' not found (required by ./bitcoind)

I did a rpm search and this popped up:
Code:
[root@vps 32]# rpm -q glibc
glibc-2.5-58.el5_6.4

I need to upgrade these packages, anyone knows a way of doing this?
Please note, I already tried installing glibc-2.11 through a RPM file but it failed. output below (I KNOW THAT it's a fedora release):
Code:

[root@vps ~]# wget ftp://194.199.20.114/linux/fedora/releases/12/Everything/i386/os/Packages/glibc-2.11-2.i686.rpm
--2011-07-20 19:45:17--  ftp://194.199.20.114/linux/fedora/releases/12/Everything/i386/os/Packages/glibc-2.11-2.i686.rpm
           => `glibc-2.11-2.i686.rpm'
Connecting to 194.199.20.114:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /linux/fedora/releases/12/Everything/i386/os/Packages ... done.
==> SIZE glibc-2.11-2.i686.rpm ... 4550836
==> PASV ... done.    ==> RETR glibc-2.11-2.i686.rpm ... done.
Length: 4550836 (4.3M)

100%[====================================================================================>] 4,550,836   2.61M/s   in 1.7s

2011-07-20 19:45:19 (2.61 MB/s) - `glibc-2.11-2.i686.rpm' saved [4550836]

[root@vps ~]# rpm -ivh glibc-2.11-2.i686.rpm
warning: glibc-2.11-2.i686.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 57bbccba
error: Failed dependencies:
        glibc-common = 2.11-2 is needed by glibc-2.11-2.i686
        libfreebl3.so(NSSRAWHASH_3.12.3) is needed by glibc-2.11-2.i686
        rpmlib(FileDigests) <= 4.6.0-1 is needed by glibc-2.11-2.i686
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by glibc-2.11-2.i686
        binutils < 2.19.51.0.10 conflicts with glibc-2.11-2.i686
        glibc > 2.5 conflicts with glibc-common-2.5-58.el5_6.4.i386
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!