Bitcoin Forum
June 28, 2017, 02:39:51 PM *
News: Latest stable version of Bitcoin Core: 0.14.2  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Help: Trying to solo mine namecoins  (Read 2354 times)
evlew
Sr. Member
****
Offline Offline

Activity: 407



View Profile
July 22, 2011, 03:46:11 AM
 #1

I have a windows computer running namecoind with the required configurations

I'm trying to connect to it from my linuxcoin rigs with phoenix and am having trouble. 

I think it has something to do with the URL any suggestions?

This is what i'm trying
python phoenix.py -u http://rpcuser:rpcpass@ipaddress:port -k phatk DEVICE=0 etc etc
1498660791
Hero Member
*
Offline Offline

Posts: 1498660791

View Profile Personal Message (Offline)

Ignore
1498660791
Reply with quote  #2

1498660791
Report to moderator
1498660791
Hero Member
*
Offline Offline

Posts: 1498660791

View Profile Personal Message (Offline)

Ignore
1498660791
Reply with quote  #2

1498660791
Report to moderator
POLONIEX TRADING SIGNALS
+50% Profit and more via TELEGRAM
ALTCOINTRADER.CO
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1498660791
Hero Member
*
Offline Offline

Posts: 1498660791

View Profile Personal Message (Offline)

Ignore
1498660791
Reply with quote  #2

1498660791
Report to moderator
Vince
Jr. Member
*
Offline Offline

Activity: 38


View Profile
July 22, 2011, 08:16:22 AM
 #2

let me make a guess:

you forgot to put

server=1

in your bitcoin.conf?

edit:

you are connecting from another machine, so you also need to set:

rpcallowip and rpcconnect

Like what I'm posting? -> 1DtHZgVufX1tc5jRCoNiUnygenwRWj939C
Chris Acheson
Sr. Member
****
Offline Offline

Activity: 266


View Profile
July 22, 2011, 05:47:35 PM
 #3

let me make a guess:

you forgot to put

server=1

in your bitcoin.conf?

bitcoind and namecoind listen for RPC commands even without the server flag.  That's all they do, so it doesn't make sense to disable server functionality on them.

Quote
you are connecting from another machine, so you also need to set:

rpcallowip and rpcconnect

rpcallowip is probably what needs to be set here.  rpcconnect is for using the client as a front-end to a remote bitcoind or namecoind.

I have a windows computer running namecoind with the required configurations

I'm trying to connect to it from my linuxcoin rigs with phoenix and am having trouble. 

I think it has something to do with the URL any suggestions?

This is what i'm trying
python phoenix.py -u http://rpcuser:rpcpass@ipaddress:port -k phatk DEVICE=0 etc etc

Post your bitcoin.conf and any arguments that you're passing to namecoind when you start it.
forexmasterja
Full Member
***
Offline Offline

Activity: 130



View Profile WWW
July 22, 2011, 10:09:12 PM
 #4

I think the rpcallowip is the problem i had to set this to "*" to get it to work with my local machines.

--** First Jamaican Bitcoin User **--
1JamaicaYQvsBkvm5JcurQBA9Kz969nsqe
Revolutionary Money Making Cloud Miner - https://cex.io/r/0/forexmasterja/0/
Chris Acheson
Sr. Member
****
Offline Offline

Activity: 266


View Profile
July 22, 2011, 10:18:19 PM
 #5

I think the rpcallowip is the problem i had to set this to "*" to get it to work with my local machines.

You should avoid doing this if you can.  Setting rpcallowip to * allows connections from anywhere, which means that someone who gets access to your password can empty your wallet.  You can have multiple rpcallowip entries, so ideally you should have one for each specific IP address that you want to allow connections from.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!