Bitcoin Forum
December 11, 2016, 10:20:34 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: [Job] 30 btc for a Gentoo Linux ebuild  (Read 1589 times)
BioMike
Legendary
*
Offline Offline

Activity: 1259


View Profile
February 01, 2011, 06:47:41 PM
 #1

I've posted this bug on the Gentoo bugzilla a week ago:
https://bugs.gentoo.org/show_bug.cgi?id=352539

It is to request an ebuild (or better, multiple ebuilds) for the fonts of the website:
http://www.theleagueofmoveabletype.com/

I'm offering 30 btc to the first person to provide an ebuild to install these fonts on my Gentoo system and follows the rules below:
- Fonts are functional from within most programs (Inkscape/GIMP/Openoffice/etc.)
- Ebuild should follow Gentoo QA guide lines as good as possible (I'll give feedback, if needed, you need to fix it then).
- Ebuild has to be uploaded to the Gentoo bugzilla, comment with your btc address to send the bitcoins to (when I'm satisfied with the result).
1481451634
Hero Member
*
Offline Offline

Posts: 1481451634

View Profile Personal Message (Offline)

Ignore
1481451634
Reply with quote  #2

1481451634
Report to moderator
1481451634
Hero Member
*
Offline Offline

Posts: 1481451634

View Profile Personal Message (Offline)

Ignore
1481451634
Reply with quote  #2

1481451634
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481451634
Hero Member
*
Offline Offline

Posts: 1481451634

View Profile Personal Message (Offline)

Ignore
1481451634
Reply with quote  #2

1481451634
Report to moderator
1481451634
Hero Member
*
Offline Offline

Posts: 1481451634

View Profile Personal Message (Offline)

Ignore
1481451634
Reply with quote  #2

1481451634
Report to moderator
t3h
Newbie
*
Offline Offline

Activity: 19


View Profile
February 03, 2011, 03:23:49 PM
 #2

I'm looking into it. Give me a day or so.

Edit: check the bug now.
BioMike
Legendary
*
Offline Offline

Activity: 1259


View Profile
February 03, 2011, 07:03:06 PM
 #3

I'm looking into it. Give me a day or so.

Edit: check the bug now.

I had a quick look and it looks ok (haven't checked through install, will do that later). Could you put it in a file and add it as an attachment?
Also, could you set all keywords to ~arch?

When all is ok, I'll PM you for the btc address to send the bitcoins to.

[edit]

I'll check tomorrow. Getting late here now.
[/edit]
grondilu
Legendary
*
Offline Offline

Activity: 1134


View Profile
February 03, 2011, 09:08:11 PM
 #4

That's a nice thread.

Although most work in the FOSS community is done for free, a little monetarty incentive can help Wink
BioMike
Legendary
*
Offline Offline

Activity: 1259


View Profile
February 04, 2011, 06:47:55 AM
 #5

Had a quick check with installing. There are a few issues while emerging (one that I posted on bugzilla and some error messages), also not all fonts show up when I checked in Inkscape. I remember that some fonts have different formats. Might be caused because of that.
BioMike
Legendary
*
Offline Offline

Activity: 1259


View Profile
February 05, 2011, 02:43:17 PM
 #6

@t3h,

Are you still working on this?
t3h
Newbie
*
Offline Offline

Activity: 19


View Profile
February 08, 2011, 02:16:37 PM
 #7

Yeah, still looking at it. Been a bit busy though.
BioMike
Legendary
*
Offline Offline

Activity: 1259


View Profile
February 19, 2011, 10:40:52 AM
 #8

Yeah, still looking at it. Been a bit busy though.

t3h, could you give an update on this?
Plloi
Newbie
*
Offline Offline

Activity: 3


View Profile
February 19, 2011, 04:50:39 PM
 #9

I not very familiar with Gentoo, but looking at the docs it look like virtual/x11 was dropped.

so i would try replacing:

DEPEND="virtual/x11 app-arch/unzip"

with:
DEPEND="xorg-x11 app-arch/unzip"



though as i said i'm not a gentoo user so take with a grain of salt
BioMike
Legendary
*
Offline Offline

Activity: 1259


View Profile
February 19, 2011, 06:56:08 PM
 #10

I not very familiar with Gentoo, but looking at the docs it look like virtual/x11 was dropped.

so i would try replacing:

DEPEND="virtual/x11 app-arch/unzip"

with:
DEPEND="xorg-x11 app-arch/unzip"



though as i said i'm not a gentoo user so take with a grain of salt

I know, although I'm not sure the xorg-x11 is the solution. Ebuild has multiple problems.
BioMike
Legendary
*
Offline Offline

Activity: 1259


View Profile
March 08, 2011, 09:38:00 PM
 #11

Ok, no reply from t3h any more.

Whoever wants, feel free to take this job. Rules still apply.
BioMike
Legendary
*
Offline Offline

Activity: 1259


View Profile
March 20, 2011, 03:34:32 PM
 #12

This offer is still open. Chinese students with some ebuild scripting abilities could work together with me on this.
PM me first before starting on this. I'd rather have not the Gentoo bugzilla overcrowded with Chinese students Wink.

Depending on the level that the student(s) can contribute, I might lower the bounty. (The 30BTC is only if the
student can provide a fully working, tested ebuild without any help from my side).
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!