Bitcoin Forum
December 15, 2017, 10:15:38 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: New flask-based multi-node wallet app  (Read 3945 times)
nkuttler
Newbie
*
Offline Offline

Activity: 21


View Profile WWW
October 17, 2013, 02:27:09 PM
 #1

Hi all,

I have just release flaskwallet, https://github.com/nkuttler/flaskwallet

It's intended to be a single-user multi-node wallet application and was written using the Python web framework Flask. You can use it to access multiple nodes to see stats, send coins, etc. Flaskwallet needs the usernames/passwords for your node's RPC API to work.

As flaskwallet is web-based you can also access it using various devices, like your desktop, laptop and tablet. If you want to do this you should know how to secure network communication. Think of flaskwallet as your self-hosted web wallet. Then nothing stands in the way of you managing your wallets from your couch, watching the ball game, and having a cool beer. Or whatever you're into.

There is also rudimentary support for OTP (using Google Authenticator) built-in, but it's only used when decrypting the wallet right now. One of the next steps is to use OTP for coin transactions.

Here's what the wallet list looks like:

http://dev.kuttler.eu/public/flaskwallet/wallets.png

I consider flaskwallet in alpha, but already usable. In fact I use it to manage all my wallets. You should know some Python and be familiar with UNIX-based operating systems if you want to use it. There are some know bugs, but I decided to release flaskwallet already anyway as I didn't have much time to advance the code in the last month.

User documentation is at http://flaskwallet.readthedocs.org/en/latest/

Oh right, and it's open source.

Patches and donations welcome: 1NG8BfDzequeiCDewn7v2AF4FcBKGxzKkH
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!