Bitcoin Forum
December 06, 2016, 02:20:45 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: How to control 2 Radeon cards without Crossfire  (Read 2750 times)
st4rdust
Full Member
***
Offline Offline

Activity: 188



View Profile
July 24, 2011, 04:38:29 PM
 #1

I'm looking to control two 5830s on my Vista x64 system. I'd like to get them overclocked ideally but right now I can't even mine with the second card. I've got all my drivers up to date, the system recognizes both of the cards but CCC doesn't show the second (the screen where you 'unlock' the card to overclock only shows for the first card) however, TRIXX has a dropdown menu to select between them, but won't respond to any changes to the second card at all, automatically reverting to the default settings.

I'm going to be installing Ubuntu on this system as I've heard that linux is better with recognizing two video cards than windows. Other than that, without the crossfire bridge, do I have any shot of overclocking or at the very least mining with both of these cards?

If you should choose to pity me -14GLjCUE7ohxRLvwZD2sfjKjf22Lt3UHip
1481034045
Hero Member
*
Offline Offline

Posts: 1481034045

View Profile Personal Message (Offline)

Ignore
1481034045
Reply with quote  #2

1481034045
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481034045
Hero Member
*
Offline Offline

Posts: 1481034045

View Profile Personal Message (Offline)

Ignore
1481034045
Reply with quote  #2

1481034045
Report to moderator
1481034045
Hero Member
*
Offline Offline

Posts: 1481034045

View Profile Personal Message (Offline)

Ignore
1481034045
Reply with quote  #2

1481034045
Report to moderator
Olly_K
Sr. Member
****
Offline Offline

Activity: 359


View Profile
July 24, 2011, 05:12:55 PM
 #2

if you're using windows, use MSI afterburner, and tick "apply clocks to all cards"

Use GPU-Z to confirm the clocks have been applied to both cards.

Works for my 3 5870s non-xfired
lowlevel
Full Member
***
Offline Offline

Activity: 160


View Profile
July 24, 2011, 05:23:41 PM
 #3

Your first problem, is likely that you don't have a display(or vga dummy plug) plugged into the second card.
You can use sapphire Trixx to overclock both cards independently now, as of version 4.0.2.

Your first miner process should have DEVICE=0 in the commandline, and your second one will have DEVICE=1

I found I had to actually remove the 'Synchronize cards in Multi-GPU config' setting before it would allow me to overclock the second card...
but I re-applied the checkbox there before minimizing trixx.

(and you shouldn't need a crossfire bridge)

Would you rather talk Altcoins? - https://cryptocointalk.com/
Xephan
Jr. Member
*
Offline Offline

Activity: 42


View Profile
July 24, 2011, 05:55:12 PM
 #4

I'm looking to control two 5830s on my Vista x64 system. I'd like to get them overclocked ideally but right now I can't even mine with the second card. I've got all my drivers up to date, the system recognizes both of the cards but CCC doesn't show the second (the screen where you 'unlock' the card to overclock only shows for the first card) however, TRIXX has a dropdown menu to select between them, but won't respond to any changes to the second card at all, automatically reverting to the default settings.

I'm going to be installing Ubuntu on this system as I've heard that linux is better with recognizing two video cards than windows. Other than that, without the crossfire bridge, do I have any shot of overclocking or at the very least mining with both of these cards?

Two ways to fix this. First is making a dummy plug, or if your monitor has a second input, connect that to your second card.
Also check which version of your Catalyst driver you have. There is a hotfix 11.6B (or 11.7 Preview) that solves this problem but causes at least one CPU core to load up 100%.

No crossfire needed for mining and if you're totally inexperienced with Linux, you might be better off using one of the two options above, or it might be more frustrating that you expect.

186q9YUW3x8TVHC5aYBEqgZZYMxft8Cw9f
st4rdust
Full Member
***
Offline Offline

Activity: 188



View Profile
July 24, 2011, 06:46:23 PM
 #5

Okay I've got TRIXX working for both video cards now. However, I still can't seem to actually mine with the second GPU, even though the system recognizes it and TRIXX allows me to tweak it. GUIMiner has the same selection from its Device drop down list as before I added the second card, just the original GPU Is this because I have no dummy plug or monitor plugged into the second card? Do I absolutely need to plug one of those in before it will let me do any mining with the card?

Also, I have previous experience with Linux, although not very recently. I'd be able to get Ubuntu going (though I'm leaning toward Kubuntu - KDE seems awesome!) which will be ideal for me, as I'm looking for something beyond the basic command line setup.

If you should choose to pity me -14GLjCUE7ohxRLvwZD2sfjKjf22Lt3UHip
Xephan
Jr. Member
*
Offline Offline

Activity: 42


View Profile
July 24, 2011, 08:45:56 PM
 #6

Okay I've got TRIXX working for both video cards now. However, I still can't seem to actually mine with the second GPU, even though the system recognizes it and TRIXX allows me to tweak it. GUIMiner has the same selection from its Device drop down list as before I added the second card, just the original GPU Is this because I have no dummy plug or monitor plugged into the second card? Do I absolutely need to plug one of those in before it will let me do any mining with the card?

Sounds like you're still on the older 11.6 drivers then. Yes either a dummy plug or an actual connection to a monitor is needed in this case.


Quote
Also, I have previous experience with Linux, although not very recently. I'd be able to get Ubuntu going (though I'm leaning toward Kubuntu - KDE seems awesome!) which will be ideal for me, as I'm looking for something beyond the basic command line setup.

To get the most out of your cards on a Linux system, you should run without X. The linux ATI/AMD drivers tend not to be as fast as the Windows one so every little bit counts.

Most of the things you would want to do on a mining rig would be through the command line anyway.

186q9YUW3x8TVHC5aYBEqgZZYMxft8Cw9f
hdfxst
Jr. Member
*
Offline Offline

Activity: 40


View Profile
July 24, 2011, 10:49:00 PM
 #7

with trixx you have to enable the monitor for that card
secularflesh
Newbie
*
Offline Offline

Activity: 18


View Profile
July 24, 2011, 11:05:17 PM
 #8

You have three options:

1. Dummy plug
2. Catalyst 11.6b
3. Linux

Pick your poison.
kam1lly
Jr. Member
*
Offline Offline

Activity: 47


View Profile
July 25, 2011, 12:22:22 AM
 #9

I crossfired 2 6990s, took a little fooling around with inserting/reinsterting the cards, but eventually I got both of them in tip top mining condition, was running them at 1.8 ghash/s
hdfxst
Jr. Member
*
Offline Offline

Activity: 40


View Profile
July 25, 2011, 02:08:50 AM
 #10

 I was wrong it's not trixx but ccc,you have to extend the desktop.and then use trixx to overclock the cards separately
Morebitcoinsplease
Member
**
Offline Offline

Activity: 84



View Profile
July 25, 2011, 11:40:59 AM
 #11

You have three options:

1. Dummy plug
2. Catalyst 11.6b
3. Linux

Pick your poison.

+1
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!