Bitcoin Forum
December 17, 2017, 02:31:04 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: litecoin pool mining w/ cgminer problems  (Read 3762 times)
Sweetrevenge
Jr. Member
*
Offline Offline

Activity: 54


View Profile
October 31, 2013, 10:14:45 AM
 #1

Hello all, I downloaded cgminer 3.6.0 and 3.5.1 and am trying to run a .bat file to mine from lite.coin-pool.com, but I keep getting this error message

"C:\cgminer-3.5.1>cgminer.exe --scrypt -o stratum+tcp://www.lite.coin-pool.com:8339 -u sweetrevenge.1 -p x --no-submit-stale -- intensity 10 --thread-concurrency 8000 --worksize 256 -1
'cgminer.exe' is not recognized as an internal or external command, operable program or batch file."

Anyone have any insights?
1513521064
Hero Member
*
Offline Offline

Posts: 1513521064

View Profile Personal Message (Offline)

Ignore
1513521064
Reply with quote  #2

1513521064
Report to moderator
No Gods or Kings. Only Bitcoin
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1513521064
Hero Member
*
Offline Offline

Posts: 1513521064

View Profile Personal Message (Offline)

Ignore
1513521064
Reply with quote  #2

1513521064
Report to moderator
Vivisector999
Hero Member
*****
Offline Offline

Activity: 532



View Profile
October 31, 2013, 02:47:16 PM
 #2

Get rid of the "C:\cgminer-3.5.1> from the batch file, and run the batch file from the same directory as your cgminer.  Hopefully that works for you.

Check out Academy Coin @ https://academycoin.io
Sweetrevenge
Jr. Member
*
Offline Offline

Activity: 54


View Profile
October 31, 2013, 11:09:02 PM
 #3

no dice. Heres the code, I'm currently using:

cgminer --scrypt -o stratum+tcp://www.lite.coin-pool.com:8339 -u sweetrevenge.1 -p x --no-submit-stale --intensity 10 --thread-concurrency 8000 --worksize 256 -g 1

I have no idea what the problem could be
Sweetrevenge
Jr. Member
*
Offline Offline

Activity: 54


View Profile
November 01, 2013, 11:10:26 PM
 #4

bump, gonna try reformatting windows 7 and see if I can get this to work.
elvizzzzzzz
Full Member
***
Offline Offline

Activity: 135


View Profile
November 20, 2013, 03:49:51 PM
 #5

Setup: Debian|experimental fglrx etc ver 13.11-beta6 AMD64
wget https://litecoin.org/downloads/linux/litecoin-0.8.5.1-linux.tar.xz
wget -c www2.ati.com/drivers/beta/amd-catalyst-13.11-beta6-linux-x86.x86_64.zip
(this doesn't work for me because AMD's javascript wants a popup YMMV)
wget http://ck.kolivas.org/apps/cgminer/3.1/cgminer-3.1.1.tar.bz2

Installed all ok, cgminer reports scrypt is enabled, ASIC stuff is disabled.

Everthing seems to work, including mining bitcoin on the GPU, until I try to mine Litecoin.
I finally got my cgminer.conf into sort of working after I figured out that it is VERY sensitive
to whitespace around the trailing "}], in the "pools" setting.

sometimes cgminer just throws a segmentation fault, but this is the latest output:
  [2013-11-20 15:19:51] Probing for an alive pool
 [2013-11-20 15:19:51] Network diff set to 1.31K
 [2013-11-20 15:19:51] No suitable long-poll found for http://localhost:9432
 [2013-11-20 15:19:52] Error -11: Building Program (clBuildProgram)
 [2013-11-20 15:19:52] "/tmp/OCLWKsBkw.cl", line 762: error: identifier "LOOKUP_GAP" is undefined
        const uint ySIZE = (1024/LOOKUP_GAP+(1024%LOOKUP_GAP>0));
                                 ^

"/tmp/OCLWKsBkw.cl", line 763: error: identifier "CONCURRENT_THREADS" is
          undefined
        const uint xSIZE = CONCURRENT_THREADS;
                           ^

2 errors detected in the compilation of "/tmp/OCLWKsBkw.cl".

Internal error: clc compiler invocation failed.

 [2013-11-20 15:19:52] Failed to init GPU thread 0, disabling device 0
 [2013-11-20 15:19:52] Restarting the GPU from the menu will not fix this.
 [2013-11-20 15:19:52] Try restarting cgminer.
Press enter to continue:

I will have another hack at this - any advice is welcomed.
elvizzzzzzz
Full Member
***
Offline Offline

Activity: 135


View Profile
November 20, 2013, 04:23:43 PM
 #6

Hmmm ... seems to be running @460MH/s on my 7970 now
all I did was to take commandline stuff out and put it in the cgminer.conf file
and reduced the lookup-gap to 1
Copy of cgminer.conf :
{"pools" : [ {"url" : "localhost:9432", "user" : "User", "pass" : "Pass"}],
"lookup-gap" : "1",
"thread-concurrency" : "8192",
"kernel-path" : "/usr/local/bin"
}

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!