Bitcoin Forum
December 18, 2017, 04:23:09 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 [21] 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 ... 75 »
  Print  
Author Topic: [ANN] [SKC] Skeincoin 0.9.3.1 | Skein-SHA2  (Read 158147 times)
Pernicio
Newbie
*
Offline Offline

Activity: 9

https://hashflare.io/r/E10633A3


View Profile WWW
December 29, 2013, 02:48:38 AM
 #401

Code:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 134, in main
    status = self.run(options, args)
  File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 241, in run
    requirement_set.install(install_options, global_options, root=options.root_path)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 1298, in install
    requirement.install(install_options, global_options, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 625, in install
    cwd=self.source_dir, filter_stdout=self._filter_install, show_stdout=False)
  File "/usr/lib/python2.7/dist-packages/pip/util.py", line 670, in call_subprocess
    % (command_desc, proc.returncode, cwd))
InstallationError: Command /usr/bin/python -c "import setuptools;__file__='/tmp/pip_build_root/pyopencl/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-KB0TXJ-record/install-record.txt --single-version-externally-managed failed with error code 1 in /tmp/pip_build_root/pyopencl

Also, I have done all the steps on a clean installation of 32-Bit Xubuntu 13.10 - some repeating just in case Wink

<a href="https://hashflare.io/r/E10633A3">
1513570989
Hero Member
*
Offline Offline

Posts: 1513570989

View Profile Personal Message (Offline)

Ignore
1513570989
Reply with quote  #2

1513570989
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1513570989
Hero Member
*
Offline Offline

Posts: 1513570989

View Profile Personal Message (Offline)

Ignore
1513570989
Reply with quote  #2

1513570989
Report to moderator
1513570989
Hero Member
*
Offline Offline

Posts: 1513570989

View Profile Personal Message (Offline)

Ignore
1513570989
Reply with quote  #2

1513570989
Report to moderator
1513570989
Hero Member
*
Offline Offline

Posts: 1513570989

View Profile Personal Message (Offline)

Ignore
1513570989
Reply with quote  #2

1513570989
Report to moderator
madjihad
Sr. Member
****
Offline Offline

Activity: 245


🌟 æternity🌟 blockchain🌟


View Profile
December 29, 2013, 09:48:51 AM
 #402

Code:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 134, in main
    status = self.run(options, args)
  File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 241, in run
    requirement_set.install(install_options, global_options, root=options.root_path)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 1298, in install
    requirement.install(install_options, global_options, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 625, in install
    cwd=self.source_dir, filter_stdout=self._filter_install, show_stdout=False)
  File "/usr/lib/python2.7/dist-packages/pip/util.py", line 670, in call_subprocess
    % (command_desc, proc.returncode, cwd))
InstallationError: Command /usr/bin/python -c "import setuptools;__file__='/tmp/pip_build_root/pyopencl/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-KB0TXJ-record/install-record.txt --single-version-externally-managed failed with error code 1 in /tmp/pip_build_root/pyopencl

Also, I have done all the steps on a clean installation of 32-Bit Xubuntu 13.10 - some repeating just in case Wink

Looks like you are missing setuptools.

Code:
sudo pip install setuptools

We definitely need the list of all requirements. I will try to setup miner on a clean install and make such list today.

Pernicio
Newbie
*
Offline Offline

Activity: 9

https://hashflare.io/r/E10633A3


View Profile WWW
December 29, 2013, 12:10:19 PM
 #403

Code:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 134, in main
    status = self.run(options, args)
  File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 241, in run
    requirement_set.install(install_options, global_options, root=options.root_path)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 1298, in install
    requirement.install(install_options, global_options, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 625, in install
    cwd=self.source_dir, filter_stdout=self._filter_install, show_stdout=False)
  File "/usr/lib/python2.7/dist-packages/pip/util.py", line 670, in call_subprocess
    % (command_desc, proc.returncode, cwd))
InstallationError: Command /usr/bin/python -c "import setuptools;__file__='/tmp/pip_build_root/pyopencl/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-KB0TXJ-record/install-record.txt --single-version-externally-managed failed with error code 1 in /tmp/pip_build_root/pyopencl

Also, I have done all the steps on a clean installation of 32-Bit Xubuntu 13.10 - some repeating just in case Wink

Looks like you are missing setuptools.

Code:
sudo pip install setuptools

We definitely need the list of all requirements. I will try to setup miner on a clean install and make such list today.


Indeed, thank you for your effort Smiley a Full requirements/dependencies list would definitely help.

I also checked if I had setuptools installed and I had 'python-setuptools' installed, but not 'python3-setuptools' - so I installed that also. After that I tried again, but seems to have not helped;
https://www.dropbox.com/s/wl1454i16njxadz/pip3.log
Code:
Exception information:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 134, in main
    status = self.run(options, args)
  File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 241, in run
    requirement_set.install(install_options, global_options, root=options.root_path)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 1298, in install
    requirement.install(install_options, global_options, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 625, in install
    cwd=self.source_dir, filter_stdout=self._filter_install, show_stdout=False)
  File "/usr/lib/python2.7/dist-packages/pip/util.py", line 670, in call_subprocess
    % (command_desc, proc.returncode, cwd))
InstallationError: Command /usr/bin/python -c "import setuptools;__file__='/tmp/pip_build_root/pyopencl/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-24DnT6-record/install-record.txt --single-version-externally-managed failed with error code 1 in /tmp/pip_build_root/pyopencl

As you can see, it's identical with the pip2.log. Could it be then, that there is even more programs that don't realize that their requirements have already being met? Shocked As in, program not registering correctly for some reason, even when there is no visible errors during the installation? Ghost in the shell? Grin

<a href="https://hashflare.io/r/E10633A3">
madjihad
Sr. Member
****
Offline Offline

Activity: 245


🌟 æternity🌟 blockchain🌟


View Profile
December 29, 2013, 12:32:33 PM
 #404

Indeed, thank you for your effort Smiley a Full requirements/dependencies list would definitely help.

I also checked if I had setuptools installed and I had 'python-setuptools' installed, but not 'python3-setuptools' - so I installed that also. After that I tried again, but seems to have not helped;
https://www.dropbox.com/s/wl1454i16njxadz/pip3.log
Code:
Exception information:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 134, in main
    status = self.run(options, args)
  File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 241, in run
    requirement_set.install(install_options, global_options, root=options.root_path)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 1298, in install
    requirement.install(install_options, global_options, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 625, in install
    cwd=self.source_dir, filter_stdout=self._filter_install, show_stdout=False)
  File "/usr/lib/python2.7/dist-packages/pip/util.py", line 670, in call_subprocess
    % (command_desc, proc.returncode, cwd))
InstallationError: Command /usr/bin/python -c "import setuptools;__file__='/tmp/pip_build_root/pyopencl/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-24DnT6-record/install-record.txt --single-version-externally-managed failed with error code 1 in /tmp/pip_build_root/pyopencl

As you can see, it's identical with the pip2.log. Could it be then, that there is even more programs that don't realize that their requirements have already being met? Shocked As in, program not registering correctly for some reason, even when there is no visible errors during the installation? Ghost in the shell? Grin

That happens sometimes, if you have some stuff installed via pip and some via apt-get and have both vanilla (non-debug) and debug versions of python. That's because of different versions of python requires related versions of packages. 

Pernicio
Newbie
*
Offline Offline

Activity: 9

https://hashflare.io/r/E10633A3


View Profile WWW
December 29, 2013, 01:08:55 PM
 #405

Quote
Quote

As you can see, it's identical with the pip2.log. Could it be then, that there is even more programs that don't realize that their requirements have already being met? Shocked As in, program not registering correctly for some reason, even when there is no visible errors during the installation? Ghost in the shell? Grin

That happens sometimes, if you have some stuff installed via pip and some via apt-get and have both vanilla (non-debug) and debug versions of python. That's because of different versions of python requires related versions of packages. 

Hmm, tried to check if I had any debug version of those, but didn't have those - just the normal ones. Could pytools conflict with setuptools? As installing pyopencl installs both pytools and numpy by default, it seems Shocked At least when done through the software center.

<a href="https://hashflare.io/r/E10633A3">
Calhil
Full Member
***
Offline Offline

Activity: 182


View Profile
December 29, 2013, 01:10:31 PM
 #406

sudo apt-get build-dep python-pyopencl
This should install all the dependencies you need.

BLC & SKC node: addnode=192.3.171.213
BLC: BcaLHiLk74XXSZdebHQY8b3CaoEBLaPtoV
madjihad
Sr. Member
****
Offline Offline

Activity: 245


🌟 æternity🌟 blockchain🌟


View Profile
December 29, 2013, 01:22:35 PM
 #407

Quote
Quote

As you can see, it's identical with the pip2.log. Could it be then, that there is even more programs that don't realize that their requirements have already being met? Shocked As in, program not registering correctly for some reason, even when there is no visible errors during the installation? Ghost in the shell? Grin

That happens sometimes, if you have some stuff installed via pip and some via apt-get and have both vanilla (non-debug) and debug versions of python. That's because of different versions of python requires related versions of packages. 

Hmm, tried to check if I had any debug version of those, but didn't have those - just the normal ones. Could pytools conflict with setuptools? As installing pyopencl installs both pytools and numpy by default, it seems Shocked At least when done through the software center.

Unlikelly, that's quite different packages, and currently I have both of them.

Now I see that the issue is here:
Code:
src/wrapper/wrap_cl.hpp:27:19: fatal error: CL/cl.h: No such file or directory

Might be wrong path to AMD_APP_SDK, check all related stuff.
https://bitcointalk.org/index.php?topic=57267.0
http://wiki.tiker.net/OpenCLHowTo

melnikalex
Member
**
Offline Offline

Activity: 60


View Profile
December 29, 2013, 04:57:05 PM
 #408

I have downloaded the driver from here : http://www2.ati.com/drivers/beta/amd-catalyst-13.11-beta-v9.4-linux-x86.x86_64.run.zip

install it with sudo sh ./amdwhatever.run


use ubuntu 13.04 : from here http://releases.ubuntu.com/13.04/

- i recommand you to use WUBI.exe... it will install ubuntu along with your windows without altering or modifiing partitions on you hdd, jut simply point the installer on what drive and what size you wanna allow for utunbu
http://releases.ubuntu.com/13.04/wubi.exe
...
Thanks, it works.
For wubi I set C:\ and it works too (D:\ did not work).
I even make some undervolt and overclock with atitweak.
Then I lost attention and it killed my PSU with overheated GPU :/.

Does this miner can stop hashing on GPU when overheated?
Does it work with solo mining?
reorder
Sr. Member
****
Offline Offline

Activity: 462


View Profile
December 29, 2013, 05:19:29 PM
 #409

I have downloaded the driver from here : http://www2.ati.com/drivers/beta/amd-catalyst-13.11-beta-v9.4-linux-x86.x86_64.run.zip

install it with sudo sh ./amdwhatever.run


use ubuntu 13.04 : from here http://releases.ubuntu.com/13.04/

- i recommand you to use WUBI.exe... it will install ubuntu along with your windows without altering or modifiing partitions on you hdd, jut simply point the installer on what drive and what size you wanna allow for utunbu
http://releases.ubuntu.com/13.04/wubi.exe
...
Thanks, it works.
For wubi I set C:\ and it works too (D:\ did not work).
I even make some undervolt and overclock with atitweak.
Then I lost attention and it killed my PSU with overheated GPU :/.

Does this miner can stop hashing on GPU when overheated?
Does it work with solo mining?
Yes, it makes pauses in mining when your card is overheat. You need adl3 python module installed for that, and change default 95C to someting more safe with '--cutoff-temp' switch.
Pernicio
Newbie
*
Offline Offline

Activity: 9

https://hashflare.io/r/E10633A3


View Profile WWW
December 29, 2013, 05:20:53 PM
 #410

Quote
Quote

As you can see, it's identical with the pip2.log. Could it be then, that there is even more programs that don't realize that their requirements have already being met? Shocked As in, program not registering correctly for some reason, even when there is no visible errors during the installation? Ghost in the shell? Grin

That happens sometimes, if you have some stuff installed via pip and some via apt-get and have both vanilla (non-debug) and debug versions of python. That's because of different versions of python requires related versions of packages. 

Hmm, tried to check if I had any debug version of those, but didn't have those - just the normal ones. Could pytools conflict with setuptools? As installing pyopencl installs both pytools and numpy by default, it seems Shocked At least when done through the software center.

Unlikelly, that's quite different packages, and currently I have both of them.

Now I see that the issue is here:
Code:
src/wrapper/wrap_cl.hpp:27:19: fatal error: CL/cl.h: No such file or directory

Might be wrong path to AMD_APP_SDK, check all related stuff.
https://bitcointalk.org/index.php?topic=57267.0
http://wiki.tiker.net/OpenCLHowTo

It may indeed be the wrong path to AMD APP SDK, but since CGminer works correctly and the poclbm-skc miner has problems identifying pyopencl, the problem might be either at pyopencl or poclbm-skc it self. I'll try if I can manually set the location of AMD APP SDK for pyopencl and/or to poclbm-skc and post results here. I don't really know how this is done, so any advices are welcome, while I try looking for them by my self Cheesy

<a href="https://hashflare.io/r/E10633A3">
Pernicio
Newbie
*
Offline Offline

Activity: 9

https://hashflare.io/r/E10633A3


View Profile WWW
December 30, 2013, 01:14:42 AM
 #411

Quote
Quote

As you can see, it's identical with the pip2.log. Could it be then, that there is even more programs that don't realize that their requirements have already being met? Shocked As in, program not registering correctly for some reason, even when there is no visible errors during the installation? Ghost in the shell? Grin

That happens sometimes, if you have some stuff installed via pip and some via apt-get and have both vanilla (non-debug) and debug versions of python. That's because of different versions of python requires related versions of packages.  

Hmm, tried to check if I had any debug version of those, but didn't have those - just the normal ones. Could pytools conflict with setuptools? As installing pyopencl installs both pytools and numpy by default, it seems Shocked At least when done through the software center.

Unlikelly, that's quite different packages, and currently I have both of them.

Now I see that the issue is here:
Code:
src/wrapper/wrap_cl.hpp:27:19: fatal error: CL/cl.h: No such file or directory

Might be wrong path to AMD_APP_SDK, check all related stuff.
https://bitcointalk.org/index.php?topic=57267.0
http://wiki.tiker.net/OpenCLHowTo

BTW, any idea how to manually instruct the location of pyopencl to poclbm-skc? Or is the principle the same as in the instructions you referred to me? Shocked

Edit:
Got it to work by separately installing the latest (2.9 at the time of writing) AMD APP SDK. Thank you for all that tried to help me Smiley
Any ideas for the most optimal settings for Radeon HD 5770?

<a href="https://hashflare.io/r/E10633A3">
reorder
Sr. Member
****
Offline Offline

Activity: 462


View Profile
December 30, 2013, 01:15:04 PM
 #412

Quote
Quote

As you can see, it's identical with the pip2.log. Could it be then, that there is even more programs that don't realize that their requirements have already being met? Shocked As in, program not registering correctly for some reason, even when there is no visible errors during the installation? Ghost in the shell? Grin

That happens sometimes, if you have some stuff installed via pip and some via apt-get and have both vanilla (non-debug) and debug versions of python. That's because of different versions of python requires related versions of packages.  

Hmm, tried to check if I had any debug version of those, but didn't have those - just the normal ones. Could pytools conflict with setuptools? As installing pyopencl installs both pytools and numpy by default, it seems Shocked At least when done through the software center.

Unlikelly, that's quite different packages, and currently I have both of them.

Now I see that the issue is here:
Code:
src/wrapper/wrap_cl.hpp:27:19: fatal error: CL/cl.h: No such file or directory

Might be wrong path to AMD_APP_SDK, check all related stuff.
https://bitcointalk.org/index.php?topic=57267.0
http://wiki.tiker.net/OpenCLHowTo

BTW, any idea how to manually instruct the location of pyopencl to poclbm-skc? Or is the principle the same as in the instructions you referred to me? Shocked

Edit:
Got it to work by separately installing the latest (2.9 at the time of writing) AMD APP SDK. Thank you for all that tried to help me Smiley
Any ideas for the most optimal settings for Radeon HD 5770?
Just try to run python as interpreter in the command line and issue 'import pyopencl' command there. If you get ImportError message, then it is not set up properly for your default python installation, if there is no output, poclbm should work too.
MethMatician
Full Member
***
Offline Offline

Activity: 132


View Profile
December 30, 2013, 07:25:34 PM
 #413

hi guys.. perhapes my last message got lost in the gpu instructions but i would love 2 know if anyone (accept for madjihad) has an interest in an easy to check stats/updates app cause the poll http://skeincoin.wordpress.com/ had 7 votes and i got 1 suggestion from madjihad - an android wallet for Skein.. which would be awesome but would require lots of time and do we really trust the random number generator? :p

for suggestions pls pm me or post something up here.. would appreciate that
gielbier
Sr. Member
****
Offline Offline

Activity: 450



View Profile
December 30, 2013, 08:53:10 PM
 #414

hi guys.. perhapes my last message got lost in the gpu instructions but i would love 2 know if anyone (accept for madjihad) has an interest in an easy to check stats/updates app cause the poll http://skeincoin.wordpress.com/ had 7 votes and i got 1 suggestion from madjihad - an android wallet for Skein.. which would be awesome but would require lots of time and do we really trust the random number generator? :p

for suggestions pls pm me or post something up here.. would appreciate that
If it's for android, please send me a preview apk please. Cheesy

           ▄▄███████▄▄
        ▄███▀▀
▄▄▄▄    ▀▄
     ▄▄█████████████▄▄  ▀▄
  ▄▀▀██▀           ▀▀██▄▄▀▄
▄▀  ██                 ▀██
  ██       ▀▀█▀▀         █
█▀        █ █ █        ▄█▀▄
▀▄         █ █ █       ▄█  █
 ██         █▄▄▄█      ▄█  ▄▀
  ██▄                ▄█▀  ▄▀
  ▀▄▀██▄▄          ▄█▀  ▄▀
   ▀▄ ▀▀███▄▄▄▄▄▄█████▀▀
     ▀▀▄▄▄▄▄▄▀▀▀▀▀▀▀
UTRUST▀████████▄
  ▀███████▄
    ▀██████▄
      ▀██████
       ▀█████
        ▀████▄
         █████
          ▀███
           ███
           ▀██
            ██
             █
●  Download WHITEPAPER  ●
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬ ▼ ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
facebook      twitter      slack
▀████████▄
  ▀███████▄
    ▀██████▄
      ▀██████
       ▀█████
        ▀████▄
         █████
          ▀███
           ███
           ▀██
            ██
             █
MethMatician
Full Member
***
Offline Offline

Activity: 132


View Profile
December 30, 2013, 10:50:37 PM
 #415

dont judge me to hard ok.. made it in between trainrides :p
escobol
Member
**
Offline Offline

Activity: 79


View Profile
December 31, 2013, 10:46:38 AM
 #416

WTS 5k, pm with offer
Dosmas
Full Member
***
Offline Offline

Activity: 153


View Profile
January 01, 2014, 03:13:16 PM
 #417

Used https://bitcointalk.org/index.php?topic=322828.msg4042222#msg4042222
Compiled skeinhash.so in mingw, but got message that key fPIC ignored as all code positionally independed.
and now when try to run on 7950, win 8.1 x64, 4gb ram, catalist 13.11 beta 9.5, it tell me that and close:

Code:
28/12/2013 00:50:51, started OpenCL miner on platform 1, device 0 (Tahiti)
 28/12/2013 00:50:51, Setting server (melnikalex.1 @ skc.coinmine.pl:6400)
skc.coinmine.pl:6400 28/12/2013 00:50:51, Compiler defines:  -DOUTPUT_SIZE=256 -DOUTPUT_MASK=255 -DENDIAN_LITTLE=1 -DGPU_AMD=1 -IC:\Skein\poclbm-skc
skc.coinmine.pl:6400 28/12/2013 00:50:51, Error loading compiled kernel: 60078364a528c8e14b098ad0e9403ceb.elf
skc.coinmine.pl:6400 28/12/2013 00:50:51, Recompiling kernel ...
skc.coinmine.pl:6400 28/12/2013 00:50:51, Setting new difficulty: 0.0625

please help to make it work
maybe my skeinhash.so is not as good as yours, can someone give the link to download it?
who make it work, please tell your os/catalist version/amd sdk ?
thanks

That is strange. Try this one skeinhash.so http://www.megafileupload.com/en/file/482956/skeinhash-so.html It was compiled under Windows 7 x64, might resolve you issue. On Windows I had issue with amdocl.dll it crashed during run and I had to replace it with older version (dll version: 10.0.923.1 and product version: OpenCL 1.1 AMD-APP (923.1)) you can download it here: http://www.filedropper.com/amdocl64 but make a backup of original file (or files if you have systerm32 and syswow64 folders).


I have used the skeinhash.so but when i run it i get:

Windowserror:error126. The specified module could not be found. Even with inserting the before mentioned amdocl64.dll I keep getting this. I have inserted the file in both the system32 and syswow64 dir.

This should be correct right?
3dcgminer
Full Member
***
Offline Offline

Activity: 138


View Profile
January 01, 2014, 03:54:31 PM
 #418

Cannot get the GPU miner to work either, trying on Win 7 64 bit and latest AMD 13.12 driver.

Using Python 2.7 64 bit I get "WindowsError Error 21 device not ready".
Also installed: ipython, Mako, numpy 1.8 MKL, pyopencl, pytools from http://www.lfd.uci.edu/~gohlke/pythonlibs/

Using the skeinhash.so from http://www.megafileupload.com/en/file/482956/skeinhash-so.html
Thanks madjihad.

Trying Python 2.7 32 bit again, also failed but that got further than the 64 bit install.

Can't find an "amdocl64.dll" to replace, they are called "amdocl.dll" now.  

Using bat file:
C:\python27\python.exe C:\skein\poclbm-skc\poclbm.py http://worker.1:x@skc.coinmine.pl:6400 -d 0

Why is this so frickin' more difficult than the compiled bitcoin python miner?
https://en.bitcoin.it/wiki/Poclbm
3dcgminer
Full Member
***
Offline Offline

Activity: 138


View Profile
January 01, 2014, 04:15:53 PM
 #419

Getting these error codes after trying Python 2.7 32 bit, all other setting as above:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

c:\skein\poclbm-skc>SKEIN_POOL1.bat

c:\skein\poclbm-skc>C:\python27\python.exe C:\skein\poclbm-skc\poclbm.py http://
worker.1:x@skc.coinmine.pl:6400 -d 0

WARNING: no adl3 module found (github.com/mjmvisser/adl3), temperature control i
s disabled


 01/01/2014 17:11:28, started OpenCL miner on platform 0, device 0 (Tahiti)

 01/01/2014 17:11:28, Setting server (worker.1 @ skc.coinmine.pl:6400)

skc.coinmine.pl:6400 01/01/2014 17:11:28, Compiler defines:  -DOUTPUT_SIZE=256 -
DOUTPUT_MASK=255 -DENDIAN_LITTLE=1 -DGPU_AMD=1 -Ic:\skein\poclbm-skc

skc.coinmine.pl:6400 01/01/2014 17:11:28, Error loading compiled kernel: 532ed20
3a8be7d1bddcebf7c43f05f49.elf

skc.coinmine.pl:6400 01/01/2014 17:11:28, Recompiling kernel ...

skc.coinmine.pl:6400 01/01/2014 17:11:28, checking for stratum...
Exception in thread Thread-1:
Traceback (most recent call last):
  File "C:\python27\lib\threading.py", line 810, in __bootstrap_inner
    self.run()
  File "C:\python27\lib\threading.py", line 763, in run
    self.__target(*self.__args, **self.__kwargs)
  File "C:\skein\poclbm-skc\OpenCLMiner.py", line 176, in mining_thread
    self.load_kernel()
  File "C:\skein\poclbm-skc\OpenCLMiner.py", line 323, in load_kernel
    self.program = cl.Program(self.context, kernel).build(self.defines)
  File "C:\python27\lib\site-packages\pyopencl\__init__.py", line 141, in build
    options = options + ["-I", _find_pyopencl_include_path()]
  File "C:\python27\lib\site-packages\pyopencl\__init__.py", line 722, in _find_
pyopencl_include_path
    from pkg_resources import Requirement, resource_filename
ImportError: No module named pkg_resources


skc.coinmine.pl:6400 01/01/2014 17:11:28, no response to getwork, using as strat
um

skc.coinmine.pl:6400 01/01/2014 17:11:28, Setting new difficulty: 0.0625

/EDIT: Tried with numpy MKL 1.72 instead of 1.8, same error code as above.
reorder
Sr. Member
****
Offline Offline

Activity: 462


View Profile
January 01, 2014, 04:26:13 PM
 #420


Why is this so frickin' more difficult than the compiled bitcoin python miner?
https://en.bitcoin.it/wiki/Poclbm

Python has sha256 bundled, but not skein hash. I suggest that somebody steps in and replaces my quickhack dll with pure python implementation from http://pythonhosted.org/pyskein/
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 [21] 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 ... 75 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!