Bitcoin Forum
September 25, 2018, 12:38:16 PM *
News: ♦♦ New info! Bitcoin Core users absolutely must upgrade to previously-announced 0.16.3 [Torrent]. All Bitcoin users should temporarily trust confirmations slightly less. More info.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Rapsberry Pi 1 controlling an Avalon AUC3  (Read 44 times)
ccgllc
Copper Member
Member
**
Offline Offline

Activity: 266
Merit: 36

Math doesn't care what you believe.


View Profile
April 03, 2018, 01:45:19 AM
 #1

Hi all.  Received my first batch of Avalons today.  I went to set up (3) strings:  String 1 was headed by a pi 1 with a single 821 on it.  String 2 was headed by another pi 1 with (5) 841s on it.  String 3 was headed by a Pi 3 with (5) 841s on it.  Once I found real data cables to use with the AUC3s (and found out just how many charging only cables I have!), the Pi 3 unit came up just fine.

The (2) Pi 1 units had AUC3's that were mostly blue but slow blinking green.  e.g.  They were more-or-less always in setup mode and resetting as soon as they came ready.  The Avalons behind those two Pis remained idle (yellow light).

I moved the AUC3s from those Pis over to the Pi 3 and confirmed the AUC3s were fine, the cables were fine, and that the miners were fine.  Currently running all (11) Avalons off that single Pi 3.

Curious if anyone knows what the problem was driving the AUC3s from the Pi 1s?  I thought perhaps insufficient power supplies to drive both the Pi 1 and the AUC3, so tried a 2.4 amp one - but had no change.

Any other ideas?

I mine bitcoin for a living, and I mine at Kano.is!
Blokforge Affiliate:  https://blokforge.com/?ref=21
Linux since 0.96 kernel and Slackware distributions on (4) floppies...
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1537879096
Hero Member
*
Offline Offline

Posts: 1537879096

View Profile Personal Message (Offline)

Ignore
1537879096
Reply with quote  #2

1537879096
Report to moderator
NotFuzzyWarm
Legendary
*
Offline Offline

Activity: 1568
Merit: 1099


Evil beware: We have waffles!


View Profile
April 03, 2018, 12:59:05 PM
 #2

Did you load the correct firmware onto the Pi-1? RasPi 1, 2, & 3B all use different firmware you can get from the Canaan site.

For bitcoin to succeed the community must police itself - Joshua Zipkin aka Joshua Alexander leaked AMT A1 miner skype chats
How a miner mfgr SHOULD operate: HaggsFIN trip to Canaan My info useful? Donations welcome! 1Fuzzyk398kDWVjuC5qPX5v6CjSkvbgAbd
-Support Sidehacks miner development. Donations to:   1BURGERAXHH6Yi6LRybRJK7ybEm5m5HwTr
ccgllc
Copper Member
Member
**
Offline Offline

Activity: 266
Merit: 36

Math doesn't care what you believe.


View Profile
April 03, 2018, 04:09:56 PM
 #3

Yes.  The correct firmware was loaded.  That said, I have some time today, so will try that again.

Update:  Thanks for the sanity check.  Reflashed the SDHC cards and both came up fine.  Not sure how I got those flashed with the wrong version... its not like a full size SDHC card would fit in the Pi3, but somehow I manged.

I mine bitcoin for a living, and I mine at Kano.is!
Blokforge Affiliate:  https://blokforge.com/?ref=21
Linux since 0.96 kernel and Slackware distributions on (4) floppies...
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!