Bitcoin Forum
March 25, 2017, 11:46:17 AM *
News: Latest stable version of Bitcoin Core: 0.14.0  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Flexible mining proxy (segfault or MSG: No enabled pools responded to the work)  (Read 775 times)
weebette
Newbie
*
Offline Offline

Activity: 2


View Profile
July 28, 2011, 01:43:47 PM
 #1

Hello!

I try to setup the flexible mining proxy and I'm always getting the message : MSG: No enabled pools responded to the work request.

I use the latest git version (git://github.com/cdhowie/Bitcoin-mining-proxy.git)

I use php 5.3.2, apache 2.2 and mysql 5.1 (on centos 6 x86_64 every software is from the repository.)

I can access to the admin page and add the pools and workers (the username password of the worker is working)

I tried to add trailing "/" after the pool url... nothing changed...

In my php.ini config file, the setting (looking in phpinfo() in the same directory of the proxy)
- allow_url_fopen is On for bot local value and master value.  
- magic_quotes_gpc is Off for both local and master value.

In different forum this error is frequent, but the way to solve this seems to configure the allow_url_fopen and magic_quotes_gpc...

Using wireshark, I CANNOT see the proxy trying to query the pools.

in my error_log of apache I find that.  I tried to set the http_response_header but nothing has changed.  I can see the proxy loop 3 times since I

Code:
[Thu Jul 28 09:30:42 2011] [error] [client 192.168.0.XXX] PHP Notice:  Undefined variable: http_response_header in common.inc.php on line 125
[Thu Jul 28 09:30:42 2011] [error] [client 192.168.0.XXX] PHP Notice:  Undefined variable: http_response_header in common.inc.php on line 125
[Thu Jul 28 09:30:42 2011] [error] [client 192.168.0.XXX] PHP Notice:  Undefined variable: http_response_header in common.inc.php on line 125

note: I don't understand why, but this morning I can not connect to the proxy (locally using localhost 127.0.0.1 or it's IP address), I get seg fault ... yesterday evening I got the message : No enabled pools responded to the work request.

Help would be appreciated :-)

Thank you!
1490442377
Hero Member
*
Offline Offline

Posts: 1490442377

View Profile Personal Message (Offline)

Ignore
1490442377
Reply with quote  #2

1490442377
Report to moderator
1490442377
Hero Member
*
Offline Offline

Posts: 1490442377

View Profile Personal Message (Offline)

Ignore
1490442377
Reply with quote  #2

1490442377
Report to moderator
According to NIST and ECRYPT II, the cryptographic algorithms used in Bitcoin are expected to be strong until at least 2030. (After that, it will not be too difficult to transition to different algorithms.)
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1490442377
Hero Member
*
Offline Offline

Posts: 1490442377

View Profile Personal Message (Offline)

Ignore
1490442377
Reply with quote  #2

1490442377
Report to moderator
weebette
Newbie
*
Offline Offline

Activity: 2


View Profile
July 28, 2011, 06:43:09 PM
 #2

MUST DISABLE SELINUX!!!   and don't add any trailing '/' after the port...
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!